https://www.duolingo.com/Liatai

Stuck and unable to complete lessons or practice

Hey there, fellow language learners... This has been really frustrating, since I want to keep learning French, but the system won't let me.

I can answer questions just fine, but when I get to the end of the lesson and click Continue, the little loading circle appears next to the Duolingo logo in the upper left corner of the screen... and stays there. It keeps circling and circling, never progressing to the "lesson completed" or "practice completed" screen. I've tried clearing my cache, refreshing the page, trying it in Chrome instead of my usual Firefox... same thing. Perpetual loading, never completing.

I even let it go for two hours once, and nothing happened. I'm on satellite internet (Hughesnet), but I haven't noticed any outages while I was taking the lessons.

This has been going on for five days now, and I'm at the end of my rope. I'll be hearing "les hommes sont riches" and "nous sommes calmes" in my dreams at this rate! Help! ^^;

Is there anything I can do? I really want to keep learning. :(

November 10, 2013

5 Comments


https://www.duolingo.com/Luis

Are you behind a proxy or an otherwise non-standard Internet connection (such as satellite)?

November 10, 2013

https://www.duolingo.com/Liatai

I don't know about a proxy, but I am on satellite internet (Hughesnet). I live in the middle of nowhere, so it's the only thing available. ^^;

November 10, 2013

https://www.duolingo.com/Luis

Unfortunately, Duolingo doesn't work well with satellite connections :( If you have a 3g phone, you can try using the app.

November 10, 2013

https://www.duolingo.com/Liatai

Oh, no! :( I don't. Darn it... it was working just fine the first day I used it.

Thank you anyway. I guess I'll have to wait until I go on vacation to keep learning, or try the local libraries. In the meantime, I suppose I'll practice and get the lessons I've already completed down solid, even if the system doesn't recognize my progress! :3

November 10, 2013

https://www.duolingo.com/Liatai

Hi there, fellow language learners! I think I just found a solution, and thought I'd pass it on to anyone else who's on Hughesnet and looking to learn a language through Duolingo. :3

While trying to troubleshoot a problem with another website, we disabled the Web Acceleration option on our Hughesnet system controls. Voila, once Web Acceleration was disabled, Duolingo worked fine, as well as the other website which was giving us problems.

I'm going to go complete more French lessons now! Whee! :D Best of luck to everyone else out there -- have fun learning! Bonne chance!

November 13, 2013
Learn a language in just 5 minutes a day. For free.