https://www.duolingo.com/profile/pnehls

Freezing at the end of Timed Lesson

Has anyone else had issues with the lesson freezing when time runs out? It's happened to me about 6 times now.

November 27, 2013

13 Comments


https://www.duolingo.com/profile/mptmpt

I have seen this happening if I hit the enter with exactly 0 sec on the timer (just happened to me 5 minutes ago). I have seen it totally about 5 or 10 times over the past few months, and the most annoying thing is that you do not get the points, so when I am doing a quick timed session to save my streak just before midnight, I always stop with a few seconds left on the timer, to make sure I will get the points.

November 27, 2013

https://www.duolingo.com/profile/AdoElias

Not exactly my problem but I am using Safari and Lesson Practise (without timer) froze on LAST question after answering and hitting "Enter" - it happened at least 3-4 times and it was really unfortunate and frustrating because I had to close the browser and I lost all the coins of course.

November 27, 2013

https://www.duolingo.com/profile/kristinemc

Just tested again and we can't replicate this. Has your internet connection changed at all recently? Are you behind a proxy?

November 27, 2013

https://www.duolingo.com/profile/AdoElias

No I am not. But luckily it hasn't happened for few weeks, so maybe it's not a problem anymore. I will let you know if it occurs again.

November 27, 2013

https://www.duolingo.com/profile/kristinemc

I couldn't replicate this in Chrome, but could you give me some more information. What browser are you using?

November 27, 2013

https://www.duolingo.com/profile/mptmpt

I have seen this happening in chrome over the past few months in whatever is the latest version at the time. I have also seen it in firefox, and in chromium. I think there is a dead time interval between 0 sec on the timer, and the actual page refresh, and it happens if you hit the enter (or continue button) within that interval. The first time I observed it was when I was "greedy" and wanted to get the last point for a question I had finish exactly when the timer was at zero, and "Enter" didn't respond, but the check button was still green and I had enough time to move the mouse, and click it. But now it happens even with "Enter".

November 27, 2013

https://www.duolingo.com/profile/pnehls

mptmpt described a similar situation to mine. I am using chrome, it seems to happen when I am trying to beat the buzzer, when i finish a sentence close to when it hits zero...

November 28, 2013

https://www.duolingo.com/profile/kultarr

I am using Chrome and get this lock up behavior as well. If I hit enter while the graphic is blinking "0" just at the wrong time, the blinking "0" will continue forever. I think it may also be with the text entry dialogue type questions. You can enter a small book into the dialogue at that point and click check and continue to no effect. And, of course, your points are simply lost. It just happened to me 3 times in a row.

November 30, 2013

https://www.duolingo.com/profile/buffalump21

this has just happened to me again, at least twice in the last 20 minutes or so....so infuriating... I use Mozilla...please fix it, i have just lost 4 coins and i CAN'T go to bed till I get another 15!!!!!

November 29, 2013

https://www.duolingo.com/profile/H-3000

I have the same problem with firefox (duolingo whitelistet in AdBlock) running OSX. Experienced the problem on two separate machines. The internet connection was stable.

Before I found this thread, I opened this one, to collect different reports on that bug: http://www.duolingo.com/comment/1219051

When I encounter the bug, the behavior of the text-box changes. When I hit enter after the freeze, it produces paragraphs, which is disabled during the normal lesson. is that a clou?

December 4, 2013

https://www.duolingo.com/profile/Kalquimarke

Duolingo freezes everytime I use it on pc web browsers (firefox, chrome). If I work in my cellphone it works all right. I have emailed for a solution since i started on Duolingo but the problem still exist.

December 10, 2013

https://www.duolingo.com/profile/sarahlynn319

This just started today on my Android app. It froze 3 or 4 times at the end of a lesson. I tried forcing the app to close and restarting the phone. Restarting the phone seems to have fixed it for now.

April 27, 2015

https://www.duolingo.com/profile/MatthewCaffrey

This happens to me periodically in timed lessons. Sometimes it freezes on the very last lesson. Sometimes it freezes if I try to "report" a question that I think is incorrect. When the freeze happens, the time keeps running, so I just have to wait it out for it to get to zero.

It happens to me about 1 in 20 lessons.

September 2, 2019
Learn a language in just 5 minutes a day. For free.