Duolingo is the most popular way to learn languages in the world. Best of all, it's 100% free!

https://www.duolingo.com/AlexBorealisMay

duolingo asks me to speak in chrome (but doesn't hear) but doesn't in firefox

The mic doesn't work in chrome (it can never hear me). I want to test to see if it works in firefox as I've been told it works in that browser but duolingo never asks me to speak when I use firefox. Any ideas? Mac OSX Yosemite, up to date browsers.

2 years ago

9 Comments


https://www.duolingo.com/Xneb
Xneb
  • 21
  • 20
  • 13
  • 11
  • 7

I can't confirm that this is true but, for some languages that were built in the incubator, the microphone exercises are only available on Chrome (this is true for Danish and Norwegian definitely, and a few others if I recall correctly) and so this might also be the case with Russian

2 years ago

https://www.duolingo.com/AlexBorealisMay

Oh wow, this sounds probable. I'll look into why the mic fails in Chrome, in that case. Thanks!

2 years ago

https://www.duolingo.com/wstockall
wstockallPlus
  • 25
  • 23
  • 20
  • 17
  • 3
  • 3
  • 1640

I think Firefox still requires that you have Flash installed and enabled for the mic to work. Have you checked that?

2 years ago

https://www.duolingo.com/AlexBorealisMay

Flash! Good grief. I'll check, thanks!

2 years ago

https://www.duolingo.com/psionpete
psionpete
  • 25
  • 21
  • 21
  • 19
  • 19
  • 6
  • 5
  • 4
  • 3
  • 1703

It could be the mic is turned off in your duo settings. Select the down arrow to the right of your profile icon and the select settings. You will see an on/off switch next to microphone. Make sure it is ON.

2 years ago

https://www.duolingo.com/A_User
A_User
  • 23
  • 11
  • 9
  • 7
  • 7
  • 7
  • 6
  • 4
  • 3
  • 3
  • 2
  • 2
  • 2
  • 2

Wouldn't it be off for all browsers, or does each browser have different settings?

2 years ago

https://www.duolingo.com/AlexBorealisMay

Thanks. I checked it was on before posting - and it's definitely on in the settings because I get asked to speak into it in Chrome but not in Firefox.

2 years ago

https://www.duolingo.com/EoghanBostock

Maybe try and restart your computer? And if all else fails and you've tried everything, go to the apple store and they might be able to help. :)

2 years ago

https://www.duolingo.com/AlexBorealisMay

Thanks, I really don't think this is a hardware issue, though.

2 years ago