1. Forum
  2. >
  3. Topic: Troubleshooting
  4. >
  5. New levels don't unlock!!


New levels don't unlock!!

Hello, I am a Duolingo user from Turkey. I am trying to practise my french skills but I can't unlock new levels. There are same comments in Turkish Google Play Duolingo page. I hope you fix it soon.

Thank you!

December 1, 2013



Hi. Thanks for letting us know. We're trying to diagnose the problem. I'm wondering if you can help us with a few things:

  1. Which platform does this happen in? Android? Web? Both? It would be useful if you tried both Web and Android and let us know.

  2. What kind of Internet connection do you have in the platform where this happens?



Dear Luis

This seems to be an issue with ALL users who use an Android phone with Turkish system language.

The issue seems to be solved when the system language was set to English, but as you can imagine that is not practical for everyone.

The issue is discussed a lot in Google Play Turkish, and there are also several posts here in the Troubleshooting section by other Turkish users (They are just not aware that issue is due to Turkish). Somebody just informed us on our Turkish-English discussion about this, and it would be great if this is somehow solved at least before our Turkish-English course is released ;) Here are some other posts by turkish users: http://www.duolingo.com/comment/1185820 http://www.duolingo.com/comment/1194296 Thanks!


Thank you. This is super useful. We will fix soon.


See also: http://www.duolingo.com/comment/1132464

On Android phones, if the system language is set to Turkish, it is not possible to advance to the next skill.


Someone else gave us more detailed feedback about this problem on a discussion we had opened. Apparently it happens when the language of the phone itself is Turkish, and removing the app, changing the phone's language to English, and then reinstalling solves the problem.

This is the guy with the feedback: kahramanmc http://www.duolingo.com/comment/1126587$from_email=comment&comment_id=1213092 he may oblige with screenshots if you need em.


Thank you first of all. I have tried to practice only on my mobile so far.

It is android 4.2.1.

I am on 3G and fiber internet.


I also tried one of the old version of duolingo.(1.3.4 i supose) It still has the same problem.



  1. The problem only occurs in Android mobile app. Web and ios apps are fine.
  2. It is not related to the internet connection, it happens both on 3g and Wi-fi.

By the way there is a workaround solution for this problem, i think the problem is with system language. Switching system language from Turkish to English solves the the problem. Steps: 1. Delete the app, 2. Restart the phone, 3. Switch system language from Turkish to English, 4. Re-install the app.

Thanks in advance.


Son update'i telefonunuza yukledikten sonra hala bu sorunu yasiyor musunuz?


Problem çözülmüştür.


And Web doesn't has that issue! Please help!


Dil silmek istiyorum ama silemiyorum nasıl yapacağım uygulamayı silip geri yükledim olmadı.

Learn a language in just 5 minutes a day. For free.