https://www.duolingo.com/MisterLaz

No sound in web browser -- found the problem -- someone in charge please fix

So a lot of people have issues with sound not working in the various languages. I'm trying to go through the German course, and everything works fine on my Android device, but when I switch to my computer, half of the words don't play. When I click on the word list, select a word and hit play, most of the time nothing happens. Words like "Junge" and "Wasser" do not play, but "der" and "ich" do.

Unfortunately, the solution to this is nothing that the end-user can do.

I did some investigation, and apparently the sound file the web site is trying to access gives us a forbidden response:

GET https://d7mj4aqfscim2.cloudfront.net/tts/de/token/Junge 403 (Forbidden)

so after some playing around, it's because the URL is invalid. It's because the word, Junge, has a capital 'J' in it. If you change the URL to a lower-case 'j', the sound plays just fine.

Here are some examples:
Broken: https://d7mj4aqfscim2.cloudfront.net/tts/de/token/Junge
Correct: https://d7mj4aqfscim2.cloudfront.net/tts/de/token/junge
Broken: https://d7mj4aqfscim2.cloudfront.net/tts/de/token/Wasser
Correct: https://d7mj4aqfscim2.cloudfront.net/tts/de/token/wasser
Broken: https://d7mj4aqfscim2.cloudfront.net/tts/de/token/Brot
Correct: https://d7mj4aqfscim2.cloudfront.net/tts/de/token/brot

This requires a change in the duolingo web code to either auto-lowercase the sound URLs in the Javascript PlayTTS() function, or the sound files need to be re-uploaded with the apprioate case on the filenames.

This is a HUGE oversight by the Duolingo team, and creates a severe problem for people attempting to learn a new language.

December 16, 2015

3 Comments


https://www.duolingo.com/BadBanker

I am now also unable to play sound in the exercises, although the sound is ok following the Correct links in your post.

Is there anything else I can do? The speakers are fine with other sound files I have on my computer

December 17, 2015

https://www.duolingo.com/sheri436151

I have the same problem.....only it is sporadically, not consistently. Right now I am fuming for having spent 25 lingots for the spanish "test", only to have the first question not have sound. This is happening so frequently it is a quality issue.

December 22, 2015

https://www.duolingo.com/HappyEvilSlosh

Good job! I wonder if that's related to why the IVONA voices don't always work in my regular browser (xombrero)...

December 16, 2015
Learn a language in just 5 minutes a day. For free.