https://www.duolingo.com/profile/Xiuhtecuhtli

Bug: Multiple choice questions acting funny

http://imgur.com/WiniCUq This just happened. (It was a multiple choice question, I selected 1 and 2, and Duo thinks only option 1 is correct.)

Obviously this question was marked as wrong when it should have been correct ("tu eres" is no different from "eres"). However, there's also another issue: while I can see that it was marked wrong in the lesson summary at the end, it did NOT come up as wrong when I submitted the question (otherwise I would have clicked "my answer should be accepted" and reported it). I finished the practice session thinking I had 20/20, and only realized at the end that I'd gotten a question "wrong".

The same thing happened to me yesterday (a different multiple choice question where I selected two options; I was initially marked correct, but it displayed as an error in the lesson review). At the time I assumed I was mistaken, but now it's happened two days in a row, so clearly there's an issue here.

January 7, 2016

23 Comments


https://www.duolingo.com/profile/Lrtward

I don't have any answers for you, but I'd suggest moving this to the "Troubleshooting" forum. Just edit the original post and select the forum from the drop-down menu. The troubleshooting forums are looked at by technical staff. Hopefully they can help you or request more information to help figure out what's going on.

January 7, 2016

https://www.duolingo.com/profile/Xiuhtecuhtli

Thank you. I haven't posted in ages but it seems like the forums have gotten really confusing to navigate - I didn't even know there was a troubleshooting forum anymore!

January 7, 2016

https://www.duolingo.com/profile/fat.k1tty

I have the same thing. http://imgur.com/DYeqYzy The response is marked correct during the 'Timed Practice' exercise, but at the end of the lesson I am short 1 point, and when I review the lesson the "error" is shown then.

January 7, 2016

https://www.duolingo.com/profile/lauren

Hi we're aware of this and working on a fix! Thank you for all the reports : )

January 25, 2016

https://www.duolingo.com/profile/remoonline

This issue is still present even after 3 months. I would have thought fixing this would have a somewhat higher priority since for new learners, it seems to convey incorrect learning.

May 7, 2016

https://www.duolingo.com/profile/jrikhal

after 3 months

Note: It has at least 8 months.

May 7, 2016

https://www.duolingo.com/profile/Knocksedan

I think it only happens on "Timed Practice", which probably limits the impact that it has on new learners. I haven't had this problem in regular practice, only in Timed Practice.

That doesn't excuse the fact that the bug seems to have been ignored for so long, but, in general, users doing Timed Practice are a bit more experienced with the language, and slightly less likely to be misled.

May 7, 2016

https://www.duolingo.com/profile/Tattamin

This same problem already occurred a few weeks ago. Then the multiple choice questions disappeared for a while until it was solved. It's really strange to see the same problem popping up again now.

January 7, 2016

https://www.duolingo.com/profile/Ryuusuke

Bug is still there.

March 30, 2016

https://www.duolingo.com/profile/moox

Still there for me.

November 15, 2016

https://www.duolingo.com/profile/Knocksedan

I think it's a question of "it's back again", rather than "It's still there". I noticed it the other day for the first time in ages.

November 15, 2016

https://www.duolingo.com/profile/moox

You're probably right, as I've only just started noticing it. Having said that, it's intermittent - I got another one which wasn't marked wrong just now.

November 15, 2016

https://www.duolingo.com/profile/GoColts6

I don't know what's wrong with the system, but I can tell you that your answer is correct. And maybe you should move this to the troubleshooting forum. :)

January 7, 2016

https://www.duolingo.com/profile/Runnerbob

I saw a similar thing with multiple choice several times .

January 8, 2016

https://www.duolingo.com/profile/lauren

Are you able to reproduce this and send a screenshot?

January 8, 2016

https://www.duolingo.com/profile/remoonline

The error still seems to be around as I got it again today.

But, then I retried the lesson to see what happens if I do an incorrect selection and got an error as expected.

But, funnily enough, at the end when I looked up the review, it was marked correct.

January 16, 2016

https://www.duolingo.com/profile/remoonline

I had noticed this issue a couple of months back and reported.
https://www.duolingo.com/comment/11110040

It had stopped sometime back. But I again found another instance today.

January 10, 2016

https://www.duolingo.com/profile/Multitaal

This problem has existed for so many months now.

Screenshot from today

January 24, 2016

https://www.duolingo.com/profile/Xiuhtecuhtli

Hi Lauren, there's a screenshot in the OP (imgur link).

If it happens again I'll take another. But the practice I did today didn't have any multiple choice questions.

January 9, 2016

https://www.duolingo.com/profile/Multitaal

Is Duolingo working on this? Screen shot from just now.

January 30, 2016

https://www.duolingo.com/profile/Multitaal

This problem is still not solved.
My latest screenshots.


July 4, 2016

https://www.duolingo.com/profile/Xiuhtecuhtli

It's happened again - I hope that posting a new comment will bump the topic so the mods will notice?? http://imgur.com/VVv1jPU

January 22, 2016

https://www.duolingo.com/profile/Knocksedan

I've encountered this bug repeatedly in the last couple of weeks, doing Timed Practice.

March 12, 2016
Learn a language in just 5 minutes a day. For free.