https://www.duolingo.com/MultiLinguAlex

Annoying bug: Some language icons are suddenly missing in my discussion posts.

I deleted some low-level language progress (like level 1 Catalan from Spanish) and the language icons of my 4 most learned languages are now missing. For example, I did not delete my French for German speakers course progress, everything is still there, but the language icon is now missing in the forums. My current correct language levels are:

.

I learn

  • French, English and Spanish from German and
  • German, Esperanto, Dutch, Norwegian and Swedish from English.

This is now solely correctly shown after I directly post a new discussion. When I open a new discussion or answer other users' posts in the forums, it looks falsely like this:

I use the desktop version on Windows 10 and it's the same problem on Firefox, Chrome and Edge, so this seems to be a problem that is independent from browser issues and has solely something to do with the mixed up language progress from different source languages. Do you have any idea what's really happening here?

January 7, 2016

14 Comments


https://www.duolingo.com/lauren

Looking into this.

January 7, 2016

https://www.duolingo.com/MultiLinguAlex

Thanks a bunch!

January 7, 2016

https://www.duolingo.com/joaopimentel

Great news! My flag levels are all messed up as well :(

French and spanish should be 20 and 19.

January 8, 2016

https://www.duolingo.com/swiftredfoxes

Hello, I wouldn't like to bother anyone but I was told it'd be better if I commented here instead of reporting the issue. I think something similar is happening to me.

Shortly, the levels and languages displayed next to my username are so random they literally turn into anything every time I comment or refresh a page. Thank you for reading!

February 8, 2016

https://www.duolingo.com/Tattamin

Wow, this is extreme. I am used to having language levels displayed wrongly, but for them to disappear completely is a new occurrence. Also, I think it is decidedly weird that not only those languages you are learning from German have disappeard, but also German learned from English.
I hope this gets solved somehow!

January 7, 2016

https://www.duolingo.com/Languageexperts1

Oh my got, very sorry for you, here is some problem on Firefox after upgrade! Hopefully your languages will soon recover!

January 7, 2016

https://www.duolingo.com/MultiLinguAlex

Thanks, but this has nothing to do with the described issue since this bug is not browser related.

January 7, 2016

https://www.duolingo.com/isaacishumble

My levels sometimes go higher

January 7, 2016

https://www.duolingo.com/benuslingo

oh yes I do have the same error with my french level which should be 7 :(

January 11, 2016

https://www.duolingo.com/cobold

I renew this question.

I'm learning French and Spanish and English from German and Portuguese from English.

I once started learning French and Spanish from English, but I cancelled these courses long time ago. Currently, I'm on level 22 in French, 15 in Spanish, 11 in English (from German), and 14 in Portuguese (from English). However, this is how my language levels are shown in the forums: language levels

I wondered whether the displayed levels depend on the site language - thus changing when I switch between German and English as course languages. Appears to have no effect, though.

edit: Interestingly, after submitting this post my language levels are displayed correctly. So this changes with daytime and the server's goodwill? ;)

edit2 After editing the language levels are displayed incorrectly again as shown in the image I posted.

April 9, 2016
Learn a language in just 5 minutes a day. For free.