https://www.duolingo.com/NinjaManatee

Not working in Linux

When I try to log into Duolingo from Linux, the home page is formatted badly and it will not accept my login credentials. I've tried searching for help, but it appears that other people aren't having problems.

I am running Mint 14 Cinnamon on a 64-bit machine with 2GB RAM, and I am using Chrome. I've tried updating Flash, but that did not help. I am able to use Duolingo find from my Windows 7 computer. Any help would be greatly appreciated.

1/16/2013, 4:30:24 PM

5 Comments


https://www.duolingo.com/xklakoux

I use Debian Wheezy 64-bit with 4gb ram in Chromium Version 22.0.1229.94 (chrome) and everything is working fine:

Beside two things:

1/16/2013, 5:46:14 PM

https://www.duolingo.com/zquad

I am on Ubuntu 12.12 Chrome Version 24.0.1312.52 and Firefox and all features work fine. Not accepting login credentials and badly formatted homepages is not a symptom of the OS or browser. The login problem sounds like its due more to your account that the OS; while the homepage might be due to an outdated browser, ad blocker/flash blocker addon, or unstable internet connection. Try a few different browsers, see if that helps.

1/16/2013, 6:06:23 PM

https://www.duolingo.com/NinjaManatee

I have figured out what the problem is, but I'm not sure how to fix it. It would appear that dansguardian is blocking part of Duolingo and that is causing the formatting to be messed up (if I turn off the firewall and dansguardian everything appears just fine). I've added an exception for duolingo.com, which appears to have fixed my account, but my daughter's account is still messed up (I have a much less restrictive filter associated with my account).

I'm off to try to figure out what dansguardian is blocking and why...

1/16/2013, 6:45:34 PM

https://www.duolingo.com/NinjaManatee

I'm putting this here in case someone else has the same problem. DansGuardian was blocking cloudfront.net (it said because it hosts Japanese porn) which apparently hosts Duolingo's CSS. I added a URL seception for cloudfront.net/css/ and that fixed the problem.

1/16/2013, 7:26:18 PM

https://www.duolingo.com/Beppe
  • 25
  • 22
  • 5
  • 4

I'm using Ubuntu (both 10.4 and 12.4) and I have no problem (actually the formatting is better than on my old Xp...). I haven't tried to activate the microphone, though.

1/16/2013, 6:07:51 PM
Learn a language in just 5 minutes a day. For free.