https://www.duolingo.com/Nethix

My microphone isnt working in flash

My microphone settings are correct and function fine in other applications. I just cannot get the microphone to function correctly in flash. I have checked my global settings and have allowed permissions for duolingo.com to record. Any help is appreciated.

June 5, 2012

13 Comments


https://www.duolingo.com/Sylnce

I solved my issue by disabling an application I had called Peer Block. Chances are if you have this issue, something is blocking the outbound traffic from your computer.

August 31, 2012

https://www.duolingo.com/ovar

duh, I don't know why I don't always go to peer block when I am having these type of issues. It's like it gets completely erased from my mind as being the "usual suspect".Heh, thanks!

January 12, 2013

https://www.duolingo.com/kerifue

I have the same problem, and I can state: ! firewall has nothing to do with it !
Nor any PeerBlock or whatever addons. The problem is elsewhere, don't waste your time in that direction.

January 12, 2013

https://www.duolingo.com/schweijk

Is your "record" button greyed out? If so, I have the same problem here (Flash settings are ok). Reported several times to Duolingo through feedback tab on the left. Still no solution. However, I've since tried to connect to the net at another location and, to my surprise, "record" button was enabled and worked just fine! So I was wondering: maybe our problem is that some ports (in your router, if that's the case) are blocked?

June 6, 2012

https://www.duolingo.com/eashaw

For all looking for a solution to this problem. It might be a browser problem. My microphone didn't work in chrome, but I tried in firefox and it worked fine.

January 31, 2013

https://www.duolingo.com/mdlobos

I am having the same trouble, Do you have mac?

June 7, 2012

https://www.duolingo.com/Nethix

I am running windows 7, even with allowing server permissions for flash I am unable to get the microphone working correctly. I doubt it is due to blocked ports and as angraman has successfully used the record function of flash player at a different site, I am inclined to believe that the issue is related to duolingo.com. I guess for now I just don't use the feature, thank you for your responses. Appreciated.

June 7, 2012

https://www.duolingo.com/Nethix

Just noticed that my firewall prevented firefox plugin container from connecting to the internet even though it would appear that it has the correct permissions.

June 7, 2012

https://www.duolingo.com/schweijk

Nethix, why do you say that the problem should lie in duolingo.com just because I've been able to use the record functions at another location? Do you think that duolingo places restrictions depending on the spot you use to connect to the web?

June 8, 2012

https://www.duolingo.com/schweijk

Regarding your last post, have you fixed your firewall so it doesn't block firefox plugin container?

June 8, 2012

https://www.duolingo.com/coldtoes

I was having this same problem on Firefox Mac. I solved it by going into the Adobe Flash Player settings, clicking "Camera & Mic Settings by Site" and setting duolingo.com to "Allow" instead of "Ask Me." For some reason it wasn't asking.

March 2, 2013

https://www.duolingo.com/nickmeinhold

Thanks coldtoes, that worked for me. I'm on Chrome on Mac. These were the steps I took: - type chrome:plugins in the address bar to open the Plug-ins page - on the Plug-ins page that appears, find the "Flash" listing - check the Always Allow check box I then went back to Duolingo and when a Microphone question came up I got a banner at the top of the window asking if I wanted to Allow microphone use. Now my microphone works.

October 7, 2013

https://www.duolingo.com/attatae

For whoever needs an update, also try changing browsers. Record does not work for me in Firefox. But it works in Internet Explorer. It is most likely an outdated flash install for my Firefox. Try updating firefox or google "how update FLASH." Great feature now that it works :)

That should work, but also make sure your firewall isn't block flash or your fav browser.

Using Windows 8.

December 11, 2013
Learn a language in just 5 minutes a day. For free.