1. Forum
  2. >
  3. Topic: Troubleshooting
  4. >
  5. It's not asking me to speak. …

https://www.duolingo.com/profile/WendyRiva

It's not asking me to speak. I don't know why. The microphone is on

It's not asking me to speak. I don't know why. The microphone is on

December 24, 2013

89 Comments


https://www.duolingo.com/profile/xaver154979

Please return us the microphone actions!


https://www.duolingo.com/profile/yoosefi

I'm having this problem. My mic works in other apps, and the settings are all turned on. Duolingo is only asking me to type, not speak.


https://www.duolingo.com/profile/spenant

it used to have a settings options but it looks like they have taken it down. maybe that will be put behind a pay wall later?


https://www.duolingo.com/profile/edgiovine

This is a browser dependent issue. If you use Chrome, it works fine.


https://www.duolingo.com/profile/amazonbear12

i'm using chrome but it doesn't work for me either. i just got a new mic and i want to test it out on duolingo


https://www.duolingo.com/profile/edgiovine

If you have a new mic you should set it up and test that it works before trying it with Duolingo.


https://www.duolingo.com/profile/Sasha450188

that what i thought from the get go. google stinks. My haunch it is Page who stinks not Brin. Any way monopoly will be converted to open source eventually.


https://www.duolingo.com/profile/bob1.618

Yes, edgiovine, this is right. I started using firefox and it stopped asking me to pronounce things. Darn it. I went to firefox because of bugs in chrome!


https://www.duolingo.com/profile/WendyRiva

I figured it out. It will ask me to speak and use microphone only through the app, but not when I'm using the website when I'm accessing through safari. I don't know why that happens, but at least I can do the speaking exercises.


https://www.duolingo.com/profile/malcolm.m

Hello Wendy. Thank you!! I think you have the answer I've been looking for everywhere.

My wife and I have just started Italian and she has been getting Qs asking her to speak right from the start but I never have. It seems from your solution that the significant difference is that she is working through the app on her iPad while I've been using the website on my pc. I wonder why Duolingo hasn't alerted us to that?

I see this post was 3 years ago so not sure if you're still there. However, I have happily given you a lingot - and would give you a hug if I could.


https://www.duolingo.com/profile/Sasha450188

me too - thru website in Firefox Ubuntu desktop


https://www.duolingo.com/profile/L_O_U_S

Similar problem here. I don't even see the microphone option in the settings. If I'm not mistaken, it used to be there when I started with Duolingo. I'm using Firefox.


https://www.duolingo.com/profile/edgiovine

Switch to Chrome - this feature works there.


https://www.duolingo.com/profile/L_O_U_S

Well, I've used Firefox for years and I don't like Chrome much, but I'll have to use it until the bug is fixed.


https://www.duolingo.com/profile/1MOiipQU

will this ever be fixed? I"m also a Chrome fan.


https://www.duolingo.com/profile/Drumpat01

I still have this problem. Tried different browsers, different languages, but no luck. I've seen people do it through on their computers. so I'm not really sure what's going on


https://www.duolingo.com/profile/Miguel280968

i use chrome (because I like it!) but this does not solve my problem on my desktop! As for the setting it could be better. I just sometimes don't want the audio questions, I'm hard of hearing and just can't catch some very common words At least the mobile version does not give you a hard time with it and goes to next question.

But i like the sound being on and it does not seem that you can skip the audio question without speaker on and micro off i don't get it. Actually the mobile version is quite good as you can use predictive mode and save you typing awkward words (like strawberies) I wish mine had spanish too. but I've got english and french that's ok


https://www.duolingo.com/profile/Miguel280968

once more, it would be nice if the posts were in chrono order...lot of wasteful reading with 3y old posts, never mind My problem is more with microphone and would like to stop the speech questions on my pc, saw it somewhere but can't find it anymore. Did once turned something off but kept getting them. However have it working well on my laptop and my phone...Strange


https://www.duolingo.com/profile/Eric489305

I have the same problem


https://www.duolingo.com/profile/kraboslav

The problem is also with the app itself. It's not just in the browser, don't have any speaking excercises in Norwegian and EVERY POSSIBLE OPTION IS TURNED ON :<


https://www.duolingo.com/profile/Ranamu

On Mac OS 10.9.5, only Chrome has speech exercises, not Firefox nor Safari (both the current updates as of 2017_07_05)


https://www.duolingo.com/profile/kraboslav

I don't really care about the PC. I use only the android app.


https://www.duolingo.com/profile/Zoe345004

I didn't even know Norwegian had speaking until i got on the PC and it prompted me, never had it ask me on the app...not sure how to fix?


https://www.duolingo.com/profile/OSCrustacean

I had the Google app disabled on my phone and after re-enabling it I was able to have speech exercises.


https://www.duolingo.com/profile/andrit
  • 1040

Same here. It works only in Chrome for me (59.0). But not in Firefox (52.2-ESR) nor Safari (9.1) nor IE (11). In iOS app it works also though.


https://www.duolingo.com/profile/thirdpotato

Also the app doesn't have any settings. And its not working on safari in my phone with the settings set to mic on


https://www.duolingo.com/profile/alextomko1

I am doing the English to German DuoLingo course for about a year. About ten days ago or so it suddenly stopped having me answer any questions in German other than the multiple choice ones. It only has me answer the german text in english and answer any of the voice questions in german are gone ect. What has happened how do I get it back to where I can get voice and text questions that I can answer in German instead of 100% english.


https://www.duolingo.com/profile/Akash160445

I am also having the same problem. I am learning Japanese and am doing it on chrome but it still isn't asking to speak anything


https://www.duolingo.com/profile/ShambhuSha460069

I was using Opera browser and changed to Chrome and it does work well and speaking courses does come


https://www.duolingo.com/profile/ElishevaGo1

i am having this issue as well. i think i may have told it that i don't want to use the microphone, but that was temporary, and i don't know how to get it back now...


https://www.duolingo.com/profile/gracyelala

Click "Settings" in the top menu. Turn "Microphone" to "on". That's it!


https://www.duolingo.com/profile/Luis

You can turn the speaking exercises back on by going to your settings (top right corner of the screen).


https://www.duolingo.com/profile/djule95

Im not seeing the option :S My mic is on


https://www.duolingo.com/profile/Eric489305

Hi Luis how are you? I have speaking exercises on and it still doesnt bring up any speaking exercised. My phones mic is turned on.


https://www.duolingo.com/profile/Tidbit1

Hey, I have tried that but I still don't even get the way to pronounce a word, I think my settings are not working. Any helpful hints or tips on how to make it work?


https://www.duolingo.com/profile/EP96

I'm having the same problem here


https://www.duolingo.com/profile/ronkisimo

This is not the issue because in settings microphone is turned on. I find that the exercises work on chrome just not safari. the problem just started around a month ago.


https://www.duolingo.com/profile/SteveSteml

I agree. I have been using Duo almost daily for about a year and a half and I have just begun to encounter the same problem about one month ago. It isn't asking me to speak anymore no matter what I do. I'm using Safari. I've checked the settings multiple times and the mic is always on. I've logged in and out, etc. Nothing works.


https://www.duolingo.com/profile/FHinson

I'm having the same problem on android, but also on ipad and imac. Particularly as a paying subscriber, I find it very disappointing that Duolingo hasn't even acknowledged that it has a problem, let alone fixed it. The exercises work fine on my office PC computer, but the office is far too busy and noisy for oral language lessons. I've tried opening duolingo in other browsers (Chrome and Firefox), but this does not fix the problem on android phone, ipad or imac.


https://www.duolingo.com/profile/ronkisimo

try a different browser. hope that helps:)


https://www.duolingo.com/profile/ElishevaGo1

Thanks :) i must have skipped it somehow...


https://www.duolingo.com/profile/Frank_Ytsma

I am learning Dutch, my wife is learning Polish . For some reason we are not asked to speak either languages ? Everything is on at the computer and working. Can you please sort this out. Thank you. Frank.


https://www.duolingo.com/profile/DebreiHelg

Although the speaking excercises are on, my mic and everything are working, speaking excercises still not appear. Did it become a paid feature? How can I fix this?


https://www.duolingo.com/profile/Shianling

I'm having the same problem. I use Duolingo in Safari, and it was never a problem before. My mic is on, I have checked the settings, and I have logged out and in several times. This is quite frustrating.


https://www.duolingo.com/profile/dapharkin

Can also confirm safari version not working, moved to Chrome and started getting speaking challenges again. Will continue to send reports to Duo.


https://www.duolingo.com/profile/ronkisimo

dido, I thought I was the only one.


https://www.duolingo.com/profile/OttoDeath

Hey ronkisimo! I see you have a 882 day streak. I am new to duolingo and I was wondering is it hard to be on the site every day? Is it worth it for lingots? Do you feel like a slave/addict? Thanks in advance! :D


https://www.duolingo.com/profile/DonForbes

Duolingo mic on-off setting does not even appear for me in Safari although I told Safari to allow Duolingo to use mic (macOS 10.13.2). In Chrome the mic on-off setting is present and works fine so I'll just use Chrome for Duolingo.


https://www.duolingo.com/profile/AlexandraZerner

Yesterday I noticed a slight change in the design of the web interface of Duolingo and it works better now, but now it's not asking me to speak. I checked the settings several times and everything is as it should be. I am using Firefox.


https://www.duolingo.com/profile/andrit
  • 1040

Same here. It works in Chrome-59.0 for me though. But not in Firefox-52.2-ESR or Safari-9.1. or IE-11.


https://www.duolingo.com/profile/SirLingualot

I think I have a very similar scenario, where it works with Chromium (unbranded Chrome) but not on Firefox. I run Linux here.


https://www.duolingo.com/profile/Miguel280968

Actually I don't find speaking such a great value at my learning stage. So I'm quite happy to turn the mic off on my pc to eliminate these oral exercises and can do the others much faster on a normal (English US) key board. (I'm glad I'm not stopped for the lack of accents or punctuation; I want to go fast and get plenty of sentences and vocabulary to build up my knowledge in Spanish.

But my phone and my W10 laptop do microphone well with Chrome. So I gave up trying on W7 desktop. I occasionally use W10, else use the phone which has only a few microphone demands for which I have no problem or very occasionally I have to repeat but it has even accepted some of my answers that I knew were way out!


https://www.duolingo.com/profile/spenant

I believe they have removed speaking, my best guess is they will be putting it behind a pay wall in the near future. I did a research article on this company and it was the only was I saw they could increase revenues.


https://www.duolingo.com/profile/edgiovine

I tested today and speaking exercises do not currently work with Firefox or Edge but they are fine if you use Chrome.


https://www.duolingo.com/profile/The_Tams

I am running Chrome and the speaking exercises do not work, although the microphone as an option shows. In firefox that option is disabled.


https://www.duolingo.com/profile/Ken823284

They did work in Edge until the recent upgrade, but now I can keep practicing in Chrome, thanks!


https://www.duolingo.com/profile/Bdog0908

I've had the same experience with the speaking exercises only working on Chrome.


https://www.duolingo.com/profile/Paul_N_

Firefox 54 same problem. Mic is on in setting. Exercises never ask me to speak ( speech recognition) Been like this for a few weeks - 27th June 2017


https://www.duolingo.com/profile/ManfredWinslow

Yes indeed, no matter what I do I no longer have speech exercises in Firefox. It works okay using the app, but the browser version is my preferred lesson plan (it's a little more difficult). Hope Duolingo sort this out -- it used to work just fine!


https://www.duolingo.com/profile/rodeutsch

Same problem. Until a few weeks ago, Duo was asking me to speak in German. Now it is not. I haven't changed anything. It worked, then it didn't, for no apparent reason. My microphone is ON. Any ideas please?


https://www.duolingo.com/profile/edgiovine

According to various comments on this thread, Duolingo speaking exercises are only currently available if you use the Chrome browser. They no longer work in Firefox, Edge, or Safari for now.


https://www.duolingo.com/profile/amazonbear12

im on chrome and it isnt working


https://www.duolingo.com/profile/pbaughman123

edgiovine, it is not working in chrome.


https://www.duolingo.com/profile/thirdpotato

I'm having this problem on my iPhone and Firefox and edge. I don't want to have to install another browser just to use I've website! That's ridiculous. Why is there no solution for this yet? ??


https://www.duolingo.com/profile/EllisTaylo

It's nice to see that after 4 years of this thread duolingo still feel that it is unnecessary to sort this out, fantastic customer service well done guys..........


https://www.duolingo.com/profile/Jana650920

yeah! my parents are learning english and spanish, I'm learning Danish. They get speech exercises and I don't but I really wanna have that.

I don't even have a microphone-option in my settings?!?


https://www.duolingo.com/profile/Miguel280968

R U using a mobile phone? On mine I always have audio questions but with an option of turning it off, apparently for one hour. It's very convenient and the next time you use it again it's "on" by default, again with the same option. That is if people are around you (Like public transport and if you have no headphone) you just click on "Can't listen now...) Also sometimes if you can't really comprehend the spoken questions this way you don't get them - Good luck. (I don't remember seeing this on DT versions.


https://www.duolingo.com/profile/Miguel280968

...What is so nice about this...perhaps you're too polite!


https://www.duolingo.com/profile/LingoEd16

I think Duolingo does not let you speak every time, sometimes I do not get a speaking exercise when the settings are on many times in a row. But some days after it lets me speak. It should be normal.


https://www.duolingo.com/profile/seckhoff

Mine's not working either, and I'm using Chrome now.


https://www.duolingo.com/profile/Jwwdaterd

Make sure you have given the app permission to access the microphone. That's what fixed mine.


https://www.duolingo.com/profile/TorMoag

I'm learning Spanish using the app on an Android device and there is no option in the settings for microphone. My husband is learning French on an iPhone and has it? Anyone got a solution?? Thanks!


https://www.duolingo.com/profile/RobertoElCuarto

My experiences:

  • An old iPad still provides speaking exercises via the app.

  • Ditto an old iPhone, although I only use it in streak emergencies, and those are pretty rare.

  • Safari on MacOS does not provide speaking exercises, and this is clearly conscious on Duolingo's part. Exercises don't present and then fail, they don't present at all.

  • Chrome on MacOS works, although it's a bit twitchier than the app.

  • I don't have a Windows 10 laptop any more, and I'm not going to try this on my old Windows 7 desktop because it was never very capable, unlike the Win 10 laptop.

The key reason may be that Chrome supports Web Speech API (since it's a Google initiative, I think) but that Safari doesn't or didn't or doesn't do well enough.

Conclusion (subject to change with new info): Use Chrome or the app.


https://www.duolingo.com/profile/CorryDastu

I had the same problem. I solved it by uninstalling. When I went to Duolingo in my search engine I did not lose any information and the speaking was back on. Good luck.


https://www.duolingo.com/profile/chahrzad3

I am not able to repeat the sentences via microphone why?


https://www.duolingo.com/profile/Colonel.Waluigi

It never asks me to do speaking questions, no matter if I have it on or off. Only listening, typing and a word bank. I use Chrome AND iPhone and it never works! What is happening?! Are they updating the speaking system on here or does it just not work?


https://www.duolingo.com/profile/ShambhuSha460069

I was using Opera browser and changed to Chrome and it does work well and speaking courses does come


https://www.duolingo.com/profile/Aonseon00

A lot of people are saying that Duolingo works for them on Chrome, but for me, it hasn't been working on Chrome, even though the microphone is enabled/allowed. It's been this way for around a week maybe, and it's pretty frustrated b/c I felt that it was really helpful. Any suggestions?


https://www.duolingo.com/profile/ShambhuSha460069

I was using Opera browser and changed to Chrome and it does work well and speaking courses does come


https://www.duolingo.com/profile/__Wil__

I'm having this issue too. I noticed after about 10 lessons on my laptop that it's never asked me to speak. When I go back to my tablet, it asks at least once during each lesson. I can't find any settings on the laptop that would affect this (mic is enabled, other programs use the mic just fine).


https://www.duolingo.com/profile/ShambhuSha460069

Check your web browser. Google Chrome is ideal for this test and it does work perfectly. Make sure you have updated Google Chrome.


https://www.duolingo.com/profile/__Wil__

Thanks, ShambhuSha. It does indeed work in Chrome. Thanks for the suggestion!


https://www.duolingo.com/profile/mizzoug

Agree with ShambhuSha460069. I use Chrome for work and Firefox for home so wasn't even thinking about the browser. I switched to Chrome and not only does it ask me to speak, the microphone option is there under settings where it isn't under FF. Go figure!


https://www.duolingo.com/profile/ErMasse

I stopped getting speaking questions years ago, and they've never come back. It doesn't matter what browser I use, or what settings. It's ridiculous, and at this point I just assume that they've phased them out or something. The functionality on this site can be so janky. I have all ad-blockers off, I have mike on in the browser and the site, and I'm using Chrome. It doesn't make a difference.


https://www.duolingo.com/profile/mary755882

I no longer get them on my android phone either.


https://www.duolingo.com/profile/JemFey

I use chrome and have all microphone options I can find switched on but I've never been asked to speak to practice my accent or anything? My daughter has the app and has been asked this from the beginning. I was wondering if it's something to do with the fact that I use the app on my phone whereas she uses the app on her tablet? Any help would be appreciated. Thank you x


https://www.duolingo.com/profile/EvkaMich

I have similar trouble. My micro is on, speaking exercises work without problem from the beginning of the Spanish course, but I never get speaking exercises in Dutch course. I thought that speaking start later in the other course, but my friend told me, that she is already doing the speaking exercises. Any ideas what could I do?


https://www.duolingo.com/profile/OttoDeath

Hy Eva Vargová! I'm Otto. :) You look very cute!! 3 I see you have a 713 day streak.. I am new to duolingo and I was wondering is it hard to be on the site every day? Is it worth it for the lingots? Do you feel stressed out when you have to visit the site every day to keep the streak going? Thanks in advance! :D


https://www.duolingo.com/profile/3raxton

I've found the fix for the mobile app!

Tap the menu in the top right corner on this site > Choose Settings > The microphone section should be turned off (mine was) > Tap On > Tap save in the top right corner

Now it should be fixed! Cheers!

Learn a language in just 5 minutes a day. For free.