https://www.duolingo.com/Amanda.Patterson

If I set my language to "English" it defaults to English for Spanish speakers. Can I change?

My students are all Turkish and there is a course of English for Turkish speakers, but I can't seem to assign it to my students. Anyone know a solution?

Edit: If I set my profile to Turkish by selecting to learn English/German through Turkish, it shows up correctly. But this eliminates many other capabilities such as:

  1. having an interface in English (the class returns to English for Spanish Speakers).

  2. creating/switching discussions into the educators forum as well as some others.

  3. viewing any progress that I've made such as leveling up in languages I've learned through not-Turkish. For example I took a placement test in the Spanish for English Speakers course in order to be able to use this forum (my use is all in my personal account) but the only course that shows up when I switch to Turkish is the ones I've taken through Turkish. (this is not an educator problem though so I'll elaborate elsewhere).

Any ideas? Is someone working on fixing this?

March 27, 2016

12 Comments


https://www.duolingo.com/jrikhal
Mod
  • 22
  • 18
  • 18
  • 14
  • 8
  • 5
  • 5
  • 5
  • 3
  • 3
  • 3
  • 2
  • 2
  • 2
  • 2
  • 2

Hi Amanda.Patterson,

Could you relocate this discussion in the “Educators" forum? You'll be more likely to have useful answers there (and it belongs there ;) ).
To relocate it, edit your original post then select the said forum in the drop-down menu on top-left of the edition area.


EDITION:

I gave a look to the settings in Duo Schools. I'd give a try to select/change for "No specific language" in the settings of the classroom. My hope: if your student only follows the course of English For Turkish speakers then you'll see their progress in this course.

The other solution, which I'm pretty sure will work, is to:

  1. Open your classroom control page in one tab of your browser, note where is located the "Classroom settings" button.
  2. Open your Duo account into another tab and switch it to English For Turkish speakers course (all your interfaces (Duolingo, Duolingo for Schools, ...) will be in Turkish now).
  3. Go back to the first tab and refresh it (everything will be in Turkish) and click to the button "Classroom settings" (now written in Turkish) of which you have noted the position before. In the dropdown menu you'll have the option "English" (from Turkish).
  4. Go on your Duo account and switch it back to any course for English speakers (to have all your interfaces back in English)

In case you need it: you'll find here various way to switch between courses.

March 27, 2016

https://www.duolingo.com/Amanda.Patterson

jirikhal, I tried to do so originally as well as now, but the only option open to me is 'troubleshooting.' So I suppose now I'm also having a troubleshooting problem =/

March 27, 2016

https://www.duolingo.com/jrikhal
Mod
  • 22
  • 18
  • 18
  • 14
  • 8
  • 5
  • 5
  • 5
  • 3
  • 3
  • 3
  • 2
  • 2
  • 2
  • 2
  • 2

Oh, it's because, in Duo settings, one is supposed to sue forums only once his/her account is level 2. ;)

You may want to do one or two lesson of any course to "unlock" the forums and then relocate your discussion. The reason is that Duo staff actively read (and quite often answer) the Educators forum (but very rarely answer in other forums).

March 27, 2016

https://www.duolingo.com/Amanda.Patterson

Update: Switching myself into the English for Turkish Speakers did work, but if I switch my page back into English as you suggested the course I offer switches back to English for Spanish. Luckily I speak some Turkish so I guess I will just have to survive this way until someone creates a workaround. (PLEASE!) Thank you for your help

March 27, 2016

https://www.duolingo.com/jrikhal
Mod
  • 22
  • 18
  • 18
  • 14
  • 8
  • 5
  • 5
  • 5
  • 3
  • 3
  • 3
  • 2
  • 2
  • 2
  • 2
  • 2

Mmm.. I'd try the same as above but with the following step in between 3rd and 4th of the above one:

Click on the link "invite users" (so it'll be written in Turksih) and copy the link there and use this link to send it to your student.

I think that even if you go back to ENglish interface (and the system indicates Spanish from English", by clicking on the link, you'll still see your users' progress on their English from Turkish tree.

March 27, 2016

https://www.duolingo.com/Amanda.Patterson

Thanks for your responsiveness. On my personal account I'd have no problem but I created a new account with my work email (to prevent the kids from getting my personal email/etc.)... Ok I'll go "learn" something =D

March 27, 2016

https://www.duolingo.com/TheWordPhoenix

Im having the same problem. Is there an option to learn more formal, advanced english with simple english. What I mean by simple english is english that like everyone knows, but has some grammatical problems. So you can take the vocabulary of a person who knows english to a higher level.

March 28, 2016

https://www.duolingo.com/0rangeorchid
  • 12
  • 9
  • 8
  • 8
  • 7
  • 6
  • 6
  • 6
  • 3

Hi Sanaa, (this is the OP from my personal account) that's not possible right now. The only courses available are for learning English from your native/another language you speak.

March 28, 2016

https://www.duolingo.com/TheWordPhoenix

Thanks

March 28, 2016

https://www.duolingo.com/jrikhal
Mod
  • 22
  • 18
  • 18
  • 14
  • 8
  • 5
  • 5
  • 5
  • 3
  • 3
  • 3
  • 2
  • 2
  • 2
  • 2
  • 2

\2. creating/switching discussions into the educators forum as well as some others.

Go to your Amanda.Patterson Duo account, switch it to english, go to https://www.duolingo.com/discussion , click on edit (your subscriptions)
Imgur
and select susbscribe to the Educator forum.
You can now switch to Turkish interface or any other and you'll still see the Educators forum (or select it when creating/editing a discussion).

\3. viewing any [...] elsewhere).

This is a design choice by Duo in the early days that all interface will be almost totally independent.

March 28, 2016

https://www.duolingo.com/vivisaurus
  • 18
  • 17
  • 14
  • 14
  • 10
  • 7
  • 7
  • 5
  • 4
  • 2076

Thanks for all your help, jrikhal!

March 28, 2016

https://www.duolingo.com/vivisaurus
  • 18
  • 17
  • 14
  • 14
  • 10
  • 7
  • 7
  • 5
  • 4
  • 2076

Hi Amanda! If you populate the classroom with students learning English from Turkish, the page should automatically change to English from Turkish.

March 28, 2016
Learn a language in just 5 minutes a day. For free.