https://www.duolingo.com/profile/dtmedic

Nothing happens after completion of a lesson.

Seems to get hung up at the end of lessons and at the end of timed practice as well, does not take you back to the main page.

January 21, 2014

28 Comments


https://www.duolingo.com/profile/DonCarlosPeligro

I am having the same problem

January 21, 2014

https://www.duolingo.com/profile/bchan

This should now be fixed - please let me know if you still experience this problem.

January 22, 2014

https://www.duolingo.com/profile/laumack123

bchan, this sounds like the same problem we shared emails about earlier. My problem (on Win7/Chrome and IE) still happens, with one new change -- if I wait several minutes after submitting last response, I get kicked back to the home page w/o registering completion of the lesson or test. Feels like a time-out response of some sort.

January 22, 2014

https://www.duolingo.com/profile/MaryJolliffe

I am having the same problem. It's discouraging because I want to go to Basic 2 but can't find any way to get there

January 23, 2014

https://www.duolingo.com/profile/Whiterun

I'm having this problem, I press 'continue' and nothing happens; nothing I do with my browser seems to help.

January 28, 2014

https://www.duolingo.com/profile/Eberbach

Tried one of my older lessons and it DID end correctly. (Before the fix they didn't.) Thanks!

January 22, 2014

https://www.duolingo.com/profile/asherbennaphtali

It's still happening. It started for me just after Christmas, then it seemed to go away in the first week of January. Now that I've been put on the new UI, it's happening again.

January 23, 2014

https://www.duolingo.com/profile/laumack123

None of the other suggestions on this topic worked for me, but one or both of the following finally fixed my problem, and now lessons/tests complete correctly: 1. added Duolingo.com to list of "allowed" sites for cookies 2. set system to auto-detect proxy settings

Perhaps one of these might help others with the end-of-lesson problem, who knows?

January 23, 2014

https://www.duolingo.com/profile/Fatfish321

Same problem here, please sort it out Duolingo!!

January 22, 2014

https://www.duolingo.com/profile/mightysparks

Still happening for me.

January 22, 2014

https://www.duolingo.com/profile/mightysparks

It wasn't happening for me in any browser, but I just cleared all history in Chrome and it's working in Chrome, but this fails to fix anything in Firefox.

January 23, 2014

https://www.duolingo.com/profile/sal10go

Yes,I finish the first sentence ,then it asks me to invite through Facebook. I comply and then it says and shows a symbol for basid. That is it it will not continue or do anything from there. Help

January 21, 2014

https://www.duolingo.com/profile/Oisin.Debard

I'm having the same problem. I can complete the course, but I have to "quit" the lesson. It seems like I get credit for completing the lesson (my total xp goes up, my streak count goes up, and the skill strength increases) but I don't see the end of lesson graphics.

January 21, 2014

https://www.duolingo.com/profile/jaspercat

There was no fanfare either!

January 21, 2014

https://www.duolingo.com/profile/Eberbach

Same problem. Have to go manually to home page. Still seem to get XP. Not so sure about the word count.

January 21, 2014

https://www.duolingo.com/profile/Swampwood1

I'm not getting the streak or experience today ***Finally cleared one

January 21, 2014

https://www.duolingo.com/profile/pnehls

same here

January 21, 2014

https://www.duolingo.com/profile/Treecie

I continue to get kicked off the site. Very frustrating. Everything happens for a reason, so I guess I am going to have to repeat the lesson again, and again, and again!

January 22, 2014

https://www.duolingo.com/profile/jaspercat

It all seems to be working now, even the fanfare!

January 22, 2014

https://www.duolingo.com/profile/laumack123

Still happening to me. Who at DL is on this?

January 23, 2014

https://www.duolingo.com/profile/laumack123

Found my own solution - nothing to do with OS or browser, as I'd thought. Doing one or both of these fixed my problem, and now lessons complete and are recorded correctly:

  1. Set duolingo.com as an allowed site for cookies.
  2. Re-set proxy settings to automatically detect.
January 23, 2014

https://www.duolingo.com/profile/asherbennaphtali

Hey laumack123, that sounds really helpful and interesting.

Can you translate this into English for the over-35 crowd?

And tell us what OS you're talking about?

I humbly beseech that you bestow compassion upon those poor souls of us who grew up in the pre-digital era of yore.

January 23, 2014

https://www.duolingo.com/profile/laumack123

And now we will both be smiling -- I am a 65 year old grandmother who just got frustrated that this same end-of-lesson problem was happening to so many folks without a good DL response. I suspect different issues may be causing the problem for different people, but my problem was finally solved by one or the other of the two things I mentioned in my post.

To allow cookies:

Different browsers (Chrome, Firefox, Internet Explorer) have different ways to get to the place where internet settings can be modified. In Chrome, click on the 3-bar icon in the upper right corner of the navigation bar, then click on settings-advanced settings-privacy/content settings. Check "allow local data to be set", then click on "manage exceptions" and type duolingo.com as a new "allowed" site. Click "done".

I am trying to use Duolingo on a Windows 7 laptop with Chrome. I have no idea if this will help anyone else, but after 3 days of frustration, it finally got the end-of-lesson issue fixed for me.

A Duolingo team member had previously sent me an email with these suggestions. They didn't work for me but might help you:

Here’s what I suggest you do: 1. Try reloading the page in your browser. 2. Try quitting and restarting your browser. 3. If 1 and 2 don’t do the trick, update Flash Here’s a helpful link to get you on your way: http://www.adobe.com/go/EN_US-H-GET-FLASH 4. Try removing/disabling browser extensions Some tips for how to do that in specific browsers: Chrome - http://support.google.com/chrome/bin/answer.py?hl=en&answer=113907 IE - http://windows.microsoft.com/en-us/windows-vista/internet-explorer-add-ons-frequently-asked-questions Firefox - http://support.mozilla.org/en-US/kb/disable-or-remove-add-ons#w_how-to-disable-extensions-themes-and-plugins

Others have suggested deleting browsing history, also.

Let me know if this helps you!

January 23, 2014

https://www.duolingo.com/profile/angiepalomino

It is not letting me advance after completing the lesson, does anybody know why ?

January 21, 2014

https://www.duolingo.com/profile/MaryJolliffe

I have the same problem. I passed Basic 1 but cannot get Basic 2 to start. Help!!!

January 23, 2014

https://www.duolingo.com/profile/angiepalomino

Mary have you solved the problem? I have not I sent duolingo an email requesting help and they did not respond it has been two days since I sent the email. My problem completed Occupations lessons and will not let me advance.

January 24, 2014

https://www.duolingo.com/profile/norchids

This is happening to me right now. I've been choosing "strengthen skills" before moving on to new content, but when I get to the end of the lesson, duolingo just stops. It doesn't recognize that the lesson is complete after I've finished the last question. It just freezes. When I hit refresh, or go anywhere else on the duolingo website, I lose my progress for that completed lesson. (Happened three times in a row, so far, and I don't want to keep losing my lessons.) Anybody know how to fix this?

January 30, 2014

https://www.duolingo.com/profile/terrispan

I see all those comments are a year ago. But I am getting the problem now (January 31 and February 1 2015) My version does not use hearts. I get to the end of the session, the page shows that my response was correct, but then I am stuck. I waited an hour - still - never completed AND IT BROKE MY STREAK! This is frustrating. After three tries (two different lessons) I went to a different computer and different browser and finally I was able to get my streak.

Is there a limit to how many I can miss in 30 tries? I checked Wiki and can't find the answer. I should have a streak for 32 days - it's only 2 days, because twice I did not get credit for completing the lesson.

February 2, 2015
Learn a language in just 5 minutes a day. For free.