1. Forum
  2. >
  3. Topic: Troubleshooting
  4. >
  5. Sound problems with Mozilla.

https://www.duolingo.com/profile/gbushaw

Sound problems with Mozilla.

The synthesized voice is not working at all when I use Duolingo in Mozilla Firefox. This is a new problem today. It worked fine yesterday. I was able to do a couple of lessons by using Chrome instead of Firefox. It also seems to work fine in Safari. Any ideas?

January 24, 2014

10 Comments


https://www.duolingo.com/profile/OlderThanRome

I have the same problem but didn't see the thread here so I wrote to customer support and they replied within a few minutes. I'll let you know once I've found the solution.

They wrote:


Happy to help. There are a few reasons why this might be happening. It’s possible that you have an outdated version of Flash installed, you installed browser extensions that block Flash (i.e. Flashblock), or that Flash crashed.

Here’s what I suggest you do: 1. Try reloading the page in your browser. 2. Try quitting and restarting your browser. 3. If 1 and 2 don’t do the trick, update Flash Here’s a helpful link to get you on your way: http://www.adobe.com/go/EN_US-H-GET-FLASH 4. Try removing/disabling browser extensions Some tips for how to do that in specific browsers: Chrome - http://support.google.com/chrome/bin/answer.py?hl=enanswer=113907 IE - http://windows.microsoft.com/en-us/windows-vista/internet-explorer-add-ons-frequently-asked-questions Firefox - http://support.mozilla.org/en-US/kb/disable-or-remove-add-ons#w_how-to-disable-extensions-themes-and-plugins Let me know if this helps you!


https://www.duolingo.com/profile/CatherinGregory

I'm have sound issues too, with Nightly (firefox). And this morning on my Apple Ipad, the same thing. The ipad is working now, but not the PC desktop.


https://www.duolingo.com/profile/gmolleda

Ekde hieraŭ la sono en Duolingo ne sonas poste du aŭ tri frazoj. Se mi rekomencas la Duolingo paĝo, la sono revenas sed ĝi reiros denove. Tiu ĉi konduto estas en Firefox kaj Cromium (libera Chrome).


https://www.duolingo.com/profile/mauricioc

I can't be sure I've found the cause, but I found out that disabling EFF's HTTPS Everywhere extension makes Duolingo work just fine again. I've contacted Duolingo support so they can fix this. Do you have any extensions which could be responsible for such a change in behavior?


https://www.duolingo.com/profile/arok

Thank you! After I dsiabled HTTPS Everywhere in Firefox it worked again. Chrome still does not work for me, even with disabled HTTPS Everywhere. The strange thing is, even I can not hear the sound, Chrome displays an icon on top of the tab that there is some sound playing.


https://www.duolingo.com/profile/Lenkvist

That fixed the issue for me as well, thanks!


https://www.duolingo.com/profile/mauricioc

A follow-up: Please don't disable HTTPS Everywhere if you're having this problem! A much better solution is to access Duolingo itself via HTTPS by going to https://www.duolingo.com/ instead.


https://www.duolingo.com/profile/shepla
  • 1851

Good idea, however I have been accessing the https version of duolingo but still lost sound.


https://www.duolingo.com/profile/Laura_Ellis

I'm having similar problems, but with Chrome. Sometimes I get the voice, but not the other sounds (success/fail ones) and sometimes I get the other sounds but not the voice. It's only been happening the past couple of days and I haven't checked it in any other browser.


https://www.duolingo.com/profile/Laura_Ellis

Forgot to say, it's not all the time. If I restart a lesson it usually fixes itself, but sometimes the voice will stop half way through a lesson (very annoying).

Learn a language in just 5 minutes a day. For free.