1. Forum
  2. >
  3. Topic: Troubleshooting
  4. >
  5. Duolingo is not fully loading…


Duolingo is not fully loading in firefox 27.0

I just get a white screen with support on one side and the bottom text menu on bottom. The bottom menu does not always appear either if you reload.

January 25, 2014



I am seeing a similar problem due to the HTTPS Everywhere extension. Duolingo support says they've just added HTTPS support, and they're working on a fix for this problem. Stay tuned!


A follow-up: Please don't disable HTTPS Everywhere if you're having this problem! A much better solution is to access Duolingo itself via HTTPS by going to https://www.duolingo.com/ instead.


This solves most of the problem, but some links on Duolingo automatically open in a new tab with regular HTTP so the page fails to load. If I manually add the HTTPS to the URL in the new tab it often loads properly, but not always.

For example, I went to the "Guide to Finding Duolingo Guides" (https://www.duolingo.com/comment/1278938) and clicked on links to http://www.duolingo.com/comment/1480196 and http://www.duolingo.com/comment/1076946 which both opened in new tabs and failed to load. Manually changing the first one to HTTPS made it load, but that didn't work for the second one.

I'm using Firefox 26 with HTTP Everywhere 3.4.5 on Linux Mint.


Yeah, forum post links go wherever the post author decided they should go. In particular, they use HTTP if the provided link starts with http://. I'd write a HTTPS Everywhere rule to automatically rewrite HTTP links to HTTPS ones, but I think Duolingo devs want to fix it on their side as well (because other extensions may also be affected, for example).

As for the last link: You can't see the post even if HTTPS Everywhere is disabled, so I'd guess it was just deleted... Usagiboy7 was the post author and he said "I forgot and deleted the old one first" in the guide you mentioned, so it's possible that he deleted it himself.


Cool thanks, disabling it seems to have solved my problem.


The same happens to me since yesterday night. I even lost my streak before I found out it still worked in Opera.


I'm having the same issue (I found this discussion thread by logging on in internet explorer). I resolved it as mauricioc suggested by using the https url.


Same thing happens in internet explorer. I rarely use it so I not even sure how to check the version it is. I will try updating flash. Needed to be updated but did not fix problem. It works in linux must be something I screwed up ha.


If anyone is still having this problem the solution is simple. You DO NOT need to disable HTTPS Everywhere. Just ALLOW Cloudfront from the filter list (you can do this from the filter list or toggle the Cloudfront from the HTTPS Everywhere icon). Cloudfront is Amazon's CDN and is probably used by Duolingo now on the back-end. You should also set the Duolingo url to https://www.duolingo.com/ then the default filter for Cloudfront usually works.

Learn a language in just 5 minutes a day. For free.