https://www.duolingo.com/profile/esgerman12

Not able to comment on Android.

I use Duolingo with Android. After pressing "REPLY" at some comment there is only a kind of an 8-digit ID instead of the comment which I want to reply to. I get only a meaningless error message if I try to post an answer though:

"An error occurred. Try again later."

I reinstalled the application and I cleared the cache of the application.

I thought at first that it worked only with some specific native language languages since I switched to another native language.

All comments: http://i.imgur.com/OuEHhUc.png

First comment: http://i.imgur.com/OpCnaD6.png

Second comment: http://i.imgur.com/luWh0tS.png

June 14, 2016

16 Comments


https://www.duolingo.com/profile/Langmut

I've had the same problem for several months now. 4 updates have still not solved it. Issued a problem report a couple of weeks ago but had none but the automatic reply.

Is there hope of ever getting this fixed? It rather puts me off using the App as the comments are half of the fun. If this is an AB test I would like to know.

July 25, 2016

https://www.duolingo.com/profile/jrikhal

If this is an AB test I would like to know.

Very very unlikely to be an A/B test IMO.
It could be an A/B test if you had no access to the discussion at all, but here it displays the "identification number" of the comment in Duo's database instead of displaying the content of the message, so definitely looks like a bug.

had none but the automatic reply

I'd consider the report didn't go out and I'd therefore send a new one from the website form.


EDITION: Oups, I didn't see the but in my second quote. ;)

Having only an automatic answer is normal.
While they will not answer to it (well, up to some exceptions probably ;) ), because they can't answer to each one, they nevertheless use them (among other criterias) to prioritize their list of bugs to be fixed according to the number of Bug Report forms received for each bug. So reporting is useful even if we don't have direct mails answers.

July 25, 2016

https://www.duolingo.com/profile/Langmut

Again 4 or 5 updates but still not solved.

September 3, 2016

https://www.duolingo.com/profile/Langmut

Hi jrikhal, I still have not had any feedback from DL and three or more updates to the app since this last post have not solved the problem. Do you think there is still hope?

August 9, 2016

https://www.duolingo.com/profile/jrikhal

Do you think there is still hope?

As long as there's life there's hope. ;)

September 6, 2016

https://www.duolingo.com/profile/Langmut

Yeah, yeah. Hope springs eternal and all that, I know...

If only I knew they are working on it - or at least have it on their list. Or if they decided not to do anything about it and tell me so I could live with that. Maybe they have already worked on it and believe they have solved it but it still doesn't work? How are THEY going to know if they don't communicate with me? It's this not knowing that annoys me most, this non-communication.

September 6, 2016

https://www.duolingo.com/profile/jrikhal

There is only kind of an 8-digit ID instead of the comment which I want to reply to

would you have a screenshot of the "8 digit" thing that is replacing the comment?
Also, how do you know what the comment is saying (and thus want to reply to that) if the comment itself isn't displayed but replaced by this "8-digit ID")?

June 14, 2016

https://www.duolingo.com/profile/esgerman12

How or where I can upload a screenshot? Any recommendations?

June 14, 2016

https://www.duolingo.com/profile/jrikhal

Upload it to a website for sharing images (like imgur). Once done, copythe link to the image the website will give you and paste it here.

June 14, 2016

https://www.duolingo.com/profile/esgerman12

Oops, I should resize them. These screenshots are too big for image linking.

June 14, 2016

https://www.duolingo.com/profile/jrikhal

They are fine (with just the link) as they are at the moment I'm writing these words. ;)


Well bug that I guess Duo would like to have feedback about.
So I suggest you fill a "Bug Report" form (with as much details as you can, for example those screenshots are perfect I think, cf. text in this form), those forms being read by staff.

And, indeed, these numbers are the identifiers of the comments. If you go on https://www.duolingo.com/comment/12020064$comment_id=12022600 it'll bring you exactly on the comment (not on top of the all discussion like https://www.duolingo.com/comment/12020064 does).


Side note: this Android view of SD is very messy: you don't see at glance which comments are answer to what other comment. :(

June 14, 2016

https://www.duolingo.com/profile/esgerman12

Ok thanks :(

June 14, 2016

https://www.duolingo.com/profile/xigoi

I also have this problem, factory reset did not help.

July 25, 2016

https://www.duolingo.com/profile/alterazu

I have the exactly same problem.

July 25, 2016

https://www.duolingo.com/profile/LarsHogberg

Still have the same problem. On all my devices (android phone and tablet)

October 30, 2016

https://www.duolingo.com/profile/Langmut

Same here. Still the same problem despite a dozen updates.

October 30, 2016
Learn a language in just 5 minutes a day. For free.