Duolingo is the most popular way to learn languages in the world. Best of all, it's 100% free!

https://www.duolingo.com/wildnis

Microphone problems in Linux?

wildnis
  • 13
  • 7
  • 4
  • 4
  • 2

Has anyone else gotten a microphone (internal) to work in Linux (Firefox/Chrome)? It keeps saying either "Oops, I couldn’t understand what you said" or "I can't hear you very well" and nothing at all happens when I click the "Play back your recording" button... But it works with a Flash microphone test at http://msuconfuciusinstitute.org/scheduler/mictest.php

6 years ago

29 Comments


https://www.duolingo.com/iox

In my Ubuntu 10.04, with Flash 11 installed, I had to go to this special Adobe page: http://www.macromedia.com/support/documentation/es/flashplayer/help/settings_manager06.html , and there set duolingo as "Always allow". This is because the duoling recorder doesn't ask you for permission, and so it can't access the mic. Once you add duolingo as a trusted site that can access your mic, recording works perfectly.

6 years ago

https://www.duolingo.com/FrediVallina

thank you, that worked for me as well in Ubuntu 12.10 with internal microphone on a VAIO laptop

5 years ago

https://www.duolingo.com/destogl

Also helped hier: xubuntu 12.04, external mic, Asus laptop

5 years ago

https://www.duolingo.com/ralphthompson

Confirmed solution for Ubuntu 12.04 too, thank you

5 years ago

https://www.duolingo.com/id000

Thanks! It worked for me on Ubuntu 12.04 and firefox.

4 years ago

https://www.duolingo.com/MauroQuil
MauroQuil
  • 11
  • 10
  • 10
  • 10
  • 10

Works for Firefox 24 on Linux Mint 14. Great help! this should be on the error message!

4 years ago

https://www.duolingo.com/bilboinamerica

How do you add a trusted website? Duolingo doesn't appear amongst the visited sites for me...

2 years ago

https://www.duolingo.com/addie_rock

Thank you a lot! I had the same issue and then I made 3 things to fix it: 1) Duolingo Settings - Microphone ON: Click or hover on the upper right corner of Duolingo website and go to Settings and make sure the Microphone is set to ON. 2) Make sure the microphone is plugged into the computer and then do the Flash microphone test at http://msuconfuciusinstitute.org/scheduler/mictest.php to check if the microphone is working in your Firefox browser. 3) As user iox said, Go to go to this special Adobe page: http://www.macromedia.com/support/documentation/es/flashplayer/help/settings_manager06.html , and there set duolingo as "Always allow". This is because the duoling recorder doesn't ask you for permission, and so it can't access the mic. Once you add duolingo as a trusted site that can access your mic, recording works perfectly.

5 years ago

https://www.duolingo.com/blobber

For the english language version of the macromedia settings: http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager06.html

5 years ago

https://www.duolingo.com/Sigundo
Sigundo
  • 21
  • 7
  • 4
  • 4
  • 4
  • 3

The flash mic you provided works for me as well. Not being facetious, but on my computer when I get the Oops.. message I have to speak up a little more and enunciate my words more clearly for Duolingo to understand me. Sometimes I have to try it several times.

6 years ago

https://www.duolingo.com/wildnis
wildnis
  • 13
  • 7
  • 4
  • 4
  • 2

I've tried talking louder and slower, but also the playback doesn't work at all, which suggested that something is wrong.

6 years ago

https://www.duolingo.com/pmontrasio

http://msuconfuciusinstitute.org/scheduler/mictest.php works for me but my mic doesn't work on duolingo. Too bad! I'm on Ubuntu 11.04

6 years ago

https://www.duolingo.com/HIGGS

I get playback but the program says it does'nt hear me.

6 years ago

https://www.duolingo.com/hugobbmartins
hugobbmartins
  • 15
  • 14
  • 9
  • 4
  • 4
  • 3
  • 2

You can follow this tip: In addition the settings you can adjust on macromedia website cited above. You have to enable recording in volume control options of your current distro in use.

I use LXDE and I'm configuring this option with gnome-alsamixer package.

I'm considering you have alsa audio system configured previously in your system.

Anyway you can do this without download any package, just type: $ alsamixer

Then you scroll to capture settings and adjust the volume using the comand line interface with directional keys. To enable or unable (set to mute) you press space key.

I hope you all solve this issue. See you.

6 years ago

https://www.duolingo.com/cagalo11

it is also the solution for Fedora 18

5 years ago

https://www.duolingo.com/2JNavas

you just need to check your configuration. Open the flash panel control (I assume that you must have it installed on your ubuntu distribution) and add duolingo domain to the camera and microphone settings by site.

4 years ago

https://www.duolingo.com/Hotrootsoup

Aside from iox's fix and various other fixes, there is something else that can be wrong.

If your microphone doesn't work in other /flash/ microphone tests, right click the flash applet, go to settings, and make sure that your microphone is the one selected. Often OS's will have a default, like "Intel Audio" and such that do nothing and are selected by default.

4 years ago

https://www.duolingo.com/tehingo

It was actually easy for me to fix.

1) When the window shows up for the first time, make sure to select "allow" and tick the box "always remember". 2) Take notice that Google Chrome will also ask you for permission with a toolbar that extends from the top, so don't forget to click on "allow" there, too! I missed that one at first.

4 years ago

https://www.duolingo.com/HeikkiKnii

the "oscilloscope" shows me very high noise from the microphone and my voice isn't recognized. When i record to any other software, i get close to zero noise. Please fix this thing.

And i get no playback when i try to play my recording in duolingo. no sound, not even noise.

i'm using a usb mic.

I'm using Ubuntu.

4 years ago

https://www.duolingo.com/hugobbmartins
hugobbmartins
  • 15
  • 14
  • 9
  • 4
  • 4
  • 3
  • 2

Type alsamixer in a terminal window. You can check the mic activation there. Be sure exploring both options (audio recording and audio reproducing panel).

I hope you haven't gave up trying use Duolingo on linux due long time without answer here.

Have good studies.

1 year ago

https://www.duolingo.com/HeikkiKnii

Not working with chromium either. a screenshot also shows a graphics problem in chromium: https://dl.dropboxusercontent.com/u/4435155/DuoLingo/Kuvakaappaus.png

4 years ago

https://www.duolingo.com/HeikkiKnii

Also not working in google chrome / ubuntu.

looks better than in chromium and it asks to allow the microphone (firefox didn't even ask it) but still not recognizing my voice.

4 years ago

https://www.duolingo.com/HeikkiKnii

also i have set my usb mic as the default device as written here by someone before.-..

4 years ago

https://www.duolingo.com/nerv_

I have same problem on Ubuntu 16.04 LTS with Chromium and Firefox. It looks strange because my microphone works with Duolingo time by time :/

2 years ago

https://www.duolingo.com/hugobbmartins
hugobbmartins
  • 15
  • 14
  • 9
  • 4
  • 4
  • 3
  • 2

Try to use Google Chrome. It utilizes a updated built-in version of flashplayer.

Firefox and Chromium rely on flashplayer plugin installed in the system library. On linux the supported version got stuck in 11v series.

By the way, you can solve that issue by installing a updated flashplayer plugin derived from Chrome technologies:

  1. pepperflashplugin-nonfree (for Chromium technologies);
  2. browser-plugin-freshplayer-pepperflash (for Mozilla technologies).

Both packages are based on ppa repository I think, but your distro may have versions of it in the default repo. Good luck!

2 years ago

https://www.duolingo.com/bilboinamerica

Pepper doesn't seem to be available for 16.04? I have adobe-flashplugin installed but don't seem to find duolingo.com among the visited sites on http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager06.html Is there a way to add it?

2 years ago

https://www.duolingo.com/hugobbmartins
hugobbmartins
  • 15
  • 14
  • 9
  • 4
  • 4
  • 3
  • 2

Yes, it is available. You don't need to add a specific PPA nowadays. I've tested a distro based in xxbuntu 16.04 series. Look-up my last edition of the post above. I've corrected the package names respecting the package list nomenclature. Maybe you just need to activate third party repository to find it instead.

I think it's easier to find it using Synaptic package manager.

Let us know your progress. Maybe helpfull to anybody who is struggling with Flash issues on linux.

1 year ago

https://www.duolingo.com/bilboinamerica

It works in Firefox now, thanks.

1 year ago

https://www.duolingo.com/hugobbmartins
hugobbmartins
  • 15
  • 14
  • 9
  • 4
  • 4
  • 3
  • 2

You're welcome. Well done!

1 year ago