https://www.duolingo.com/SuzaF

Cyrrilic Alphabet - how to switch to from latin - Linux Mint and Firefox

SuzaF
  • 22
  • 13
  • 11
  • 8
  • 7
  • 7
  • 6

Dear fellow-learners,

I fail constantly in switching from latin to cyrrilic, my keybord sticks with latin. Russin language is instalöled, but if I switch the little botton in the test bos (upper left corner) nothing happens. Can sombody help? I searched the discussions here but did not find any solution. Thanks a lot and have a nice evening!

2 years ago

5 Comments


https://www.duolingo.com/slycelote
slycelote
  • 25
  • 17
  • 10
  • 7
  • 1418

I assume you have Cinnamon edition installed (that looks like this). If so, type 'Keyboard' into that text field in the screenshot that appears after you click the menu. Then click 'Keyboard' menu item and in the window switch to layouts tab. Make sure you have Russian and English layouts there. If you have, then you should see the flag in the lower right corner and be able to switch between layouts by clicking this flag or pressing Alt+Shift.

(I have an older version of Linux Mint, but yours should work in the same way.)

2 years ago

https://www.duolingo.com/SuzaF
SuzaF
  • 22
  • 13
  • 11
  • 8
  • 7
  • 7
  • 6

Dear Imbaimba12 and dear Slycelote, I've found it!!!!! In my distribution it's not a flag but the first two characters of the language (like "de" for German and "ru" for russian) and to finally have identified it makes my life a lot easier, not only in Russian. Thanks again for your kind help and have nice evening!

1 year ago

https://www.duolingo.com/Imbaimba12

Hey,

you can set the keyboard layout for different windows. So for example you have a text editor open and firefox, if you click inside the text editor and then change the flag you have russian in the editor and firefox still has latin chars.

If you click somewhere inside firefox and then the flag you should change the layout for firefox.

Maybe this will help. If not: Which Distribution? Which Window Manager?

2 years ago

https://www.duolingo.com/SuzaF
SuzaF
  • 22
  • 13
  • 11
  • 8
  • 7
  • 7
  • 6

Dear Imbain, thanks a lot! However, I already fail in finding the flag...I changed the textcoding into all viareities of cyrrilic but I never managed to finally type in cyrrilic. If I change the alphabet in the duolingo editor it only changes whether the text which I should translate is shown in cyrrilic or latin, my typing always stays latin. And this is very confusing, especially since the transcription in duolingo seems to be slightly different from the other learning platform I use. I use Firefoxx 44 for Linux and the lates version of mint is installed.

2 years ago

https://www.duolingo.com/Imbaimba12

Okay. I assumed you already have the flag there. Take a look at slycelote's answer, follow that and you should see it.

1 year ago
Learn Russian in just 5 minutes a day. For free.