Duolingo is the most popular way to learn languages in the world. Best of all, it's 100% free!

https://www.duolingo.com/Eliasz302

Microphone doesn't always work. Anyone else experience this?

I am doing a lesson and it says to click the microphone and read what I see. I did that, then clicked stop, and nothing happened. There was no error message or any other hint as to what happened. Most of the time, it works fine, but this seems to happen at random, about 1 time out of every 20. I don't know how to fix it besides either reloading the page or clicking the "I don't want to use a microphone" button. Today, for some reason, it has been happening so often that I can't finish a lesson without working around it. Is anyone else experiencing this? Does anyone know what to do about it? I am using Firefox on OS X 10.9.1. I reported this about a month ago and they haven't replied or fixed it.

4 years ago

8 Comments


https://www.duolingo.com/Eliasz302

Sorry about this. I got frustrated and posted that without thinking much. That said, I found a bunch of posts about microphone problems but not anything about the microphone not working intermittently. If I find out anything else, I think I'll mention it in this thread.

4 years ago

https://www.duolingo.com/KDNP
KDNPPlus
  • 12
  • 11
  • 5
  • 4

I'm having this exact problem. My microphone works most of the time and I can get through one or three or five lessons with no difficulty, then suddenly I get the same problem Mike reported. I have to click the "I do not want to use the microphone" button, finish the lesson, then go back to my settings and turn it on again. After that it has the same behavior as before: it works until it suddenly doesn't. The graphic moves as if it is recording my response to a question, but then the button goes back to the empty microphone after I click Stop. Reloading the page takes me back to the beginning of the lesson.

For bug tracking purposes (if anyone is doing so): I'm using Chrome on Windows 8.1 with a Logitech headset. I've searched the forums and there are lots of reports of microphones not working at all, but I have no seen any solutions posted for intermittent problems.

4 years ago

https://www.duolingo.com/Mademoiselle_Iv

I have exactly the same problem, except mine stops working 1 in 3 times, so i cannot finish "regularly" any lesson. I'm using Firefox on Windows 7. It may be something to do with Adobe Flash, although I do not get crash report, like with other sites when it stops working

4 years ago

https://www.duolingo.com/megan5marie

I think I have a workaround. It will still be an annoying issue, but if you can wait a couple of minutes every time this happens, you may not have to restart the lesson or disable your microphone.

The exact issue you described just happened to me (for what seems like the thirtieth time), so I opened another tab and searched for others with that issue. That brought me hear, but by the time I was done reading your issue and the responses, I heard the Duolingo "Correct!" tone dinging from my other tab--the one with the lesson in progress. I went back to that tab, and my microphone submission had finally been registered. It seems that maybe when this happens it's really only a very long (about 2 minutes, maybe?) delay rather than a total non-response, but until now I had always given up on it before those two minutes were up. I use Safari instead of Firefox, but it sounds like you are having the same issue. If you have the time, try waiting next time if you don't want to deactivate your microphone.

4 years ago

https://www.duolingo.com/Flavia-Anna

Hello! With me is happening the same problem. I don't know what to do. But I'm use Google Chrome... :/

4 years ago

https://www.duolingo.com/HUNTERGURL

i took off the microphone ability

4 years ago

https://www.duolingo.com/territrades
territradesPlus
  • 25
  • 21
  • 20
  • 14
  • 12
  • 8
  • 8
  • 7
  • 6
  • 4
  • 3
  • 1746

For this reason, I stopped using the microphone. Most the times it worked just normal, but sometimes there was absolutely no response.

4 years ago

https://www.duolingo.com/ILove264
ILove264
  • 13
  • 10
  • 9
  • 6
  • 5
  • 3
  • 3
  • 2
  • 2
  • 2

I'd just turn off the microphone option in your settings bar.

2 years ago