1. Forum
  2. >
  3. Topic: Troubleshooting
  4. >
  5. Lack of sound FIX

https://www.duolingo.com/profile/jerlikescats

Lack of sound FIX

I found the problem with the lack of sound is that there isn't support for Google Chrome. If you just use a different browser like Mozilla, you'll have sound! :)

February 22, 2013

15 Comments


https://www.duolingo.com/profile/tylrmurphy

Hey now, we do support Chrome. In fact, most of the team and most of our users access Duolingo from it.

Unfortunately, problems with sound and microphone input happen to people in certain browsers for various reasons. If you have extensions installed in Chrome, try disabling them, restarting the browser, and see if that fixes the problem. If you don't have any extensions installed, see if sound is working on other websites in Chrome like youtube.com.


https://www.duolingo.com/profile/rikiriki2bis

I did and tried everything. Not a single sound. Nothing. At all. With Chrome and IE.


https://www.duolingo.com/profile/bren
  • 2545

Try going here http://duolingo.com/#/word/es/hombre/Noun and click on the speaker. Does that play?


https://www.duolingo.com/profile/rikiriki2bis

SM2 SWF V2.97a.20130101 (AS2/Flash 8) ExternalInterface available Adding ExternalInterface callbacks... Testing Flash - JS... Flash - JS OK Waiting for JS - Flash... JS - Flash OK Enabling polling, 50 ms interval

Sound does not work. When I click on the speaker button nothing happens.


https://www.duolingo.com/profile/unitoto

I have the same problem as rikiriki2bis and dont know how to fix...:(


https://www.duolingo.com/profile/saurjk

I don't get any sound in firefox and chrome in windows as well as linux mint, however, there is sound in youtube and metacafe videos


https://www.duolingo.com/profile/rstanile

I use firefox, with multiple plugins. I had no sound, despite sound working OK in different sites. But I found the problem source, that was flashblock. I had to add duolingo.com to a whitelist. The rest of blocking addons (like adblock or scriptblock) were not causing any trouble. I'm posting this for other people.


https://www.duolingo.com/profile/saurjk

yes that worked... i tried adding www.duolingo.com to whitelist... but that didn't work... i had to remove www.


https://www.duolingo.com/profile/rikiriki2bis

Can you be more specific? Which white list? Windows firewall? flash options? Browser options? if it is just Firefox then for all the other browsers, the issue is still open


https://www.duolingo.com/profile/rstanile

In my case, the problems were caused by flashblock add-on for Firefox, so I added two domains to its (plugin's) whitelist: duolingo.com and cloudfront.net (the content is hosted by this provider), and restarted firefox. It worked.

I recommend everyone having problems with sound :check if sound works with the same browser on different sites that use flash (youtube for example), and if it is a case only with this SITE, add the mentioned domains to whitelists of any blocking addons you have.


https://www.duolingo.com/profile/Salty_Mango

I am a bit technologically challenged, so forgive the following question, but how do you add these two to the "whitelist"? Because I am still not hearing sound.


https://www.duolingo.com/profile/befree

-- but i want to ues G-chrome ..i don't want to change !!!! so how can i fix it .. i really hate waste my timee -- merdeee !!!


https://www.duolingo.com/profile/rstanile

You haven't been very specific. Please be:

Learn a language in just 5 minutes a day. For free.