1. Forum
  2. >
  3. Topic: Duolingo
  4. >
  5. Sound in Linux

https://www.duolingo.com/profile/ds36

Sound in Linux

I am unable to hear sound in linux. I am using Gentoo, Firefox, KDE? Sound is normal for any other programs that I am using.

June 23, 2012

19 Comments


https://www.duolingo.com/profile/v1ru5tx

Thanks a lot dude !!! I'M REALLY GRATEFULL WITH YOU !!


https://www.duolingo.com/profile/VThervin

Running Fedora 23 64-bit. This didn't work for me but thanks for the suggestion


https://www.duolingo.com/profile/elgranjulili

Hello. Try to do it again. I have updated the last week to new version of ubuntu. I had to make it two times because first did not work. GL ;)


https://www.duolingo.com/profile/iustitia

"Oops! That page doesn’t exist or is private." :/


https://www.duolingo.com/profile/ds36

I have solved the problem of hearing the sound samples. I use Flashblock to eliminate videos and annoying ads that start immediately upon entering a site. While it was not obvious to me that flash is used here, when I experimentally whitelisted duolingo.com and refreshed, I was able to hear the sound samples.

I had also tried eliminating pulseaudio (for essentially no good reason). I will try putting it back to see if it makes any difference whatsoever. I suspect not.

So, now I can settle in to mispronouncing Spanish...


https://www.duolingo.com/profile/VThervin

Finally fixed this on my Fedora 23 Firefox. Goto about:config and search for media.gstreamer.enabled -- set it to true and it should work. I did some steps before this though, installing rpmfusion to get the mp3 codecs https://ask.fedoraproject.org/en/question/42073/how-i-can-install-audio-codecs-like-mp3/

After installing the rpmfusion, my software auto-updater had 2 or 3 audio downloads that started prompting me to download. I updated those as well. Then the gstreamer.enabled worked.


https://www.duolingo.com/profile/StivensonRincon

In my fedora 20 (Updated) sound works perfect.


https://www.duolingo.com/profile/avikar

Do you have ALSA installed? Check up in your preferences on what applications allow sound. Does sound work in firefox? http://www.gentoo.org/doc/en/alsa-guide.xml


https://www.duolingo.com/profile/neilforshaw

Wikipedia has sound samples which the latest versions of Firefox can play without Flash. See if they are working http://en.wikipedia.org/wiki/File:German_alphabet-2.ogg


https://www.duolingo.com/profile/ds36

Thanks for responding. neilforshaw: The wikipedia sound samples worked just fine.

avikar: Yes, ALSA is installed. Yes, sound works in Firefox. Basically, I'm using sound with VLC, firefox, flash, or mplayer with no problems. I just verified that all devices are on within alsamixer.

Also, when I hit the sound button next to the words, you can see the little swirling symbol next to duolingo in the upper left corner. That suggests to me that the button is functioning, the audio is being downloaded. It just isn't being played.

It would be nice if there was a way to generate error messages.

Anyway, thanks for your help.


https://www.duolingo.com/profile/somethingaskew

I have the same problem using Ubuntu 12.04. I tried again on a Windows XP virtual machine, but no luck.


https://www.duolingo.com/profile/ezio.melotti

I use Firefox+Flashblock on Linux too and I can confirm that whitelisting http://duolingo.com fixes the problem.


https://www.duolingo.com/profile/seabre

@quakk I'm on Ubuntu 12.04 on Chrome. It's been working fine for me..


https://www.duolingo.com/profile/healsgood

32-bit Ubuntu 11.10, no Flashblock on Firefox, no sound. Was there a solve for this?


https://www.duolingo.com/profile/blobber

I'm using 32 bit Mint 13 with Firefox and flashblock. I tried the above suggestion about the whitelist, but it didn't help. So will go back to what I have been doing: Use a different browser for duolingo. Midori web browser plays the sounds perfectly. Can't get the microphone to work though but that is probably something to do with my settings.


https://www.duolingo.com/profile/VThervin

I'm on Fedora 23. When trying to play a duolingo sound sample, I got a prompt to install a MPEG-1 Layer 3 (MP3) decoder. However, the software manager that opened directed me to a fedora page saying that it's not available. Just posting this in case the Duolingo devs are reading https://fedoraproject.org/wiki/PackageKit_Items_Not_Found#Missing_Codec


https://www.duolingo.com/profile/ChaoticMind

Note: if you have shumway installed, try disabling it.


https://www.duolingo.com/profile/Alejandro296779

I had the esma proble in Ubuntu 16.04 and solved dby installing ubuntu-restricted-extras.

Good luck!

Learn a language in just 5 minutes a day. For free.