https://www.duolingo.com/AHemlocksLie

Flash request microphone permissions. Every. Single. Time.

Every single time I have to use the microphone, multiple times in every lesson of every unit, Flash requests permission for Duolingo to access my microphone and camera. Yes. I will allow this.

So, I try going into the Flash Player settings in the control panel and adding a rule just for Duolingo, maintaining that all other sites need to ask permission. Nope. Maybe if I ban all sites completely but keep its exception? Nope, now the setting page pops up every time, but when I close it, instead of then asking permission, it just doesn't record anything.

Okay, so I track down a settings page on the Flash website that actually has a little Flash window to change your settings. Everything looks golden. It seems my Duolingo entry, it confirms it's allowed, it seems properly spelled, "duolingo.com".

How the !@^# do I get it to stop asking me constantly! It's extremely slow and unresponsive, forcing me to move the mouse into position and waiting several seconds to click, lest my attempt to use the buttons be utterly ignored. Even with a global ban and a unique exception rule, it STILL opens a small settings window first before not working.

March 2, 2013

6 Comments


https://www.duolingo.com/kristinemc

That is very frustrating! So, we also have little control over flash. Does your flash permissions box look like this image: http://www.chat-avenue.com/images/flash.jpg? Have you made sure to check the 'remember'checkbox?

March 2, 2013

https://www.duolingo.com/AHemlocksLie

No, I don't get that. The first window looks like this: http://i.imgur.com/0oeLw5Y.png and when it pops up, I have to put the mouse over it, wait a couple seconds, then click, or else it can't process it for some reason. Then, after I click close, I get http://i.imgur.com/sRsGT7V.png this one. Again, I have to get in position and wait patiently before clicking. That part in particular makes it extremely annoying because I can't just click through it. It seems like it's struggling to process something, but I have a 6 core 3.2 GHz processor, so that should NOT be an issue.

March 2, 2013

https://www.duolingo.com/breezelbrille

I have the same issue, with exactly the same dialogs. It occurs using Chrome on my Mac. Firefox accepts the global flash settings, but Chrome seems to ignore this. I would be glad, if someone found a solution, because I couldn't so far.

May 12, 2013

https://www.duolingo.com/atenas2007

Is there a Mac answer? I authorized the mic and camera in Flash, but duolingo does not recognize it.

May 18, 2013

https://www.duolingo.com/joanlaw

280317 Seems this is still going on years later. May have to turn off the oral version. Most frustrating.

March 27, 2017

https://www.duolingo.com/roykil

I actually managed to get it working in Firefox again, after very long time with this frustrating problem (had to use Microsoft Edge to use Duolingo...). I uninstalled flash completely, rebooted my pc and re-installed flash. Now it works in Firefox again... :)

March 29, 2017
Learn a language in just 5 minutes a day. For free.