https://www.duolingo.com/mattoleriver

No slow Esperanto

The title says it all; the turtle button does not work (for me) in Esperanto. I am using Ubuntu 16.04 on a desktop and have no troubles with this feature on English>Spanish or Spanish>English but it will not work for English>Esperanto. I click on the turtle and am rewarded with dead silence.

May 7, 2017

4 Comments


https://www.duolingo.com/Zerr_

The "slow" option works because they use a text-to-speech (TTS) bot, otherwise known as a "robot voice". They can make the voice talk as quickly or as slowly as they want it to.

Spanish, French, English, German, etc., have a TTS. Unfortunately, for Swahili, Vietnamese, Irish, and indeed Esperanto, as well as a few others, there was no good TTS, so they had to get a real-life human to record each and every of the thousands and thousands of sentences in the course.

If they wanted to have "slow" sentences for each and every sentence, they would need to re-record each and every of the tens of thousands of sentences, which of course they're not going to do. That's also why there are no hover-word-voices and no sound on the "select-a-word" exercises.

It's really hard to slow down or speed up audio without distorting it, so the "slow" option was disabled.

May 8, 2017

https://www.duolingo.com/mattoleriver

Thanks, great explanation.

May 8, 2017

https://www.duolingo.com/OrcaDuo

That's odd. Does sound work in other applications? Ex: Tinycards

May 8, 2017

https://www.duolingo.com/sirhalos

Esperanto never had a slow option since it uses real recordings. Spanish has it because it is using a computer generated voice.

May 8, 2017
Learn a language in just 5 minutes a day. For free.