https://www.duolingo.com/merigreenleaf

Help! I can no longer switch the language setting

I'm hoping someone can help me figure out how to change my language setting back to English. I had previously been switching it back and forth between English and Spanish so that I could continue practicing my English-to-Spanish tree while also working on the reverse (Spanish-to-English) tree. Today I logged in to the site to change the setting back to English and the settings page changed! There's no longer an option for selecting the languages where I can choose options like "I want to learn Spanish. I know English" like on the help page: https://support.duolingo.com/hc/en-us/articles/204644534-My-account-is-in-a-language-I-do-not-understand-How-do-I-change-it-back-

All I see now is "language" then a drop down menu of 8 Spanish-to-another-language courses. It's like the site thinks I'm logged out and is prompting me to start a new course from scratch, but I'm not logged out. Has this happened to anyone else? How do I get the other language settings page back where I can select all the options from the drop down? How do I change the language setting back to English?

Edit: A big thanks to Paralars1! I got the language back to English, but I still don't have my old language setting page back. Now it's doing the same thing as before, just in English, so instead of having the option of all the courses to pick from in any language combination, I only have the 20 or so available from English. I'm trying to figure out if this is a bug or if it's a new feature/change that Duolingo rolled out. Edit edit: And apparently this is a new feature for Duo. It would have been nice if the help page had changed to reflect this so I wasn't completely baffled, but at least I know now how to switch between languages.

June 14, 2017

16 Comments


https://www.duolingo.com/Paralars1

There should be a button below that dropdown that will take you to another screen, where you can select both your spoken language and your desired course.

June 14, 2017

https://www.duolingo.com/merigreenleaf

The only button below the drop down of 8 languages says "ver todos los cursos de idiomas" so it's prompting me to view all courses so I can select a new language to learn. The original drop down menu where I could select my spoken language/desired course isn't an option. :( I have a link below this that says in Spanish "start from scratch or learn new languages" but that page doesn't give me the change language settings option either.

June 14, 2017

https://www.duolingo.com/Paralars1

So if you click that button, you go to this screen

https://picload.org/image/ripidlpi/scrnsht.png

right? If you choose English in the top right dropdown and then click the Spanish course, doesn't that work?

June 14, 2017

https://www.duolingo.com/merigreenleaf

AHA! That did work! For some reason it made me click the button to start a new course and that changed the language setting back to English. That's really strange! Now that I'm back on the English side, the settings page is still messed up though. Instead of it giving me all the different language options that it did before, I still have the limited drop down where it's just the languages offered in my selected language. So your idea worked and got me back to English, but I still don't have my old language settings page back.

June 14, 2017

https://www.duolingo.com/Paralars1

That's just the new layout. Didn't you see everyone complain yet?

June 14, 2017

https://www.duolingo.com/merigreenleaf

No because I was stuck in Spanish and couldn't navigate the site or figure out what was going on in the forum. LOL! Thank you so much for your help!

June 14, 2017

https://www.duolingo.com/merigreenleaf

I hadn't clicked to start the Spanish course because I was afraid it was going to reset my progress. It looks like the next screen it takes me to is one that starts a course, not continues what I was working on. I guess it's worth a try though because nothing else is changing this back to English.

June 14, 2017

https://www.duolingo.com/Paralars1

I just tried switching back and forth myself this way and it didn't reset anything

June 14, 2017

https://www.duolingo.com/Roman_Cyfko

I dont now how to do it :(

June 14, 2017

https://www.duolingo.com/PolyglotPearl

Hi merigreenleaf!
Could you change this to troubleshooting? That's where discussions like this belong.
To do so, click edit. At the top left hand corner of the page the a drop down bar, where you can choose the topic.
Thanks!

June 14, 2017

https://www.duolingo.com/merigreenleaf

That wasn't an option when I posted the question (just Duolingo: English, then something like french and spanish), but I changed it now. Like I said, the language setting is stuck on one that isn't a language I'm fluent in and I'm having a tough time navigating the site.

June 14, 2017

https://www.duolingo.com/PolyglotPearl

Yes, that's true. When you go to discussions, it shows what you're subscribed to, right? Click on Troubleshooting. You then have to post it while you're in the Troubleshooting forum.

June 14, 2017

https://www.duolingo.com/merigreenleaf

Ah! Okay, now I know. Unfortunately it seems to have placed this in the Spanish Troubleshooting forum because all the other questions are in Spanish. That's not going to be too helpful because there's no way to place this in the English one. :(

June 14, 2017

https://www.duolingo.com/PolyglotPearl

Huh. I don't know how to change that : (

June 14, 2017

https://www.duolingo.com/Paralars1

I guess that would be something like "solución de problemas", then ;)

June 14, 2017

https://www.duolingo.com/merigreenleaf

Yup, that's where I moved it to. :) It wasn't originally an option for me to pick when I started the post. I have no idea why.

June 14, 2017
Learn a language in just 5 minutes a day. For free.