https://www.duolingo.com/cazort

"Alternate" Discussion Page That is Broken

On a small portion of exercises (probably <10% of them), when I click the button to open the discussion page, it opens a page with a different-looking look-and-feel. There is no sound button to play the sound (which is annoying because 90% of the time I visit a discussion page it's just because I want to hear the sound for an exercises that had no button), but also, if I try to post, it gives me a 404 error.

Here's a screenshot of the "alternate" page: https://imgur.com/a/iexzo

the URL of the page I used to generate the screenshot: https://www.duolingo.com/new-comment?fromLanguage=en=de=ec60b20668a84c580112c142d54be0b0

Here's a screenshot of what the "normal" page looks like: https://imgur.com/a/30mhK

and the URL of a normal page: https://www.duolingo.com/comment/7468943

Does anyone know what is causing this and if there is any workaround, or if the DuoLingo people could fix this glitch?

September 23, 2017

10 Comments


https://www.duolingo.com/SatharnPHL
Mod
  • 1137

When nobody else has commented on a particular exercise, the discussion page for that exercise doesn't exist, so you get the "new-comment" page from your first screenshot. As far as I know, that has been the "new normal" for the last few months, since they updated the site to remove the activity stream, and streamlined the exercise pages. You shouldn't be getting a 404 when you submit from that page, but you'll have to submit a bug report for that (though I think there there were some server problems earlier today - maybe you were affected by them when submitting your discussion).

September 24, 2017

https://www.duolingo.com/cazort

This makes sense.

I have had this problem persistently, whenever I try to start a new discussion then, since the redesign.

Also as a side note, removing the speaker from the "New Discussion" page seems very bad since 90% of the time I'm only clicking through to the discussion page because I want to get access to the playback feature.

Why they don't just make the playback available on the exercise page itself and save me the trouble, is totally beyond me.

September 24, 2017

https://www.duolingo.com/lilyflower231

Have you tried submitting a bug report?

September 24, 2017

https://www.duolingo.com/cazort

Yes. I have tried and I don't know whether or not it was received. When I submit a bug report I get no verification that the submission went through. Like I hit submit and it just takes me to this page:

https://support.duolingo.com/hc/en-us?return_to=%2Fhc%2Fen-us%2Frequests

With no sign or verification that my report went through.

It's incredibly demoralizing...am I wasting my time filling out these reports? Are they lost in space?

September 24, 2017

https://www.duolingo.com/lilyflower231

No, they definitely go through. I have had more than one be followed through on. However, it usually takes maybe a week or so for the team to see them, so perhaps just wait a few days.

September 24, 2017

https://www.duolingo.com/cazort

This is really bad UI design / flow for them to not send a message saying that the bug was received...especially given that it's sending me to a page where it's showing me a bunch of Q&A things, given that many sites send you FIRST to a page like this before actually sending the report...

September 24, 2017

https://www.duolingo.com/piguy3

Do you have e-mail notifications turned off? I have always gotten an e-mail when I send a bug report.

September 28, 2017

https://www.duolingo.com/cazort

Yes, I do have e-mail notifications turned off.

September 28, 2017

https://www.duolingo.com/piguy3

I would guess that if you turn them back on before submitting a bug report, you will receive a formulaic e-mail upon submission (among other things reiterating that you are unlikely to receive a personal reply). By this point I have probably submitted dozens and have received one which was non auto-generated. Perhaps that one would have come through even with notifications off, but as it came from the same system, I can't say.

September 28, 2017

https://www.duolingo.com/piguy3

I have this problem all the time. Unaware of a workaround. We'll have to hope they get around to fixing it.

September 28, 2017
Learn a language in just 5 minutes a day. For free.