https://www.duolingo.com/TerraZe

Chinese won't release control of CTRL+space, so timed practice in another language is messed up

I've been taking some Chinese, but the Windows controls won't stop taking over the CTRL+space key sequence even if I change the sequence in the language bar.

I'm working on finding a work around for that (without uninstalling and re-installing the language when I need that key sequence), but right now I can't really do speed tests without using the mouse, because I always hit CTRL+space to get the person to repeat what they said, but that doesn't work, because Chinese takes it over and uses it to switch formatting (so you can go between Chinese character input and Latin character input).

Maybe there is a way to allow us to set preferred keystroke listeners for timed practice on our account or have a choice between a few.

I'm not sure if anyone else has this problem.

EDIT: it's a setting under the "Advanced Key Settings" in the keyboard language settings (specifically called "Text Services and Input Languages") at the bottom called "Chinese (Simplified) IME - Ime/Nonime Toggle" of which there are only a few settings: first box has a choice of "Ctrl, Ctrl + Shift, Left Alt + Shift" and the second box has a lot of other keys including "Space", "Page Up", A-Z, etc. Right now it's on "Left Alt + Shift, Page Down", but "Ctrl, Space" still takes over anyway. ... and disabling this doesn't help. It switches itself back on.

EDIT2: to be clear, Shift+Ctrl+Space still works, but when you have a long sentence, that doesn't always work out for the best in timed practice. Plus, I inevitably hit, Ctrl+Space and set the keyboard to Chinese character entry, which causes me to flutter around getting the keyboard back. I can simply hit ctrl+space again to get to nonime, but I still want to listen usually, so even have to use the mouse or listen to the slow one which isn't good when you have seconds to spare.

April 18, 2014

17 Comments


https://www.duolingo.com/Lrtward

I don't know what keyboard emulator you are using, but I have English and Spanish keyboards set up on my Windows computer and my hotkey sequence is alt-shift by default, but I can change it. Maybe you can change your hotkey sequence? I know NOTHING about Chinese character set keyboards, though, so I apologize in advance if I'm out in the weeds. Just an idea.

April 18, 2014

https://www.duolingo.com/TerraZe

I have Portuguese on the keyboard that I switch between, and never had this problem. It only started with Chinese. I even know it's the Chinese, because it comes up every time I hit CTRL-space, and I've even used CTRL-space to shift between the formatting. I change the sequence, but it's not taking. I've found a page that might work, but it involves changing a few things in the registry. I'm going to look for other work-arounds before I try something like that.

BTW, what you are talking about was disabled because of this problem (I disabled all settings, but it didn't help, as that won't even be disabled). The problem is a IME/nonIME setting that's specific to Chinese (and probably other similar langauges).

April 18, 2014

https://www.duolingo.com/Lrtward

Well, shoot. I've not nothing. I do, however, appreciate your followup post with more information. Perhaps someone more knowledgable than I will have a suggestion.

April 18, 2014

https://www.duolingo.com/TerraZe

NP, thanks for trying to help. I added more info to the original post to spell it out better. I'm finding it's a common problem online, even after you remove the language sometimes.

April 18, 2014

https://www.duolingo.com/FrankySka

Hi,

You might get better responses if you move your post to troubleshooting. This way it may be more visible to the team.

To do that click “edit” below your post, and than scroll up to the top to choose this forum in the drop down menu. Then save!

April 18, 2014

https://www.duolingo.com/TerraZe

Oh, OK. I'll move it.

... It's moved.

Thanks.

April 18, 2014

https://www.duolingo.com/nightshifted

You can get around this bug by editing the registry, but I don't recommend doing this unless you're familiar with editing registries. Instructions: http://superuser.com/questions/327479/ctrl-space-always-toggles-chinese-ime-windows-7

April 18, 2014

https://www.duolingo.com/TerraZe

Yeah, that's the one I already found, but want to save that for last. I've edited registries before, but I like to save that as a last result (don't worry, I'll back it up if I go that route). I was hoping someone that uses Chinese knows a trick or two to get around this. I have a feeling editing the registry may be the only way around it.

April 18, 2014

https://www.duolingo.com/RichN

I solved this issue by changing the key combination into something that, so far, I've never needed to press: ctrl+`

Hope this helps.

April 18, 2014

https://www.duolingo.com/TerraZe

Ctrl+` isn't even an option for IME/nonIME toggling. Do you have an east Asian language installed? ... or maybe for any language that doesn't use Latin characters, but I'm not sure exactly.

April 18, 2014

https://www.duolingo.com/RichN

In the dropdown, the symbol actually looks like this: '`' including the single quotes. Right between "SLASH" and "LBRACKET" (yes, all caps, no quotes).

Can you find it?

April 18, 2014

https://www.duolingo.com/TerraZe

No, you don't understand. for the IME/nonIME toggle, you can't put what you want. It's a list that doesn't have "`" at all. It does have "Ctrl" as a start to the key sequence, but "`" isn't listed. It doesn't show that.

Thank you for trying to help.

April 18, 2014

https://www.duolingo.com/RichN

This is how it looks like on mine, if yours is different, then I'm sorry.

image

April 18, 2014

https://www.duolingo.com/TerraZe

Oh, I'll be damned. There it is. Thanks... I really didn't see that. It wouldn't have helped since changing the key sequence wasn't helping, but I still should have looked harder.

It worked itself out from yesterday, and I'm not sure why. I had changed the key sequence to a few things (and apparently didn't actually "read" all the sequences), but it didn't release Ctrl+space which was the problem. I tried restarting, and I removed and put on a few languages. Maybe I should have restarted again, because when I tried to do it this morning, the language bar had released control of "Ctrl+space" back to me.

... and I and using the key combination you showed too, because it's right at the end of the keyboard, and it is something uncommon. Thanks.

... I had to re-install a nonIME Chinese keyboard to switch between and was worried it would do it again. I had to restart to get everything running, and it worked. I'm just happy I didn't have to go into the registry. Thanks again.

April 18, 2014

https://www.duolingo.com/RichN

I'm glad that you've solved your issue.

April 18, 2014

https://www.duolingo.com/TerraZe

I'm not sure what exactly solved the issue, because I did change it before. I just didn't see the "`" symbol (I kind of saw it, but didn't really know what it was). But I am really thankful for the help and for the suggested key sequence, because it will help.

April 19, 2014

https://www.duolingo.com/TerraZe

Yay, I woke up this morning and it's solved... and I don't know why. It can't be restarting, because I already tried that. I never got around to editing the registry. I did delete and add a few languages trying to trigger something, but that didn't appear to work either... That was the last thing I really did. Maybe something did trigger something. Oh, well. It released Ctrl+space to me again. I wish I knew what helped it.

I just did a time practice.

April 18, 2014
Learn a language in just 5 minutes a day. For free.