1. Forum
  2. >
  3. Topic: Troubleshooting
  4. >
  5. Problems related to OpenDNS??


Problems related to OpenDNS??

For about the past week I have been having lots of problems accessing the site. I get a page from OpenDNS saying "Hmm, www.duolingo.com is not loading now..." It seems to be totally random--not related to any specific portion of the site, and happens about 1 out of every 5 times I navigate to a new page.

Similar problems were recently reported and attributed to Firefox, but I use Chrome. Other than that it seems like the same problem.

I changed from OpenDNS to my ISP's DNS server. I also disabled a setting on Chrome along the lines of "use internet traffic information to speed download." I have not had the problem since.

April 24, 2014


  • 2450

Since you're configuring your DNS servers in the OS / browser, hopefully what I'm about to say is meaningful: Our DNS entry for www.duolingo.com is actually a CNAME to something that Amazon Web Services controls. I suspect that OpenDNS might not be respecting the duration for which it should cache those entries. Amazon will periodically change the machines it uses to support www.duolingo.com, and when that happens, the DNS resolution provided by OpenDNS could become out of date and no longer valid. That would cause the error message you see. It's also possible that the setting you changed in Chrome caches DNS lookups for longer than it should in an effort to speed up page loads.

I haven't had this problem in the few years I've been working on Duolingo, and will try to investigate more whether this is an OpenDNS/chrome settings issue. Please do let us know if you keep having this problem!

  • 2450

I looked at the OpenDNS responses using the "dig" command and it seems like they do respect the cache duration. Were you having problems with other sites at this time? I might also suggest trying Google's DNS resolver if you don't trust your ISP's DNS for some reason.


I was not having problems with any other sites. And I have not had the problem since I changed those settings. I suspect you are on the right track about the cache duration, etc. Whatever the problem it seems solved, but I am surprised others were/are not having it.

Learn a language in just 5 minutes a day. For free.