Can't access a new skill. Please help?

I've been working on the Russian course for several months lately, and I've reached the People 2 skill. But for some reason Duolingo says I've already completed it, yet I can't access the skill at all even just to practise it.

Any help would be much appreciated.

Here is the link to a screenshot:

July 1, 2018


What happens when you click on the "People 2" circle?

July 1, 2018

The loading screen (with the three dots) appears for a second but then I just get returned to the homepage. By the way I've tried this with both Microsoft Edge and Google Chrome so I don't think it's a web browser problem.

July 1, 2018

I suggest submitting a bug report in that case. I really thought the issue was going to be with cache/history but if it happens on two browsers that's not the problem.

Here's where you report a bug:

Also, it does appear that there's something flaky going on with that skill. Here's a post I just saw from eight hours ago: Russian - People 2 unlocked by itself

July 1, 2018

Many thanks for your help, I really appreciate it.

July 1, 2018

There is a red dot behind your skill:

Can you try this:

Probably it does not work anymore (as stated in another thread about another tree), as the new A/B "skill crown test-out" code has been re-engineered, rolled out end of June, and replaced the old "lesson test-out" code.

Your extended user profile is corrupt, for any reason (usually tree updates result in converted, but corrupted, skills).


Is currently the reason that no NEW skills are unlocked, as your skills Sport and "Weather and Nature" have the same problems.

  • lesson_number 1
  • skill_title "People 2"
  • skill_url "People-2"

People 2

  • name "People 1" (seems to be wrong as name is expected to conflict with your previous skill!?!)
  • short "People 2"
  • title "People 2"
  • url_title "People-2"
  • num_missing (lexemes): 35 of max 35 num_lexemes
  • missing_lessons 5

Either staff resets your skill to L0 (you can not do that for yourself) or they change their new "test-out" code that it also resets/updates the old lesson variables accordingly.

I expect new problems with the other two resetted skills...maybe works, maybe not (they are related if you can strength words, even lessons have been RESET).

If you choose to submit a bug report, you may want to include a link to this thread and my further explanations.

We actually had similiar problems in other Spanish or French trees for other users, but we could solve them earlier ourselves in the first weeks of June (before the new A/B code rolled out).

Users had reported back that the old "skill lesson test-out" (which is not available anymore) solved all their tree and extended user profile issues!
This was also the case for my updated EN-PT tree.

July 1, 2018

I have the exact same issue (submited bug report with link to this comment). What does the red dot on duome mean?

July 7, 2018


Either that the lessons have been reset for this skill in your tree (e.g tree updates)


that there is a bug contained in the code controlling skill unlockings.

You can see in the above comment$comment_id=27837513 that the "People 2" skill seems to use an incorrect name "People 1".

Just guessing...

July 7, 2018

Ok ok, agora já percebi. Muito obrigado pela rápida resposta.

July 7, 2018
Learn a language in just 5 minutes a day. For free.