https://www.duolingo.com/profile/SnarfSnarf123

Practice broken

The practice button no longer works for me. On the mobile app I just "an error has occurred" and the banner stays on my phone even when I exit the app so I then have to force stop it or reboot. So then I tried the web app and clicking the button just does nothing now. All this was working previously. The Chrome debugger shows the POST https://www.duolingo.com/2017-06-30/sessions is giving an HTTP 500 error:

vendor-ddd8b654.js:48 POST https://www.duolingo.com/2017-06-30/sessions 500 () (anonymous) @ vendor-ddd8b654.js:48 (anonymous) @ vendor-ddd8b654.js:21 t.exports @ vendor-ddd8b654.js:21 t.exports @ vendor-ddd8b654.js:98 Promise.then (async) XmWMX.r.request @ vendor-ddd8b654.js:67 r.(anonymous function) @ vendor-ddd8b654.js:67 (anonymous) @ vendor-ddd8b654.js:48 (anonymous) @ app-b80705c4.js:1 r @ app-b80705c4.js:1 (anonymous) @ app-b80705c4.js:1 (anonymous) @ app-b80705c4.js:1 Wsg1/.Ra @ app-b80705c4.js:1 gi @ app-b80705c4.js:1 (anonymous) @ app-b80705c4.js:1 r @ app-b80705c4.js:1 (anonymous) @ app-b80705c4.js:1 (anonymous) @ app-b80705c4.js:1 Wsg1/.Ll @ app-b80705c4.js:1 (anonymous) @ app-b80705c4.js:1 (anonymous) @ vendor-ddd8b654.js:21 (anonymous) @ app-b80705c4.js:1 r @ app-b80705c4.js:1 (anonymous) @ app-b80705c4.js:1 (anonymous) @ app-b80705c4.js:1 Wsg1/.PS @ app-b80705c4.js:1 t.sessionCreate @ app-b80705c4.js:1 t.componentDidMount @ app-b80705c4.js:1 t.notifyAll @ vendor-ddd8b654.js:73 close @ vendor-ddd8b654.js:48 closeAll @ vendor-ddd8b654.js:93 perform @ vendor-ddd8b654.js:93 perform @ vendor-ddd8b654.js:93 perform @ vendor-ddd8b654.js:98 S @ vendor-ddd8b654.js:98 closeAll @ vendor-ddd8b654.js:93 perform @ vendor-ddd8b654.js:93 batchedUpdates @ vendor-ddd8b654.js:98 i @ vendor-ddd8b654.js:98 dispatchEvent @ vendor-ddd8b654.js:21 t._rollbar_wrapped.t._rollbar_wrapped @ vendor-ddd8b654.js:48

September 3, 2018

4 Comments


https://www.duolingo.com/profile/Lrtward

Well that sounds nasty. Have you tried uninstalling/reinstalling the app?

If the problem persists after reinstalling, you could submit a bug report: https://support.duolingo.com/hc/en-us/articles/204728264-How-do-I-report-a-bug-

September 3, 2018

https://www.duolingo.com/profile/Angomr

Im having the same problem, really annoying not being able to go over previous topics as easily

September 3, 2018

https://www.duolingo.com/profile/SnarfSnarf123

Yes it's very buggy. I did 3 practices in a row just now and then forth just broke. Once it breaks it won't work again for ages however many retries I do. The normal lessons work fine and I have full 4G and WiFi signal sat next to my router. So clearly there is a bug in the practice code somewhere. It's not just mobile either I get it at work on the web app as well with a super fast ethernet connection.

September 8, 2018

https://www.duolingo.com/profile/SnarfSnarf123

Still getting this on my Moto G4 and Windows 7 desktop with Chrome browser although they seem to have fixed the banner so it no longer stays forever on Android. What's wierd is that the lessons always work for me on the android app and on the web and practice hardly ever works - maybe 1 in 10 attempts and retrying never works. Please please fix!

September 19, 2018
Learn a language in just 5 minutes a day. For free.