https://www.duolingo.com/fazulakis

Size of accents in DL fonts

I'd like to raise an issue regarding the fonts used in DL.

It seems to me that the size of accents is too small. In particular, it is sometimes difficult to distinguish "i" from "í", which makes learning more tiring. Also, accented capital letters have tiny, difficult to spot accents in small print. For example: "Ó" vs "O".

Whereas the standard sans font in DL is generally beautiful and very readable, this accent issue is really bothering me.

And by the way, no, I don't suffer from any special eyesight issues! :)

Thank you everyone for this great resource!

September 20, 2018

11 Comments


https://www.duolingo.com/scilling

This is a long-standing issue with their choice of the Museo Sans Rounded typeface. If you use Duolingo in a Web browser, a workaround can be found in this discussion.

September 20, 2018

https://www.duolingo.com/fazulakis

Thank you for this scilling. However I have tried it and my "fadas" are still pea-sized. On the other hand it'd be better for everyone if DL would just cop on, instead of having to mess with our browsers.

September 20, 2018

https://www.duolingo.com/scilling

Is Museo Sans Rounded still being displayed in your browser? Did you try restarting your browser after installing either Stylus, Stylish, or Tampermonkey? Did you use the default typeface choice of Verdana in the user style/userscript? (Verdana’s síntí fada are not pea-sized.)

Duolingo is not concerned with how legible the diacritics of Museo Sans Rounded are, so any typeface changes will need to be done on a per-browser basis.

September 20, 2018

https://www.duolingo.com/fazulakis

Yes, I did restart after installation. But no luck, still stuck with Museo Sans Rounded. I am running Firefox ESR 52.9 in Linux.

September 20, 2018

https://www.duolingo.com/scilling

Did you use the default typeface choice of Verdana when you’d installed the user style? If you did, are the Verdana font files installed on your Linux system? (They’re often found in a package named “ttf-ms-fonts”.)

I’m running an older version of ESR Firefox, but the @font-face rules that I’m served still match the rules that the user style overrides. If you view the source of this discussion page in your version of Firefox, is there a JavaScript assignment of the variable window.duo.stylesheets there? If there is, what strings are assigned to it?

September 21, 2018

https://www.duolingo.com/fazulakis

Thanks for your help, but I'm still bumping my head over this with Firefox. I've tried all combinations and permutations but nothing happens. Maybe some other extension is messing up my settings, I'll have to do a clean start...

Verdana is definitely installed, and I'm leaving all defaults. I'm doing a browser restart after every installation/uninstallation. When I check the source (CTRL-U) I can see window.duo.stylesheets with value ["/css/ltr-00926682.css","/css/rtl-1e12e7994d.css"].

Don't waste your time any longer, it has to be some issue on my side. I'll try other browsers.

September 24, 2018

https://www.duolingo.com/LICA98

yeah it sucks

I use a font changer and it worked great until the recent site update when it started forcing their font every time the page was reloaded (so to get my font I had to click on the font changer icon every time and only then it changed)

a couple of days ago I got fed up with that and installed another font changer and this one is "stronger" so it doesn't let the page to force their font

(but there is a downside to the new font changer that it changes the font on every page you visit (on the previous one you could set it not to change))

September 20, 2018

https://www.duolingo.com/fazulakis

Thanks, can you please give more details? I've tried scilling's tweak above but somehow it does not work for me.

September 20, 2018

https://www.duolingo.com/LICA98

the font changer I used first https://chrome.google.com/webstore/detail/font-changer-with-google/jgjhhoglgjdklldfgoffdiaceffijeke

the one I use now https://chrome.google.com/webstore/detail/force-custom-fonts/hckjchjpkmbihoocajjpjajkggbccgee

(this works only in google chrome, so if you use another browser try googling font changer for that browser)

September 20, 2018

https://www.duolingo.com/fazulakis

Thanks a lot, I don't normally use Chrome but I'll give it a try!

September 20, 2018

https://www.duolingo.com/suellen007

Thank you!. For those of us who do have eyesight issues, I just leave them out entirely! :))

September 21, 2018
Learn a language in just 5 minutes a day. For free.