https://www.duolingo.com/profile/ladyzaba

No speaking exercises in the web app

I'm doing French, Russian and German and in my Androind app I have some speaking exercises (since I've chosen to have them in the settings), but not while working on my notebook in the web app. And I can't find where to allow them :-(. Any advice, please?

January 3, 2019

9 Comments


https://www.duolingo.com/profile/ladyzaba

Thanks, but the problem is I can't turn the microphone on, there's no such a choice for me :-(. I've tried in Vivaldi and Firefox, it's the same. Maybe I should somewhere enable Duolingo to use mic, but I'm not able to find where :-(. My microphone works well, I've tried in a recording app and it's OK.

January 3, 2019

https://www.duolingo.com/profile/pentaan

@ladyzaba

I've tried in Vivaldi and Firefox

https://support.duolingo.com/hc/en-us/articles/204642264-My-microphone-is-not-working-How-can-I-fix-it-

1. Check that you are using Google Chrome. Microphone exercises only work on Chrome.

January 4, 2019

https://www.duolingo.com/profile/ladyzaba

Now I'm using Chrome (just for Duolingo). Microphone is turned on (and it's working for other applications in my comp), but I still don't get any speaking exercises in web based Duolingo :-(.

March 29, 2019

https://www.duolingo.com/profile/Arachnje

Did you make sure to give duolingo the permission to use the mic on your browser? To check that on Firefox, try this:

  • Right-click a blank area of duolingo's course page, and choose View Page Info, then click the Permissions tab.

  • Scroll down to Use the Microphone. If the permission level is set to Always Ask, uncheck the Use default box, then change the permission to Allow.

  • Close the dialog box and refresh the page or restart the browser to see if it works.

January 4, 2019

https://www.duolingo.com/profile/ladyzaba

I feel like I was really stupid, but I can't find “View Page Info” after right-clicking a blank area of Duolingo's course page in Firefox (as well as in Vivaldi) :-(.

January 4, 2019

https://www.duolingo.com/profile/Arachnje

You should see it (or an option phrased differently but referring to the page info) on the pop-up menu that appears when you right-click on the blank area of the page:

Duolingo course homepage, showing the pop-up menu that includes "View Page Info" option highlighted in blue.

January 4, 2019

https://www.duolingo.com/profile/ladyzaba

Thanks a lot. I've managed to find this setting in Firefox (not in Vivaldi, which is my default browser), allowed using mic without asking, restarted FF, and I still can't see this option in Duolingo :-(.

January 4, 2019

https://www.duolingo.com/profile/Katja-z

"View Page Info" is not a choice when I right-click on a blank area of a page for me either. Is there a way to enable that? And if so, how?

I tried different sites and on none of them does the pop-up menu display "view page info".

May 2, 2019
Learn a language in just 5 minutes a day. For free.