1. Forum
  2. >
  3. Topic: Duolingo
  4. >
  5. Facebook connect not working


Facebook connect not working

I am trying to connect my account with my facebook, but the button is not doing anything when I press it. Any idea how to fix this?

July 18, 2012



I was able to link my account by opening an anonymous tab in Chrome.

But when I try to find my Facebook friends, I can not.


Thank, it worked for me as well! The button Find Friends on Facebook didn't worked for me either. So I disconnected, and then I couldn't connect anymore. So I did as you suggested, in Incognito mode, I was able to connect again, and then I was also able to Find friends on Facebook!


Same thing happened to me with Chromium + Ghostery addon. I had to add an exception for the Duolingo site.


im using the kindle fire app and it was posting my progress to fb but now its not, how can i fix this?


I'm having the same issue, but on an iPad. The share/Facebook button doesn't seem to be doing anything. Are these extensions on the iPad too?


This could be caused by addons like DNT+ and such. Try temporarily disabling those addons for this particular site.

  • 106

Another add-on that causes this is "Facebook disconnect"

Anything like that will do that. It has nothing to do with duolingo.


This fixed it for me; thanks a lot.


How do i get rid of that add on?


The same thing is happening on my iPhone. Nothing happens when I try to sign on with Facebook, which is how I created my account.

[deactivated user]

    I disabled both Ghostery and uBlock and it's still doing nothing


    Same, not working for me.


    Doesn't log in an my mobile phone with the FB app. Would like to hear how to fix this.


    6 years later and this still isn't working, lol


    It works with this workaround : Disconnect, and then open a new browser in Incognito mode, then I was able to connect again, and then I was also able to Find friends on Facebook!


    I had the same problem, turning off Ghostery fixed it


    I figured it out. Keep hitting the button, even try to click on it when it’s still slid over into the on position. Once you do that the pop up for permission pops up and boom connected to Facebook. This was the mobile app Incase anyone needs to try it


    I had the same problem but with the new version of Microsoft Edge. It occurred because I had tracking prevention in "Strict". As the browser says: "Parts of sites might not work". So, if you're using a tracking prevention, switch it to a friendly option. I don't know what could be the option in Chrome, but if it's occurring the same, try to check blocking prevention. Hope it helps!


    I'm having the same issue for that last year, tried using the Incognito suggestion below and this let me authenticate to Facebook, but then once authenticated it closed window and went no further (find friends button just indicated "Connection Failed")


    I had forgotten I'd installed the extension "Facebook Disconnect" to Chrome. With that disabled temporarily the button worked for me.


    pleae connect my doulingo with facebook so I can see my progress number 6

    Learn a language in just 5 minutes a day. For free.