https://www.duolingo.com/Bluewyne

Duolingo Plus Advertisement Not Closing on Brave Browser

I've done a few lessons today and whenever the Plus advertisment ( https://i.imgur.com/lKrt7Ut.png ) would show, I'm not able to skip it. That is, the "No Thanks" button isn't functional and clicking it does nothing.

I'm using the latest version of the Brave Browser, so the issue might be browser-side. Brave runs on Chromium (I think), so maybe others are having issues, too, though.

June 14, 2019

13 Comments


https://www.duolingo.com/Crayonzie

same things been happening with me, every time you finish a lesson clicking the 'No Thanks' button does absolutely nothing.

June 14, 2019

https://www.duolingo.com/BoneheadBass

I use Chrome and have had the same problem since yesterday (14 June 19) -- Version 74.0.3729.169 (Official Build) (64-bit).

To say this is annoying is something of an understatement, as it feels like, by refusing to allow progress to another lesson or practice session, Duo is trying to force users to sign up for Duolingo Plus. Surely that can't be the intention... right?

--- UPDATE 16 Jun 19 ---
I just discovered that using the Back button gets me out of the endless Duo Plus loop. Good to know, but it shouldn't be necessary...

--- UPDATE 20 Jun 19 ---
Looks the problem has been solved; at least, everything has worked normally for me today (so far, anyway...)!

June 15, 2019

https://www.duolingo.com/Belleif

The page is simply broken. When I tried clicking "try seven days for free," the graphic slid away and nothing happened.

June 15, 2019

https://www.duolingo.com/NancyMihalich

You're correct, Belleif! I clicked on "try seven days for free" and nothing happened. I used the back arrow to get back to lessons.

June 15, 2019

https://www.duolingo.com/NancyMihalich

It's so frustrating! The ad shows up after every lesson! This is the second day that it's done this. It makes me want to stop doing lessons!

June 15, 2019

https://www.duolingo.com/NancyMihalich

Moi aussi! I closed out the app and did another lesson and it did it again. I clicked the back arrow button and that worked. Good luck!

June 14, 2019

https://www.duolingo.com/ixnari

This is what I'm doing. Thankfully, Duolingo remembers the progress you've made after finishing a lesson, so clicking back on your browser should bring you back to the "Learn" menu with the completed lesson tallied up.

That said, it would be much better if you could simply close the ad after each lesson. Just saying, Duo.

June 17, 2019

https://www.duolingo.com/susanstory

That has been happening to me as well, since yesterday evening. When I click "No Thanks" nothing happens and even clicking "Try 7 free days" it does nothing.

I refresh the page and it goes to another lesson. It was giving me XP for the lessons I did.

Yeah, it was annoying. I think it's maybe a bug and they'll fix it, I hope.

After all Duolingo is supposed to be free forever.

I also was thinking, "What is the point of a No Thanks button?"

June 15, 2019

https://www.duolingo.com/laszlopanaflex

the button works if you disable or whitelist your adblocker. it looks like the button click function was changed to work after the ad content fully loads.

June 17, 2019

https://www.duolingo.com/pentaan

The same issue has been reported for Firefox 67.0.2 https://forum.duolingo.com/comment/32631302

Duolingo prefers the Google Chrome browser. You might give it a try.


Please, submit a bug report via
https://support.duolingo.com/hc/en-us/articles/204728264-How-do-I-report-a-bug-

June 14, 2019

https://www.duolingo.com/angrysandwich

Same thing is happening to me too, for about 3 days now. I finally figured I should look for a solution in Troubleshooting. I'm using Firefox. I think the page is just broken. Hopefully it's fixed soon.

June 16, 2019

https://www.duolingo.com/Chris617319

And now they've got a 5 slide ad so you have to click it 5 times to move on. That is really being much too aggressive. It's quicker just to keep a bookmark under your browsers address bar. Learn now, you can see the writing on the wall of what is coming.

June 17, 2019

https://www.duolingo.com/lisamybias

Today was the first time that it happened to me... Annoying...

June 17, 2019
Learn a language in just 5 minutes a day. For free.