https://www.duolingo.com/sudozero

Audio playback isn't working.

I cannot hear any sound when I click the speaker icons. (Sound does work on youtube with both webm and flash playback.)

I run Trisquel 5.5, which is an Ubuntu 11.10 clone. I have gnash installed, which is a flash replacement. My browser is based on firefox 14.

I love the website; would you please consider fixing this problem? It seems like people with other operating systems are having the same problem too!

Thanks very much. :)

July 28, 2012

23 Comments


https://www.duolingo.com/polonskyo

I used to have the same problem in Chrome and got idea how to work it out from this thread. So I'm posting it here and probably this will work for you as well. My browser is set up not to run plugins (including Flash) automatically, so that I have to click every time I want to watch a video, e.g. on YouTube. This apparently was the cause of the problem. I've added an exception for duolingo.com website: Settings->Show Advanced Settings->Content Settings->Plug-ins->Manage Exceptions; add "[*.]duolingo.com" and restart Chrome. VoilĂ !

January 4, 2013

https://www.duolingo.com/tbritt

I have no sound on this website only. System sounds work. Youtube works. The audio on Duolingo does not work. I am using Mac OSX 10.8 with Safari. Help!

November 29, 2012

https://www.duolingo.com/neuble
  • 11
  • 9
  • 7

I'm using the latest version of chrome, and I appear to be having a similar problem.

July 29, 2012

https://www.duolingo.com/SteeleCB

After I got back from my holiday (about a week), sound no longer works on any of my Linux computers. When I log into Windows to try it, Firefox tells me Duolingo relies on Flash. Well, I don't use Flash - it is a dated technology which fails on many computers and is being phased out. Duolingo should move past Flash. But that doesn't explain why Duolingo sound work before I went on holidays and now does not (on two different computers).

January 24, 2014

https://www.duolingo.com/SteeleCB

Just in case anyone else encounters this problem: the Firefox plugin 'HTTPS everywhere' actually blocks Duolingo from loading now. Some website change they made to Duolingo in the past 2 weeks has caused this, as the plugin worked fine with Duolingo before this.

Sound also works now, so I'm not sure if Duolingo fixed something that was broken, or again the above plugin was interacting badly with the website update.

Regardless of whether it was Flash causing the problem or not, my point stands: it is not a sound business decision to base your website off Adobe's proprietary, buggy, and insecure Flash. To make matters worse, each year I hear of a new device or platform which has dropped Flash support.

January 26, 2014

https://www.duolingo.com/eliheady

Just a data point here, as it is not meant to be a solution for OP (tho it might work if you're willing to use binary-only plugins): installing Adobe-supplied Flash plugin (11.2) got audio playback working for me (ubuntu 12.04, chromium 18).

This is not a good situation long-term, as Adobe is dropping support of Linux as of the current release (they will, however, backport fixes to 11.2 for some time).

I'm just hoping the Duolingo team has an alternative plan in the works that does not require Flash for site functionality.

July 30, 2012

https://www.duolingo.com/tcar984

Same here. Using Opera based on Chrome engine; windows 7 64bit. Duolingo audio was working perfectly yesterday, but not today. I've tried everything, disabling all plug-ins, flash settings, nothing helps. You should really abandon flash.

January 24, 2014

https://www.duolingo.com/eliheady

Same problem here - Ubuntu 12.04, Chromium 18 and gnash 0.8.10

July 30, 2012

https://www.duolingo.com/placeybordeaux

I am running Ubuntu 12.04.1 chromium Version 23.0.1271.97 and flash version 11.2.202.261

Sound works on all other flash applications, but duolingo. I just tried installing luakit and it worked fine on there. I will just use luakit for duolingo for now.

January 24, 2013

https://www.duolingo.com/the_rastaman

i have the exact same problem. I run scientific linux 6.2. i have the adobe flash plugin installed and my browser us firefox 10.0.6 i hope this info can be useful.

July 29, 2012

https://www.duolingo.com/a.sandhu

My flash plugin is not working at duolingo.com site in Chrome environment.

August 16, 2012

https://www.duolingo.com/JeremiasAQ

I have same problem in here. My system is Ubuntu 12.10 Gnash 0.8.11 and have this same problem with Firefox, Chrome and Opera. We need a solution without Adobe help.

November 4, 2012

https://www.duolingo.com/Faya
  • 10
  • 6

Same problem. Windows 7, Firefox 16.0.2. I had the same problem some months ago and adding duolingo to the exceptions list of my flashblock-addon helped then. But now, with the same settings, sounds are not working again.

November 8, 2012

https://www.duolingo.com/mckenziejon

Not working for me either, Chrome OS v.23.0.1271.94. Youtube and other sites with Flash audio are working just fine.

December 13, 2012

https://www.duolingo.com/quatrox

I got the same problem. I use Ubuntu 13.04 with Firefox 20.0 and Gnash 0.8.11.

May 3, 2013

https://www.duolingo.com/justinwilson

Same here, left feedback every time I'd log in. Mac OS X Lion, and I've tried latest browser versions: Chrome, Safari, Firefox and Opera.

November 26, 2012

https://www.duolingo.com/TexJ0N
  • 13
  • 11

Same Problem on Mac OS X Chrome: 21.0.1180.90 Flash: 10.3.183.29

January 1, 2013

https://www.duolingo.com/NiclasJnnssn

win 8 latest chrome version and I have the exact same problem, pls duolingo do something about it.

November 2, 2013

https://www.duolingo.com/cristobalmeza11

Hey!!!!!!! I tried connecting my sound on the headphones jack of my computer instead the "normal" one, and it worked perfectly, and i couldn't hear anything on every browser and with every configuration of them, hope it works for you.

January 9, 2014

https://www.duolingo.com/SuperMykeBros
  • 22
  • 16
  • 11
  • 8
  • 4
  • 3
  • 2

I have just changed my OS from Fedora 21 to Kubuntu 15.10 and now I cannot hear audio from duolingo. I use Firefox 41.0.2. I do not have problems on Fedora.

November 7, 2015

https://www.duolingo.com/amanda11741

go to your duolingo settings (in the drop down menu with your profile) and turn speaker on, then save

March 12, 2016

https://www.duolingo.com/kylazap
  • 13
  • 12
  • 10
  • 5

I only cannot hear the spoken language on certain languages. I cannot learn Vietnamese or Swahili because there is no audio to hear the language, but french, spanish, polish, and german all work normally.

April 26, 2017

https://www.duolingo.com/Muribel
  • 25
  • 17
  • 15
  • 6
  • 6

Since I updated my Mac OS to Mojave, the speakers wouldn't work with Duolingo. Makes some of the exercises impossible! Eventually, I found the problem was all to do with Flash. So, here is how to cure it. Click on the Apple symbol, and select System Preferences. The Flash Player symbol should be down at the bottom left. Click on it. One of the headings there should be 'Camera and Microphone settings'. Underneath it is a box 'Camera and Microphone settings by site". Click on it, and you will find a list of sites allowed by Flash. Mine was empty. Click the '+' symbol at the bottom left, and then enter the name of the site, i.e. www.duolingo.com Works a treat now!

October 29, 2018
Learn a language in just 5 minutes a day. For free.