https://www.duolingo.com/BritBlue

Duolingo on Apple Mac - Thrown out of Duo...

I was just thrown out of Duolingo and told that my browser no longer supports Duolingo (it is the most up the date version of Safari) and it offered no alternative other than Internet Explorer, Chrome and Firefox. Safari had been working fine for the past month until a few minutes ago. Does anyone have any suggestions?

July 8, 2014

9 Comments


https://www.duolingo.com/AlexisLinguist

Try clearing your cache. I'm on 7.0.3 (not quite sure it is the extreme-latest, as I follow iOS more than OS X), and it works pretty well for me.

July 8, 2014

https://www.duolingo.com/BritBlue

I'll give it a try, not sure if I can though, despite my scientific background I am woefully inept on computers! lol I'm using firefox at the moment but I don't want to have two browsers open all the time!

July 8, 2014

https://www.duolingo.com/kristinemc

What version of Safari are you using?

July 8, 2014

https://www.duolingo.com/BritBlue

Thanks for replying - I know you are busy! Version 5.1.10 (6534.59.10) I ran my updates and everything is up to date, a few people are having this problem and it seems it started at the exact same time so we assumed Duo was having some problems?

July 8, 2014

https://www.duolingo.com/HappyEvilSlosh

Version 5 isn't the most recent version anymore. Mac are currently only supporting 6 and 7. However I get the impression that which version of Safari you can get depends on which version of the OS you are running. Welcome to Mac's forced upgrade cycle. :P

July 10, 2014

https://www.duolingo.com/Christine1999

You're probably right, I have version 5 on one of my computers. This one refuses to open Duo. The another one works fine, but this has version 6. So I overcame this obstacle, however I can imagine that some people will have problems with solving this. Dear Duo, why?????

July 10, 2014

https://www.duolingo.com/HappyEvilSlosh

It looks like they've recently cut off access to Safari versions prior to 6. If getting the latest version isn't an option (you really shouldn't be running unsupported software!) you can try changing the browser agent string. Basically you lie to duolingo about the browser you're using. These were instructions I recently sent to someone else, I don't know if he had any luck:

Try following the instructions here and change the string to Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9) AppleWebKit/537.71 (KHTML, like Gecko) Version/7.0 Safari/537.71. It might work.

July 10, 2014

https://www.duolingo.com/Christine1999

Sorry, I'm not coming with any suggestions, I just wanted to tell that it's the same in my case :(.

July 8, 2014

https://www.duolingo.com/BritBlue

I think I saw someone else a couple of days ago say that they were having problems with safari - I think Duo may be tinkering with something....

July 8, 2014
Learn a language in just 5 minutes a day. For free.