https://www.duolingo.com/DianaMcMc

Why is my microphone not working?

August 4, 2012

13 Comments


https://www.duolingo.com/christucker

I've tried this on my mac and it still doesn't work, even though I have it set to "allow"

February 4, 2013

https://www.duolingo.com/NathanWilliams

Have you got flash player installed?

Did you tell flash player to give DuoLingo permission to use your microphone? (Right click on the record button, choose settings, microphone and allow DuoLingo to use the microphone)

August 4, 2012

https://www.duolingo.com/crcannata

Figured out the problem with my mic not working in Duolingo. I selected that I did not want to use my microphone when it again did not provide the input as it should have. I then exited the lesson and went to my settings and selected to turn my mic back on. It now works again. So, the problem is within Duolingo but that was an easy work around.

February 20, 2013

https://www.duolingo.com/grebza

Right click on record and then click on the microphone icon. You have two options, try to another one

October 20, 2013

https://www.duolingo.com/gustyyy

Chrome doesnt seem to work for most people, try switching browsers, preferably Mozilla. It worked for me. It seems you cant make flash changes in chrome, though its more flexible on Mozilla.

November 30, 2013

https://www.duolingo.com/teamxblade

I am on a Mac, I set to allow and it's still not working. Help.

January 11, 2014

https://www.duolingo.com/hoody711

Also not getting any love on Mac. Have the most recent flash, set to allow on duolingo.com in flash settings. The record button just never fills in for me.

January 20, 2014

https://www.duolingo.com/teamxblade

Really? I updated my flash and it seemed to be working ever since. Also check your settings on duo lingo and safari or the browser you use and refresh. Hope yours works hoody. I know it's a pain in the behind.

January 26, 2014

https://www.duolingo.com/hoody711

Yeah I'm updated and on Chrome, Firefox, and Safari, whenever a spoken prompt comes up, the "Record" button just never fills in. It just stays faded out and unclickable. I can't find any settings in the browsers that seem to make a difference.

January 27, 2014

https://www.duolingo.com/teamxblade

I use strictly use Safari. First try going to your settings on duo lingo and make sure 'microphone' and 'speaker' are both turned on then try and make sure your flash is updated and is set to allow. After that I suppose try restarting your browser and see if when doing the lesson when it's your turn to speak you should see a big blue round circle with highlighted white microphone for you to speak. I think that is the updated, because before it would read 'record'.

January 27, 2014

https://www.duolingo.com/hoody711

Yep tried all that. For some reason I have the grayed out rectangle for "record," and no blue circle. :(

January 31, 2014

https://www.duolingo.com/cfholton

I see lots of old threads on this. I am also having this problem on a Mac (OS 10.11.6) across four browsers (whereas previously it was working consistently in Chrome and untried in the others): Chrome (58.0.3029.110), Safari (9.1.2 - allow Flash screen hangs), Opera (45.0 - does not appear to be "listening" when mic is clicked) and Firefox (46.0.2 - mic button animation was making it appear as though sound was being recorded, but it was never accepted until suddenly it was accepted every time; hoping it keeps working in that one). A mic check outside of DuoLingo shows the mic itself is working well.

May 31, 2017

https://www.duolingo.com/dominicoder

Every time I click the microphone: ih.js:223 Uncaught TypeError: Cannot read property 'toLowerCase' of undefined at ih.js:223 (anonymous) @ ih.js:223

September 26, 2017
Learn a language in just 5 minutes a day. For free.