1. Forum
  2. >
  3. Topic: Duolingo
  4. >
  5. how do I turn speech function…

https://www.duolingo.com/profile/djgreengirl

how do I turn speech function back on?

I turned my speech function (when I speak into the computer to answer) off because I was in public. Now I want to turn it back on and do not know how. Any advice would be much appreciated!

August 15, 2012

21 Comments


https://www.duolingo.com/profile/djgreengirl

I just figured it out! Just in case anyone else has this problem, here is the answer: go to your screen name and select "settings" from the drop down menu. There will be a choice to turn microphone "on" or "off."


https://www.duolingo.com/profile/Jleijssen1

Is it true that you can't turn this function back on after a while? I used to practice on my phone for a few months, without microphone. Now I'm practicing on my laptop, and the microphone is on, but still I don't get any speech training...


https://www.duolingo.com/profile/ArtyomTrubchik

same for me! turn micro off/on doesn't help


[deactivated user]

    i found this thread because i could not turn on the speech lessons and there hadnt been any updates, the only way i could find was under accessibility in the settings of the app, no way on the site


    https://www.duolingo.com/profile/Robert136638

    You have to use Google Chrome. Internet explorer doesn't show the Microphone feature.


    https://www.duolingo.com/profile/granavery

    Shocking and disappointing that Duolingo doesn't allow mic on with Windows.


    https://www.duolingo.com/profile/nobody.123456

    Safari is not supported even in 2021


    https://www.duolingo.com/profile/ChristineD8908

    If you're in Chrome and your microphone is on and the feature still isn't working, clear your cookies; that will make the speaking exercises come back again.


    https://www.duolingo.com/profile/ElRancano

    This worked for me. Thank you!


    https://www.duolingo.com/profile/Ktbullar

    Worked for me too, merci beaucoup :)


    https://www.duolingo.com/profile/Flo92750

    How do I clear cookies?


    https://www.duolingo.com/profile/ChristineD8908

    Go into your browser settings and look under "History." There should be an option there to clear cookies.


    https://www.duolingo.com/profile/JosMarioHe2

    Only works in Chrome for me, I've been using Safarin and the Microphone option is not available in this browser


    https://www.duolingo.com/profile/Kermit-likes-tea

    can i do it on microsoft edge i dont use chrome


    https://www.duolingo.com/profile/Cora139563

    January 2021 - Please, someone, update the directions for turning the microphone back on! Thanks - Cora


    https://www.duolingo.com/profile/nobody.123456

    Hey Cora,

    Go to profile, tap “settings” on top right corner. Under “General”, you can find options to toggle listening and speaking exercises


    https://www.duolingo.com/profile/Cora139563

    Thank you for your speedy response. But, in the first place, "General" does not appear when I tap on my image (This directions was not included, by the way.) Under Account, there is a "settings" option. which says, again, "Microphone not authorized! In order to practice your speaking skills, please give Duolingo permission to access your microphone. You can click the recorder icon in your browser’s address bar or click here for help." The recorder icon gives the same message, and the "Click Here" function is not operational. PLEASE update these features - it is frustrating and so time-wasting to be continually unsuccessful! Thank you - Cora


    https://www.duolingo.com/profile/nobody.123456

    Oh. I am sorry. I thought you are using an iOS or Android app. It seems you are using a browser. If you are using safari on a Mac, you can find options to turn on mic in “privacy” under “preferences”. For other browsers, I can’t help you. But, you can google “how to turn on mic in chrome/Firefox”


    https://www.duolingo.com/profile/florencegraham

    turn sound on for duolingo


    https://www.duolingo.com/profile/Hannah820153

    April 17, 2021 I am still having the same problem on both Safari and Chrome on Mac! Fix it Duolingo please.


    https://www.duolingo.com/profile/Cora139563

    This was not a problem Duolingo could help with. I finally went to the settings on my own computer. I don't remember how, but eventually I found an audio feature that needed turning on. Good luck.

    Learn a language in just 5 minutes a day. For free.