https://www.duolingo.com/liamog

Duolingo is interfering with browser spell check

There is an issue in the lessons where the spell check is disabled on the wrong fields by Duolingo. Looking at the source code, I can see that the textarea tag has the spellcheck="false" attribute, but on the wrong fields.

Take these two examples:

When translating from English to Spanish, spell check is enabled

But when translating from Spanish to English, it's disabled with spellcheck="false"

Why is spell check disabled when typing English and then enabled when typing in Spanish? Shouldn't it be the other way around? It's happening on both Chrome and Firefox.

September 15, 2014

5 Comments


https://www.duolingo.com/--._

Probably so "usted" is not corrected to "busted" and other ridiculous corrections.

September 16, 2014

https://www.duolingo.com/liamog

But the spell check is enabled when typing in Spanish and disabled when typing in English. See the screen grab above. It should be the other way around.

September 16, 2014

https://www.duolingo.com/bchan

Hmm that's interesting. The test currently running disables the auto correct when the language you're typing in doesn't match your browser language. Have you changed the hierarchy of your languages in Chrome?

September 16, 2014

https://www.duolingo.com/liamog

Here are my language settings in Chrome:

My Windows 8 default language is Irish if that makes any difference.

September 16, 2014

https://www.duolingo.com/DougFessler

I noticed the same thing. I recently discovered that there is a Chrome extension that will re-enable it. We live in a spell check world now.

https://chrome.google.com/webstore/detail/spellcheck-and-autocomple/lhgojccblhkehkeddjejgobddjiidadp

January 27, 2017
Learn a language in just 5 minutes a day. For free.