Is there anyway to choose the direction of my translations in the immersion section?

Since my first language is English, the default setting was that I translated from another language to English. At one point I guess I switched this somehow, but I can't remember how to change it back! Is this no longer an option? Right now I'm stuck translating from English to Portuguese and would like to switch it back to Portuguese to English.

October 8, 2014


Has there been any progress on this? When I change my base language to Spanish, I can't see my English based courses and when I have English as base, I can't translate from English to Spanish. It would be ideal to have both directions available.

September 27, 2015

As far as I can tell, this was a beta feature at one point but must have never been fully implemented. It sure seems like it would be convenient though!

January 4, 2016

Are you viewing the whole site in Portuguese? If so you need to switch back to English as the base language and go to Portuguese immersion.

October 8, 2014

No, I'm viewing the English version of the site, but for some reason the translations in the immersion section are just backwards

October 8, 2014

I have both directions (Spanish to English and English to Spanish) in my Immersion selection. I have done Immersion in both sections, and maybe that is what triggered it. Ideally, I wish I could filter only for Spanish to English, but I haven't seen an option yet either.

October 8, 2014

How did you get started doing the translation in both directions? I don't see any option for translating from another language into English.

October 9, 2014

I accessed it from the 'reverse' or 'mirror' tree (the "I know Spanish and am learning English). Once I was in that part of duolingo, I selected Immersion. It is also why I have an English flag, although it is my native language :)

October 9, 2014

Thanks! If I go to the "I know Spanish -> learning English" tree, now I can do translations in the Spanish -> English direction. It still seems like that's backwards of how it should be, but at least I can get both languages this way. I've contacted tech support from Duolingo a couple times but haven't heard anything yet :(

October 10, 2014

I only have this under 'your edits' and 'your uploads', but can never see both under the All tab. You can get there as Wazzie says or through other people's timelines or by uploading English documents.

But anyway, Mikey needs an actual technical bod from Duolingo to fix this one. Anyone there?

Unless you're looking at 'my edits' instead of 'all', Mikey?

October 9, 2014
Learn a language in just 5 minutes a day. For free.