https://www.duolingo.com/h0gar

Can't see the translation on lower resolutions

Not easy to explain by text so here is a screenshot to show what I mean: http://i.imgur.com/T0GsdMX.jpg

See? The translation is hidden and I need to scroll after every reply because it keeps scrolling up. Pretty annoying. Hence it would be nice either to reduce the page height or to disable this auto-scrolling. For your information this is with a 1366*768 resolution.

December 12, 2014

2 Comments


https://www.duolingo.com/wazzie

This is such an annoyance for me.
My resolution is 1024x600 (on a 10.1 inch note book) and it drives me crazy to always have to scroll.

I used to participate a lot in the discussions, and I just don't anymore. I think I just 'forget' about the discussion, not being able to easily see it.

I have submitted help tickets on this in the past, written in this forum in the past... The last time I posted, the problem was resolved for a little while (maybe a month?), and then went right back to the current setting. This tells me that duolingo is happy with the current settings, and isn't interested in adjusting them for the smaller user base that we are a part of.
This actually makes me a bit sad, because I know that Luis wants to offer language education across the world (and especially to those who cannot afford traditional education), but has a website that can only be seen properly on newer (and expensive) computers. It really frustrates me.

So, with all that being said, I have found a couple of solutions that work for me. You can use F11 (chrome) to put your browser into 'full screen' mode. This allows the website to take up the entire screen of your laptop. I also downloaded the Zoom extension in Chrome so I can fine tune my Zoom levels to fit everything on the screen without making the text too small to read.

I really hope that duolingo truly takes these concerns into consideration.

December 12, 2014

https://www.duolingo.com/h0gar

Since I'm not the only one being annoyed with this thing, here is how to disable it. Copy/paste the following line in your url bar when you are on the duolingo website:

javascript:function getPropertyDescriptor(e,t){var n=Object.getOwnPropertyDescriptor(e,t);var r=Object.getPrototypeOf(e);while(n===undefinedr!==null){n=Object.getOwnPropertyDescriptor(r,t);r=Object.getPrototypeOf(r)}return n}obj=document.body;propertyName="scrollTop";var originalProperty=getPropertyDescriptor(obj,propertyName);var newProperty={enumerable:originalProperty.enumerable};newProperty.set=function(e){};Object.defineProperty(obj,propertyName,newProperty)

You can even add it as a bookmark and click on it everytime you go on duolingo. This will disable the auto-scrolling after every reply. Hope it helps.

Edit: you have to write javascript: manually in the url bar, and then you can copy/paste the rest, and tap enter.

December 13, 2014
Learn a language in just 5 minutes a day. For free.