1. Forum
  2. >
  3. Topic: Troubleshooting
  4. >
  5. "Discuss sentence" not working

https://www.duolingo.com/profile/cansu.gurk

"Discuss sentence" not working

I click discuss sentence button but nothing happens. Has that happened to anyone before? Is the problem caused by me or duolingo? How do I fix it if possible?

January 3, 2015

40 Comments


https://www.duolingo.com/profile/sa_mills

This happens to me intermittently. Sometimes it works, sometimes it doesn't. I haven't noticed a pattern yet.


https://www.duolingo.com/profile/Oceanotti

This problem remains unsolved as of 11/12/2016


https://www.duolingo.com/profile/Joe_Joeboberson

still unsolved in febuary 2017

please duolingo


https://www.duolingo.com/profile/PeterJense14

As of nov. 3rd 2017 I had the same problem, but I now have found the solution: IF YOU HAVE an ad-blocker, like AdBlock or uBlock activated, then the "DISKUSS" link will not function. Just unblock "duolingo.com" (the whole site), and everything works like a charm, including the ads :)


https://www.duolingo.com/profile/Bohuslav1

Ah - thanks for that - I do indeed have an ad-blocker, so I'll try what you suggest. Thanks for the tip.


https://www.duolingo.com/profile/Nan992093

I don't have an ad-blocker. It's an intermittent problem. Some days it's fine, some days not.


https://www.duolingo.com/profile/DTSFF
  • 1566

I concur, it has never been related to ad blockers in my case.

Actually, I haven't had this problem for a long time now, so I thought it was fixed. Except that sometimes when I click the DISCUSS button, a tab with no comments will be shown, as if nobody had ever commented the sentence, despite the presence of a number between ( ) next to DISCUSS. I'm not sure whether that's the same issue


https://www.duolingo.com/profile/Japanese_Neko

Dude, thanks!!! I put Duolingo on the "don't block" or something like that list on my adblocker, and now the conversation button works!!


https://www.duolingo.com/profile/hcarleton

What browser(including version)?


https://www.duolingo.com/profile/cansu.gurk

Google Chrome 39.0.2171.95 m


https://www.duolingo.com/profile/hcarleton

Hmm, well so much for that theory. Must be a Duolingo bug.


https://www.duolingo.com/profile/embauer74

This is happening to me constantly! It is very frustrating! I have tried Safari on Mac OS X and IE, Chrome and Firefox on Windows 8.1. I restart the browser and comments are available for the first few sentences of each lesson, and then the button is inactivated until I restart the browser again. The comments are indispensable to the learning experience. I would love to see this fixed (and to be able to access the comments from the iPad app for that matter).


https://www.duolingo.com/profile/bendespain

I've restarted my browser and computer and still get nothing when I click the discuss sentence button. The report problem button works though.


https://www.duolingo.com/profile/bendespain

When I do a lesson it'll work, but if I go back to https://www.duolingo.com/practice it won't. Seems to happen at random locations, but it's persistent at those locations/lessons. I'm pretty sure once I finish this practice lesson then next one will work fine, but I'll have to see.


https://www.duolingo.com/profile/bendespain

Well, german next practice session still fails but French has no problem


https://www.duolingo.com/profile/Daniel701507

From time to time, I doesn't work for me either. However, the “Report a Problem” button always works.


https://www.duolingo.com/profile/hapstad

This issues persists as of 12/24/16...more than a year after reported is ridiculous.


https://www.duolingo.com/profile/drdodds4

Just stopped about a week ago (end of Feb 2017), but was fine before that. The DIscuss Sentence button highlights, but no action occurs.


https://www.duolingo.com/profile/DTSFF
  • 1566

18.04.2017, this keeps happening to me from time to time. I don't know how to reproduce it


https://www.duolingo.com/profile/sciencecw

still happening 2nd May 2017


https://www.duolingo.com/profile/AaronMoat

I have the same issue.

I did some digging and it would appear that this is a server-side issue. I went through a lesson (French for English speakers, Adjectives-2/1, however I have noticed this in most if not all lessons) and pressed "Discuss sentence" after each part of the lesson, and a HTTP request is made to https://www.duolingo.com/sentence/something every time the discuss sentence button is clicked. The first occurrence I noticed of the button not working (Translate "Ils sont jolis."), this HTTP request returns a 404 and the dialogue box resulting in the discussion does not pop up, and no further discussions pop up after this, because no further HTTP requests are made on following parts of the lesson, even when the button is clicked. In other words, the first 404 found breaks the button for the rest of the lesson, and I have also noticed this behaviour for skill strengthening.

The aforementioned request is contained at the URL: http://pastebin.com/raw.php?i=TtSch7qY

(I hosted it on Pastebin because Duolingo was escaping the ampersand strangely, breaking the URL)


https://www.duolingo.com/profile/markbooth

1 year later and this still remains unfixed. :(


https://www.duolingo.com/profile/AANickFan

2 years later and this still remains unfixed. :(


https://www.duolingo.com/profile/sa_mills

Another place 404 errors show up is if you search for a particular discussion from the discussion tab (type the sentence in the search box). Many of the links in the search results take you to a 404 page.


https://www.duolingo.com/profile/AaronMoat

You're quite right. I searched for "Ils sont jolis." (the same error-causing sentence) in the forums, found https://www.duolingo.com/comment/5329442 which redirects to a 404.


https://www.duolingo.com/profile/Jon._b

It is most likely because the discussion was taken down for spam, or irrelevance.


https://www.duolingo.com/profile/kay-mika

I noticed the same problem today with the Italian course ( the report a problem button wasn't working, too).


https://www.duolingo.com/profile/Abidaga

Happening at present, as well as no sound


https://www.duolingo.com/profile/Kier427541

I have NEVER had this work right. I click discuss button and I do get to see others’ comments on the sentence but I cannot leave a comment myself. This is through the iOS app on my iPad, and I have a paid subscription.


https://www.duolingo.com/profile/AgustinDevoto

The discuss button does not appear in the app. Before that, I couldn't reply any comment.


https://www.duolingo.com/profile/OliverBens1

It doesn't work for me either on some sentences.


https://www.duolingo.com/profile/polish_student99

I notice that this seems to occur after I exit out of the comments by clicking on the background rather than by pressing the X.


https://www.duolingo.com/profile/AANickFan

Wow. I didn't even know there was an X, it's so small.


https://www.duolingo.com/profile/Nan992093

It used to work for me but stopped altogether around the time other changes were made in Duolingo (about March 2017?).


https://www.duolingo.com/profile/Bohuslav1

Had no problems on my Greek course until a couple of weeks ago but now the button frequently doesn't work and sometimes a 404 comes up. The report a problem button works up to a point, but typically doesn;t have all the options available.


https://www.duolingo.com/profile/Zsuzsi97194

Yes I can’t access “Discuss” either in Hungarian course but can see previous comments. Sept 19 2020 !

Learn a language in just 5 minutes a day. For free.