https://www.duolingo.com/Wgilgan

microphone not working

November 6, 2012

69 Comments


https://www.duolingo.com/BeauBeach

I want to use the microphone, and it works fine for Dragon Naturally speaking, but Duo Lingo says "I can't hear you very well" or "I couldn't understand that". Have you considered adding a place on the site where users can test their microphone and see the audio level being received? Also, the dialect in the German lessons does not accept the hard "ch" and "ig" that are common in northern dialects, it's uncomfortable speaking the softer sounds when my German speaking peers use the hard sounds.

February 15, 2014

https://www.duolingo.com/cclev007

My mic worked fine using Internet Explorer but not Chrome. I googled how to increase or boost my mic volume and now I no longer have trouble on Chrome or Skype for that matter.

February 24, 2015

https://www.duolingo.com/VanessaLandry

I am having the same problem in only some sentences, I am doing french and the microphone works well with most sentences then gets stuck in other phrases. I even tried recording the computer speaking and it still doesn't recognize the phrase. Annoying when doing a timed test.

November 6, 2012

https://www.duolingo.com/johnmarkos
Plus
  • 25
  • 22
  • 19
  • 3
  • 3
  • 677

Mine is getting stuck today. It hasn't done this before.

February 1, 2014

https://www.duolingo.com/matroids
  • 25
  • 24
  • 11
  • 10
  • 4
  • 3
  • 3

For Chrome users on Mac OS, I found the following fix. Open Safari and download Adobe Flash Player from http://get.adobe.com/flashplayer/
Note that Chrome already comes with Adobe Flash installed, but for some reason Duolingo does not recognize it unless you install Adobe Flash from Safari. After the installation, you should be able to use the microphone fine using Chrome.

August 15, 2014

https://www.duolingo.com/Beatles-Musician
  • 20
  • 19
  • 15
  • 14
  • 14
  • 13
  • 13
  • 13
  • 10
  • 10
  • 10
  • 9
  • 9
  • 8
  • 8
  • 8
  • 8
  • 6
  • 6
  • 5
  • 4
  • 3
  • 3
  • 2
  • 2
  • 2
  • 89

I might got a solution for the Chrome users: in the right-upper corner, left to the bookmark symbol, one can see a deactivated camera sign. Click on it and grant Duolingo access to your microphone, it will demand to reload the page and then it should work for everyone.

June 8, 2014

https://www.duolingo.com/sarah.elizabeth.
  • 15
  • 12
  • 8
  • 7
  • 7
  • 7
  • 7
  • 6
  • 6
  • 4
  • 3
  • 2

Thanks for the suggestion, but mine was already set to the correct setting--although I was unaware of this shortcut before. : ) It must be a problem with the duolingo site.

July 27, 2014

https://www.duolingo.com/amk2015
  • 13
  • 10
  • 9
  • 3

Similar to Beatles-Musician's suggestion, this worked for me:

At the beginning of the address bar there is a little green padlock symbol. Next to it is https:/www.duolingo.com.....

Click the green padlock. Click on the permissions tab. Where it says 'media' (second to the bottom) select 'always allow on this site'. *

It will ask you to reload the page. Afterwards, go to your settings on duolingo and turn on the microphone.

  • I also clicked allow popups at this stage, I don't know if this had an effect.
September 1, 2014

https://www.duolingo.com/harryblatterer

Thanks. That did it! Grazie mille!

September 4, 2014

https://www.duolingo.com/Sinartu

CONFIRMED fix for me on chrome. Thank you :D

July 24, 2015

https://www.duolingo.com/TriciaHeda

I just tried that and it didn't work. :(

July 2, 2014

https://www.duolingo.com/Beatles-Musician
  • 20
  • 19
  • 15
  • 14
  • 14
  • 13
  • 13
  • 13
  • 10
  • 10
  • 10
  • 9
  • 9
  • 8
  • 8
  • 8
  • 8
  • 6
  • 6
  • 5
  • 4
  • 3
  • 3
  • 2
  • 2
  • 2
  • 89

But did the icon change after the action?

July 2, 2014

https://www.duolingo.com/amk2015
  • 13
  • 10
  • 9
  • 3

What is the bookmark symbol and the deactivated camera sign? I can't see it.

August 27, 2014

https://www.duolingo.com/Beatles-Musician
  • 20
  • 19
  • 15
  • 14
  • 14
  • 13
  • 13
  • 13
  • 10
  • 10
  • 10
  • 9
  • 9
  • 8
  • 8
  • 8
  • 8
  • 6
  • 6
  • 5
  • 4
  • 3
  • 3
  • 2
  • 2
  • 2
  • 89

https://www.duolingo.com/amk2015
  • 13
  • 10
  • 9
  • 3

Thank you for your help, unfortunately that symbol doesn't seem to show up on my browser :/

August 28, 2014

https://www.duolingo.com/ScottWood2
  • 14
  • 9
  • 7
  • 6
  • 6
  • 5
  • 5
  • 4
  • 2

Go to http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager07.html

In the panel, click on the fifth tab, "Website Privacy Settings". Find duolingo.com, and then click "Always Allow".

September 1, 2014

https://www.duolingo.com/xjedlex

This is working :) here, have a few Lingots..

February 22, 2015

https://www.duolingo.com/adriano
  • 25
  • 25
  • 10
  • 1046

You can solve this problem following the steps: 1 - Open this URL in your browser: http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager04.html 2 - In "Always trust file in these locations:" select "Add location" option. 3 - Write "duolingo.com" in "Trust this location" box. 4 - Click in "Confirm".

April 23, 2015

https://www.duolingo.com/doste572
  • 25
  • 13
  • 7
  • 7
  • 1108

This worked perfectly! Mine had been working well for months when it suddenly quit and I could not figure out why. Duolingo no longer appeared in my Flashplayer settings and I had to re-add it. Thanks adriano!

August 8, 2015

https://www.duolingo.com/Kalquimarke

I'd be glad to give some lingots for some useful advice in how to test and make the microphone work for Duolingo in Debian linux and Chromium browser.

I have tried to make it work for almost a year without success. Other platforms seem to be working fine (such as Android and Samsung).

Apparently, Flash extension in my browser should be configured for allowing Duolingo's website to use the microphone. But it does not solve the problem.

Flash, Java and Debian are updated (last update).

My microphone works well with other apps, so it is ok.

Regards!

January 31, 2014

https://www.duolingo.com/RainbowFortune

I have a problem with French. I am also studying German, Spanish (and Portuguese, but it doesn't have the speaking parts). I don't have any problems with German or Spanish, but the French one does not seem to understand me. I know that my pronunciation is probably not perfect, but now, when it writes what it thinks I said, it has nothing to do with what I actually said. I say 'heureux', it writes down 'lcl', which makes no sense. A few days ago, the sentence was 'Il habite dans ce quartier', which is a pretty simple sentence, and what it wrote back (as something I said) was 'You are a ❤❤❤❤❤ dans ses quartiers'. I have it printscreened for proof. It's really starting to annoy me, it is impossible for me to be SO far off when saying these sentences...

February 23, 2014

https://www.duolingo.com/kevin.pras

For chrome, when it wants you to speak on the search bar on the top right you'll see a tiny video camera with a x on it click on it and enable the website. Enjoy

December 12, 2014

https://www.duolingo.com/romuloff

Yes! That solves ! Here people ! The solution ! =D

July 3, 2015

https://www.duolingo.com/caroljanovik

I used to use the iOS app and speaking exercises were fine, now I switched to Android (Moto X) and they do not work at all (Hmmm... that doesn't sound right - every time). I went back to my iPhone, did the same lessons and speaking exercises were working perfectly. Anything I could do about it or it's up to Duolingo to fix it?

April 7, 2015

https://www.duolingo.com/RodneyCamp5

When I use the microphone learning German it always says correct - even if I don't speak.

July 12, 2015

https://www.duolingo.com/_Jaker_

I am having this issue as well in French. Always correct even if no answer or intentionally wrong to test it.

August 7, 2015

https://www.duolingo.com/muhammadtalha710

can we skip a sentence in pronunciation test?

July 29, 2013

https://www.duolingo.com/wagner.m

Who know how I can skip sentences with reading the text? I have a good microphone on PC but it has a bad echo. That makes me a big troubles with sound. On a mobile it is working perfect.

December 31, 2013

https://www.duolingo.com/martin.hassman

I had same problem with some French phrases. My microphone was very low, so I raises microphone volume and I have oposite problem now. I can say almost anything (even some nonsence) and it is accepted as correct pronunciation, which is strange. Definitelly better, but not correct.

January 13, 2014

https://www.duolingo.com/BigCatz
  • 13
  • 9
  • 5
  • 4

I turned it off on my PC running chrome and I can't reactivate it.

February 6, 2014

https://www.duolingo.com/Brookland

Cannot get microphone to work in either IE or Chrome. (It works perfectly well with other programmes) Very frustrating.

February 10, 2014

https://www.duolingo.com/srahm1112

I am having the same problem. I use Chrome.

February 18, 2014

https://www.duolingo.com/BigCatz
  • 13
  • 9
  • 5
  • 4

Mine is working again in Chrome. I'm not sure how. I plugged in a USB mic along the way and went back to the native PC mic. Maybe that "fixed" it.

February 19, 2014

https://www.duolingo.com/JoRenaud

Je suis francophone et j'apprends l'anglais . Le micro fonctionne très mal. Sinon, c'est un jeu génial.

March 4, 2014

https://www.duolingo.com/koyakun

This comment thread might be helpful: https://www.duolingo.com/comment/1636161

March 6, 2014

https://www.duolingo.com/koyakun

You might want to check your firewall settings. My office's firewall turned out to be the problem for me. I'm able to use the same computer and configuration when I switch to my personal internet connection.

March 6, 2014

https://www.duolingo.com/bhohenstein

mic still not working in Crome on MBP...

March 28, 2014

https://www.duolingo.com/dabernathy89

Glad i'm not the only one

April 2, 2014

https://www.duolingo.com/LiFicreator45

when I click on the microphone and I say the words it doesn't work. I tried it again and again but it still doesn't work my other people say that it works very well. maybe I did something wrong or it just well not work

June 17, 2014

https://www.duolingo.com/amk2015
  • 13
  • 10
  • 9
  • 3

take a look at my comment above if you're using chrome.

September 1, 2014

https://www.duolingo.com/LizBacon

I am using Chrome and having no luck. Boo.

September 21, 2014

https://www.duolingo.com/LizBacon

Yay, Chrome let me turn on the microphone. Gave me a prompt under the menu bar. Thanks Chrome!

September 21, 2014

https://www.duolingo.com/CoratheGymnast

Mine doesn't even have a place to click, before you say the words in french!! UGH

October 29, 2014

https://www.duolingo.com/DylanWarren

I was having problems in Chrome with the microphone. I turned off my Ad Block software for this page and it appears to be working now. Perhaps this will work for someone else?

November 4, 2014

https://www.duolingo.com/Beatles-Musician
  • 20
  • 19
  • 15
  • 14
  • 14
  • 13
  • 13
  • 13
  • 10
  • 10
  • 10
  • 9
  • 9
  • 8
  • 8
  • 8
  • 8
  • 6
  • 6
  • 5
  • 4
  • 3
  • 3
  • 2
  • 2
  • 2
  • 89

From Duolingo Help:

My speech input is not working. What can I do?

Duolingo requires the Adobe Flash plugin to accept speech input, so first ensure that you have Flash installed. If Flash is installed but speech input is still not working, try refreshing the web page in your browser. If this does not fix the problem, try closing and reopening the browser. If none of these solutions work, make sure you do not have any browser extensions installed that would block the Flash plugin. Some extensions known to interfere with Flash include Ghostery, Adblock, Flashblock, and DNT.

November 4, 2014

https://www.duolingo.com/Gigliettina

Il microfono non funziona

November 10, 2014

https://www.duolingo.com/dlamb126

The microphone doesn't work very well at detecting a foreign language on Chrome, but it works great on Safari.

February 21, 2015

https://www.duolingo.com/jimvil2

It dosen't even show up for me

March 10, 2015

https://www.duolingo.com/NadinePeacock

I am having trouble with the microphone. Seems like a common problem. I first started using the program in Chrome and it wasn't working, so I switched to Firefox and it was fine. Today when I used the program in place of the microphone icon there was a button saying Flash needed to be updated. After I updated Flash I couldn't use the microphone in any browser (Chrome, Firefox or Internet Explorer).

March 12, 2015

https://www.duolingo.com/Sineadkelvin

Can't hear April 2015

April 4, 2015

https://www.duolingo.com/Sineadkelvin

I orphaned not working April 2015

April 4, 2015

https://www.duolingo.com/Barbara542744

Microphone is not recognizing Spanish What should I do ?

July 21, 2015

https://www.duolingo.com/waledkamal

I am having the same problem. I use Chrome.

August 5, 2015

https://www.duolingo.com/Marialilliput

I use duo lingo on my iPad and it hardly ever works, settings seem fine. Any ideas?

August 27, 2015

https://www.duolingo.com/liit4m
  • 12
  • 6
  • 5
  • 5
  • 5
  • 4
  • 2

Hi! Does anyone have a fix for Opera? Thanks!

September 6, 2015

https://www.duolingo.com/Bas160805

I was having this problem but seem to have fixed it. (I am using mozilla firefox but this may apply to other browsers. You have to right-click on the microphone symbol (when you have a speaking question), this opens up Flash Player settings. Choose microphone settings and adjust the volume so it isn't too load or too soft (you don't want it to go to red when you speak normally). You might also need to change your sound device here as well, if it doesn't work. After I did this, duolingo started understanding me! -Seb.

September 20, 2015

https://www.duolingo.com/tumsi

That only works if you get pronouncing exercises. I even get them. And none of the above advises could helped me (Flash settings, deactivated Firefox addons, Firefox security settings...)

January 11, 2016

https://www.duolingo.com/Knittergeek

The microphone on my iPhone 6S is not recognizing the Spanish phrases at all. Same thing as other comments below, "I can't hear you very well" or "I couldn't understand that " Is there a fix for this? App is pretty useless without voice recognition.

October 28, 2015

https://www.duolingo.com/victorbcn76

My microphone doesnt works in the Android application, but through the browser works ok.

February 1, 2016

https://www.duolingo.com/SusanPisan

I have tried to used couple different microphone headsets and neither work - Duolingo cannot hear. I wish there was some sort of technical support to adjust settings. I am not able to practice the speech segments at this point.

March 16, 2016

https://www.duolingo.com/adriano
  • 25
  • 25
  • 10
  • 1046

Follow this steps below: 1 - Using the right mouse button, click above the "Speaker" icon. 2 - Choose the "Global settings" option. A new tab page will be opened. There is a menu on the left side with the "Settings manager" title. 3 - Click on "Website Privacy Settings panel" and find and select the "www.duolingo.com" and then "Always allow". 4 - On the right menu, click on "Website Storage Settings panel" and find and select the "www.duolingo.com" and then "Always allow". 5 - Close the Duolingo page and open again.

March 18, 2016

https://www.duolingo.com/CorBAN37

How can you make them hear you? You speak loud, but they don't hear you. That's great!

March 21, 2016

https://www.duolingo.com/Skydriller

I can use the mic on Chrome but there are too many ads. so i don't want to use it.Instead i use Yandex everything is perfect but i can't even speak in speaking activity it doesn't even let me speak it just says i can't hear you i don't know what to do

May 26, 2016

https://www.duolingo.com/ColinEllio1

When my mic stopped working suddenly this morning, I too was puzzled and tried all the suggestions I could find on the Duolingo website without success. However I solved the problem in a different way: going into Windows Control Panel, I clicked though to Audio Devices and noted that my Bluetooth headset was set as the default for recording and not my webcam. On changing that, it worked again. I don't know why this should be the case as I didn't change it from the webcam in the first place and I guess when I next use my Bluetooth headset with Dragon Naturally Speaking it won't work! but at least it's now working in Duolingo in Chrome.

November 2, 2016

https://www.duolingo.com/RaphaelHesse

Ich will mein Mikrofon zulassen!

January 6, 2017

https://www.duolingo.com/Anita734131

All of the comments are here, where is duolingo's advice????

April 10, 2017

https://www.duolingo.com/omaneta

mine says that same thing it works just fine on my gmail drivevoice speaking for my essay but not on duolingo

April 13, 2017

https://www.duolingo.com/John288621

using opera but microphone not working Help

November 27, 2017

https://www.duolingo.com/Kathleen256390

I’m using an iPad. My mic was working fine when I started. One day I couldn’t talk so chose the “can’t speak now” option. Since then all I get is “that didn’t sound right, we’ll try later”. Even on phrases I’ve said correctly before. I checked my settings on the iPad and Duolingo and my mic is on. Not sure how to fix this.

January 23, 2018
Learn a language in just 5 minutes a day. For free.