https://www.duolingo.com/terry.nycum

Always "I can't hear you very well" on Mac

I'm using Chrome on a Mac. I've granted DL permission to access the mic, twice—I removed it once and regranted in trying to fix it—made sure the input source is set to internal microphone, and confirmed that my speech is registering normally volume-wise in System Preferences > Sound > Input. No matter how slowly and clearly I speak, DL gives me the "I can't hear you very well. Please record again (try speaking slower)" message. (I see the mic icon Chrome adds to the toolbar when the page is taking input, so I know I'm speaking at the right time.) How can I troubleshoot this?

January 19, 2015

10 Comments


https://www.duolingo.com/vildand91

The same thing happens to me, just with safari. I've not found any solutions, though.. If I speak loudly it usually works, but yelling french phrases in your room isn't that popular over long periods of time, weirdly enough :P

January 20, 2015

https://www.duolingo.com/tu.8zPhLBXipiNkv

...which can be quite annoying. I'm currently using FF after Chrome and I don't think it's just one browser. =P I believe Duolingo has a hard time to hear what we're trying to say even if the pronunciation is correct.

January 21, 2015

https://www.duolingo.com/vildand91

I know, right! With a phone or earbuds etc it works fine. Probably something to do with the mac + duo interaction, I'd guess.... But I don't get to experience this problem that often, usually it will just tell me to upgrade Flash player and turn off the speaking lessons for me in the mean time :')

January 21, 2015

https://www.duolingo.com/tu.8zPhLBXipiNkv

Haha, I did the exact same thing when that bothers me so much! xD

January 21, 2015

https://www.duolingo.com/terry.nycum

Try taking it outside your room? https://www.youtube.com/watch?v=UO70z00Hnxg :-D

January 21, 2015

https://www.duolingo.com/vildand91

:O I can't speak to duo like that, he would never recover!

January 21, 2015

https://www.duolingo.com/tu.8zPhLBXipiNkv

I believe I found out what happened. Try going to camera and microphone settings. Increase the recording sound to the max and check "Reduce echo". These work out for me as I don't hear "I can't hear you very well" as often. This should solve the problem. Give it a try. =)

January 27, 2015

https://www.duolingo.com/psionpete

Try Safari just in case it is a problem with Chrome. Also check the mic has not been disabled in Duo settings.

Other than that I don't know. It works on my iMac/Safari (but not tried it with Chrome)

January 19, 2015

https://www.duolingo.com/tu.8zPhLBXipiNkv

I've been getting the same problem (as you) for quite a long time now. I think it could be just Duolingo.

January 19, 2015

https://www.duolingo.com/Kathryn_Hunter

I have that issue on my Air with Safari and the internal mic, but it is not an issue when I use my earbuds with their own mic.

January 19, 2015
Learn a language in just 5 minutes a day. For free.