https://www.duolingo.com/Gnorian

How to Change International Keyboard Settings

I've been enjoying an International keyboard setting for a while. It let me hold down alt, then hit " or ', then I type in a, u, or any letter I want accented.

Then I encounter a problem... Now, I don't have to hold down alt to access this feature. Now, every time I want to use a ' or ", or other characters, it tries to accent my letters. This is pretty annoying, since I need to type a lot in English, so I'm rarely accent letters...

Does anyone here, who has experience with International Keyboard Programs, know why this is happening, or how to fix it? I'm happy with the way it was before, but it changed to be like this inexplicably.

August 2, 2013

4 Comments


https://www.duolingo.com/Alphathon

What system are you using it on (Windows PC, Mac OS X, iPhone, Android etc)?

August 2, 2013

https://www.duolingo.com/Gnorian

PC, Windows 7. Sorry for not mentioning that earlier.

August 3, 2013

https://www.duolingo.com/Alphathon

I assume you just used the standard Windows keyboard layout settings to select the layout. If you didn't, what software are you using? If you did, it shouldn't be defaulting to using accented characters. There are a few things you should check to see what's causing the problem.

  1. Check to make sure that the layout is still the one you selected. Another layout may have accidentally have become selected.

  2. Open the Windows on-screen keyboard and see what it shows. To do this, go to Start → All Programs → Accessories → Ease of Access → On-screen Keyboard. Once it is open, check to see if either of the alt keys are lit up - there may be something forcing alt or alt gr to be "on" for some reason (either some weird software issue or some problem with your keyboard). If this is the case, try connecting a different keyboard to see whether the issue is software of hardware related.

If everything looks OK in both of those places, it may be a more complicated issue.

August 3, 2013

https://www.duolingo.com/Gnorian

I'm using something called, "Windows Language Bar". I found a reasonable fix, where I can just swap to plain English when I want to type sentences.

I checked the windows on-screen keyboard, and it doesn't seem to have alt-depressed. Instead, pressing alt allows access to the accented marks without characters and other symbols, such as: ´ ¨ ¶ etc..

August 4, 2013
Learn a language in just 5 minutes a day. For free.