https://www.duolingo.com/profile/DiffieHell

I can use Duolingo app with 3G, but not with Wifi.

When I turn off mobile data (3G), but am still on Wifi on my android, the Duolingo app seems to think I am offline. (However, I know I am not offline because my browser still connects to the internet). With 3G on, the app works fine.

This started to happen to me today; last week, I could do Duolingo on Wifi just fine.

Any idea what could be happening?

February 11, 2015

14 Comments

Sorted by top post

https://www.duolingo.com/profile/dewey.vf

I have a very similar issue. I have to turn off wifi to use duolingo (as it defaults to use wifi when available instead of cellular data). I don't need to do this with any other app and duolingo did not have this issue before. This started a moth or more ago.

Is Duolingo doing something strange on the network that my firewall might block?

November 29, 2016

https://www.duolingo.com/profile/VirusKA

Did you try restarting?

February 11, 2015

https://www.duolingo.com/profile/DiffieHell

Yes, both the app and the phone. It didn't help.

February 11, 2015

https://www.duolingo.com/profile/alsfurlan

I have the same issue

November 21, 2016

https://www.duolingo.com/profile/22catcher

2018 january same problem.

January 13, 2018

https://www.duolingo.com/profile/5marika5

July 2018 - the same issue started yesterday

July 14, 2018

https://www.duolingo.com/profile/AttalosOfMacedon

October 2018 - same issue since today. Disabling wifi solves the problem. My wifi works fine otherwise.

October 7, 2018

https://www.duolingo.com/profile/GouthamiJa

Found a solution????

October 23, 2018

https://www.duolingo.com/profile/hebell

December 2018 I have this problem now too. Only works on my phone, over the cellular network. No longer works when connected to the internet via my home routerbut everything on my phone otherwise does

December 21, 2018

https://www.duolingo.com/profile/hebell

DECEMBER 30th 2018 - Whew! - Finally fixed it. My home network is Comcast XFinity which does not support IP6. However, my Zoom router does support IPv6. Duolingo seems to fail in this situation (even though nothing else does). So, I went into my router, and disabled IPv6. Now, everything works and my home network seems unaffected. With the Zoom router, there was not a simply IPv6 on/off selection. Instead, I had to go into DHCP6 and uncheck the "enable" button on DHCP6 "prefix delegation". Thanks to others who mentioned IPv6 on other forums or posts. It is now consistently working.

December 31, 2018

https://www.duolingo.com/profile/duckmaestro

Same problem here too.

December 23, 2018

https://www.duolingo.com/profile/hebell

December 23 UPDATE: OK - it hung forever and ever, and finally started the lesson (over wi-fi). Then, it hung forever and ever on the first question. I waited it. Out . It finally worked! Now it seems to be working. So, it must be on Duo's end, I'd think.

December 23 2018 - I de-install the app, even though I heard this has made no difference to others. I reinstall it. I get a BRAND NEW version of Duolingo. (No more hearts). It looks different. But it STILL WILL NOT connect to the network. (This is a correction to my previous post)

December 23, 2018

https://www.duolingo.com/profile/VwV37t

2019 june same problem.

June 26, 2019

https://www.duolingo.com/profile/hebell

Hi VwV - I hope you saw my post above. I was frustrated for weeks, but the problem was fixed when I changed a setting in my router. Search "IPv6" on this page. Good luck. I did a lot of homework on this.

June 26, 2019
Learn a language in just 5 minutes a day. For free.