1. Forum
  2. >
  3. Topic: Troubleshooting
  4. >
  5. Inability to open sentence di…


Inability to open sentence discussions

From time to time there is a sentence that I have questions about and when I click to view the discussions about that sentence, nothing happens.

Today there was one I was really interested in, so I went to the discussion forum for that language, did a search, and clicked on the sentence discussion and... nothing! I could open other sentences that were listed in my search results, but not that one.

I tried right-clicking and "open in new tab" and I got a screen with the Duo menu and the mountains at the bottom, but no content.

I tried opening a different browser and pasting the URL into that browser. Another Duo menu, hills, and no content.

https://www.duolingo.com/comment/2043622 - are you guys able to open this? If not, maybe we could post some other comments that are "un-openable" and get tech support to take a look at them and try to determine what they might have in common.

February 21, 2015



Same for me, I can't open it. I can't open any other ones too.


Hi, thanks for letting us know. We'll look into this!


For what it's worth, pamec, there are quite a few of these discussions that don't open. I run across them often enough in the lessons for it to be "a thing" and I've seen others mention it in the forums. This is just the first time I've cared enough about one to search for it outside the lessons, try opening in another tab, another browser, etc.

I had actually thought that the java or flash or whatever was glitchy. I've only just realized there's probably something about the discussion itself that's causing a hangup.

These discussions might shed some light on what's happening, maybe not. As you can see, it happens enough to be mentioned, but I don't think anyone's realized until recently that it might be specific discussions that don't open, instead of a random thing:

https://www.duolingo.com/comment/6106087 - suggests it's specific sentence discussions that won't open; names the lesson but not the sentences


pamec, here's another one that didn't open for me.

Searching for it in the sentence forum and then right-click, open in new tab yielded an empty page.


That doesn't open for me either. Another one someone had posted sometime back.


Thanks, remoonline. I missed that when it was posted. I'll just add mine to it. Doesn't make sense to have two threads going.


This is still unresolved and seems to be quite common. When the discussion on one sentence of an exercise won't open, the button stops working for the rest of the exercise, even when the other discussions do exist.

Here's another one that doesn't exist: https://www.duolingo.com/comment/4456267 ("Die Ware" from German for English Speakers, Business 1)


I've been getting this on and off for a couple weeks now... sometimes the discussion opens, sometimes it doesn't, I haven't noticed any kind of pattern. I'm using Chrome on Linux.


For this issue, using Google Chrome I managed to fix it by specifically authorizing Duolingo's pop-ups. In Chrome, access "More" (the 3 vertical dots near the top right), click "Settings". Scroll all the way to the bottom in the settings window and click "Show Advanced Settings". Under "Privacy" click "Content Settings", under "Pop-Ups" select your preference "Allow all sites..."(not recommended) or "Do not allow any site...". After a selection is made, click on "Manage exceptions". A new window appears, write or paste Duolingo's web address (https://www.duolingo.com) and select "Allow" next to it. This should enable you to open the Discussion board for any lesson.


Help!! Discuss sentence won't open 2015/03/02.


It would help if you put the link to the sentence whose discussion won't open. Otherwise the programmers have no idea where to look.


I suppose they could see where I'm up to :https://www.duolingo.com/skill/de/Verbs:-Present-4

although I've encountered this problem from time to time earlier, as it seems others and you have too. But your supposition is possibly right as I just tested an earlier lesson and discussion opened up ok. But this last one that failed today still has the won't open problem.


Hi! just found this discussion. Please see my entry in Troubleshooting where I have just worked out that either the new-look website doesn't work properly in internet explorer or internet explorer is not working properly.

I cannot get into discussions at all in internet explorer, which is my browser of choice on my windows 10 laptop.

Discussions work on firefox, but on IE a completely blank page comes up without even an error notice.

On my android tablet the new DL site works on Chrome but it keeps freezing in all sections of DL that I have tried. I do not know if this is a DL problem, a Chrome problem but other sites seem OK on my tablet in Chrome, or a tablet problem though my tablet seems to work fine in all other respects.

I do hope you can solve the problem or some techy DL person can answer for me. I am not flooded out with help. All except one of the posts on my discussion are from myself as I add new information.

I started off by reporting it as a bug as I hadn't realised it was only in IE and I couldn't get to a forum, and maybe it is a bug. I don't know.


When this happens, you should report it to Duolingo.


The report button only goes to the course team, who can't do anything about technical issues. Creating a thread in "troubleshooting" is the right thing to do.

Anyway, I'm here because this is still happening to me (February 2016). Very frustrating, as it seems to more often than not only happen for the sentences I have questions about.


I have the same issue with "La robo estas blua kaj ❤❤❤❤❤" : https://www.duolingo.com/new-comment?fromLanguage=en&learningLanguage=eo&sentenceId=e9e9a51d8d83f88e77ab7273d65f02eb

Duolingo says there are 90 posts in the discussion, but when opening it, it shows nothing, and the translation is missing too.

What a pity to miss all the jokes that must be there!



There is a new issue on the web portal with multiple browsers with the visible Discuss button but when you click on it, it auto-closes the tab shortly after failing to load the thread_id.

Actually this is a cookie issue where Duolingo did not inform its userbase that something fundamental was changed on the web this and last year and user action needs to be taken.

"Solved: "Discuss" icon not working in Chrome": https://forum.duolingo.com/comment/49470058

It is the solution full or partly at least.

See my posted comment and bug report response code.

Please make this linked thread STICKY and create a new support Faq that duolingo.com browser cookies need to be cleared.

Learn a language in just 5 minutes a day. For free.