1. Forum
  2. >
  3. Topic: Troubleshooting
  4. >
  5. BUG: discuss sentence button …

https://www.duolingo.com/profile/JoeOcher

BUG: discuss sentence button not working

The "discuss sentence" button that appears on the web is not working for me. It's not greyed out or anything and it gets highlighted when I hover over it. but I can't click it.

I've tried this for multiple sentences, others have clearly discussed the sentences I'm trying to click on as it shows a number e.g. "discuss sentence (7)". I'm using the website and chrome.

May 19, 2015

9 Comments


https://www.duolingo.com/profile/writchie4

This bug has been around for a long time. Here's a thread from a few months ago: https://www.duolingo.com/comment/6224415

It'd definitely be nice if it were fixed this time. It's annoying to not be able to see the discussion when you know it exists.


https://www.duolingo.com/profile/vivisaurus

Did you check if that particular discussion was "locked"? If you can take a screenshot or share links I can try to replicate it and pass it on to the team. I'm moving this conversation to "troubleshooting" as our developers keep an eye there for possible bugs. Thank you! :)


https://www.duolingo.com/profile/JoeOcher

Okay here's a screenshot from just now http://imgur.com/c2P0x8q and here's a link to the discussion page for the sentence (which seems to be unlocked) https://www.duolingo.com/comment/735190

The problem doesn't happen all the time, but regularly enough that it's annoying. The error seems to apply to entire lessons (so if you can't click on one sentence in a lesson you won't be able to click on any sentence discussions in that lesson)


https://www.duolingo.com/profile/jrikhal

For information, this seems to be the same bug as the one described here (and in the linked discussions in there).


https://www.duolingo.com/profile/writchie4

Hey vivi, not sure if the team is still looking for examples of this bug, but I just saw it again today with the sentence "O café tem pouco açúcar." in the first lesson of the Adverbs skill in the Spanish-to-Portuguese tree. The "Discuss sentence" button showed that there were 4 comments, but the discussion pop-up wouldn't appear.

If you all need more sentences/information to help track down the bug, please let me know. I'm happy to help.


https://www.duolingo.com/profile/JoeOcher

Hi, this bug is still present. Tell me if you need more screenshots/examples. Hope you find a fix :)


https://www.duolingo.com/profile/Kier427541

I use the app on an iPad (mini, 4th gen) and a paid subscription so I would think an ad blocker would make no difference. I can click “discuss” (sometimes; sometimes there is no button, just “report”) and it will let me see comments, but I have never been able to leave a comment of my own, and it seems unlikely that every single discussion I’ve gone to is locked, more probably there’s some bug.


https://www.duolingo.com/profile/Ballygawley

Same issue for me on and off. Using Firefox. It is something to do with my computer. Rebooting the laptop has always fixed this. It is strange, that there is no problem with "report" or "continue" buttons though :-)


https://www.duolingo.com/profile/Thomas.Heiss

@staff

There is a new issue on the web portal with multiple browsers (Pc, Android) with the visible button but when you click on it, it auto-closes the tab shortly after failing to load the thread_id.

Actually this is a cookie issue where Duolingo did not inform its userbase that something fundamental was changed on the web this and last year and user action needs to be taken.

"Solved: "Discuss" icon not working in Chrome": https://forum.duolingo.com/comment/49470058

It is the solution full or partly at least.

See my posted comment and bug report response code.

Please make this linked thread STICKY and create a new support Faq that duolingo.com browser cookies need to be cleared.

Learn a language in just 5 minutes a day. For free.