Duolingo is the most popular way to learn languages in the world. Best of all, it's 100% free!

https://www.duolingo.com/LorenzoCabrini

Debian, ibus and Ukrainian input method.

I've already got a host of input methods enabled in ibus. Time to add a new one, so I search for Ukrainian. Now input methods can be a funny thing. Matching 'ucraina' are 8 different input methods. Not sure which one to choose, and all the freedom of choice is increasing my heart rate so I go for the simplest option: after all Gnome prides itself on dumbing the system down for us, right?

OK, I guess it works, but... Apart from the fact that I'm getting used to the keyboard layout gradually, there are some things that don't seem to work, most importantly space.

The question is: can anybody tell me which Ukrainian keyboard I should use? Or, if I am using the "correct" IM, how the $#%^ do you type a space?

Please avoid telling me about this great browser plugin that you are using. Not interested. My desktop environment already offers IM, which all in all I'm fairly happy with and I don't need another layer. Just need it to work as expected. (Which maybe it is, but then I'm curious as to why the longest key on the keyboard appears dead)

3 years ago

6 Comments


https://www.duolingo.com/Norrius
Norrius
  • 20
  • 11
  • 7
  • 7
  • 6
  • 6

So if you are running Debian with Gnome, doesn't Settings -> Keyboard -> Keyboard Layouts work for you?

3 years ago

https://www.duolingo.com/somelauw
somelauw
  • 17
  • 13
  • 10
  • 10
  • 10
  • 10
  • 6
  • 5
  • 5
  • 5
  • 4
  • 3
  • 2
  • 16

Tell us which of the 8 layouts you are trying to use and how you tried to set it up, so we can try to reproduce your problem.

3 years ago

https://www.duolingo.com/LorenzoCabrini

Sure, the one called just Ukraine (well, Ucraina on my system). I just added it, use Meta+Space to switch between layouts.

3 years ago

https://www.duolingo.com/HappyEvilSlosh
HappyEvilSlosh
  • 25
  • 25
  • 23
  • 22
  • 21
  • 13
  • 13
  • 11
  • 11
  • 11
  • 10
  • 10
  • 9
  • 7
  • 4
  • 3
  • 2
  • 2
  • 2
  • 13

In my version of IBus I only see one option for Ukrainian. I use i3 rather than Gnome so I'm not sure exactly what you're seeing on the change keyboard window but I believe IBus and whatever 'Change Keyboard Layout' corresponds to (probably some variation of setxkbmap) are different systems...

3 years ago

https://www.duolingo.com/LorenzoCabrini

Ibus is supposed to be the grand unification of layout/input method systems. As you can imagine, grand undertakings often cause trouble. And the underlying desktop should not matter. I've used ibus on KDE and XFCE as well. But then again, I've seen weird things before.

I have to Ukrainian layout in the selector list all right. And I can switch to it. It works. I suck at finding the letters, but that is a different story. What does not work, is my space key, but only when using Ukrainian (by now I've gone through all the variants, and space not working appears a consistent behavior)

3 years ago

https://www.duolingo.com/HappyEvilSlosh
HappyEvilSlosh
  • 25
  • 25
  • 23
  • 22
  • 21
  • 13
  • 13
  • 11
  • 11
  • 11
  • 10
  • 10
  • 9
  • 7
  • 4
  • 3
  • 2
  • 2
  • 2
  • 13

If it's of any use to you if I use setxkbmap ua (I have versions of this command set to hotkeys to to select most of my layouts—I only use IBus to get Japanese input) I get Ukrainian and space still works, if I add it on IBus space still works but it also doesn't seem to actually remap my keyboard to Ukrainian letters so I'm not quite sure what incantation is required to make it work. :P I only had a single Ukrainian option for IBus.

3 years ago