1. Forum
  2. >
  3. Topic: Troubleshooting
  4. >
  5. Language switching in the mid…


Language switching in the middle of a lesson

Hello! I was doing my French practice today and after nine questions the exercises suddenly switched to German.The flag on the top bar was still French. The progress after finishing the lesson was assigned to German, even though half of it was in French. This has happened to me before with Italian and French as well.

June 7, 2015



Sure nobody were connecte to your account from another platform (phone apps, tablet, another computer where you could have let your Duo session opened, etc...)?


Nope, no chance.


Were you using the web app or a mobile? I had this happen once about 2 weeks ago in the iOS app: my German lesson suddenly started giving me sentences in Irish. It hasn't recurred for me and I couldn't figure out how to reproduce it, so I didn't report it.


It was on the web app. Never happened to me on the Android mobile app, but I hardly use it at all anyway.


I have a slightly different problem. I was experimenting and suddenly ended up with the Rssian version. How do I get rid of it? As I cannot speak Russian I do not know how to get back to the English.


Presuming you mean your website interface is in Russian? Have you tried going to e.g. duolingo.com/course/eo/en and clicking the button? That should take you back to the Esperanto from English course. (And I think the app syncs with the website to some extent; at least on my android it's told me off for using it while I had the website on EN->UK, since that's not on the app yet.)

Personally I just had the website switch me to German without my trying to directly after a Spanish exercise. Which was also 24 exercises long even though I didn't miss anything--seems a bit odd.


Thanks for your response. No, that's not the problem. I was "experimenting" with the different language interface buttons in between lessons and thought I had found a Russian via English course. I ended up with a complete Russian interface and cannot fathom out how to get back to the English one. In other words it is a case of "curiosity killed the cat".


Are you using the android app by any chance? I don't have a windows phone and my only Apple device is an old nano with no online capabilities, so I don't know how those work. (I'm just trying to be helpful; I am not involved in Duolingo tech support or anything like that.)

But, I went and looked at my app-it may be similar regardless.

There's a menu in the top left corner beside Английский. Open it and the bottom option Добавить курс should take you to the course selection screen--scroll down until you see some English words and select your course.

(Английский would be the Russian word for "English", something like angliski transliterated. And I'd bet курс is cognate with "course", as it would be pronounced similarly. I don't really know much of any Russian (yet.) but I have been learning the Cyrillic alphabet in anticipation. And some Ukrainian, which I was not entirety planning on. :) )


Thanks for taking the time to try and help me. I tried to follow your directions using my pc, however it seems the problem is more complicated than that. Although I changed the language preference to English it did not help. I have tried working it out with Google Translate. Incidentally I am doing the Esperanto beta course, which is not included in the duolingo app yet.


Maybe try clearing your cookies for the site and other browser stuff like that before switching to the Esperanto course again? I'm sorry, I thought maybe you weren't on the website (which is probably a bit silly of me; I don't think the forums are accessible in-app).

I do seem to remember that simply selecting "I speak [language]" probably doesn't change the interface? And if it's in settings, there is a save button required to commit to a number of changes.

Learn a language in just 5 minutes a day. For free.