https://www.duolingo.com/largesock

Can't complete any activities with Chrome

I recently decided to get back into duolingo but can't get things to work. I can pop up a new practice or test and answer several questions, but inevitably the "Check" button grays out and I stop getting new questions. I can click Quit and get a pop-up button to navigate to other parts of the website. But I never get a message saying I've passed or earned any points because the activity can never complete.

When I get into this state, Chrome's debug panel (CTRL+SHIFT+J) shows this error: ReferenceError: WebSpeechSpeakElementView is not defined at e.exports.a.extend.initialize (https://d7mj4aqfscim2.cloudfront.net/proxy/js2/d789a56888be55261b23-duolingo.js:17:21648) at t.View (https://d7mj4aqfscim2.cloudfront.net/proxy/js2/d789a56888be55261b23-vendor.js:5:28629) at n (https://d7mj4aqfscim2.cloudfront.net/proxy/js2/d789a56888be55261b23-vendor.js:5:31102) at n (https://d7mj4aqfscim2.cloudfront.net/proxy/js2/d789a56888be55261b23-vendor.js:5:31102) at n (https://d7mj4aqfscim2.cloudfront.net/proxy/js2/d789a56888be55261b23-vendor.js:5:31102) at new n (https://d7mj4aqfscim2.cloudfront.net/proxy/js2/d789a56888be55261b23-vendor.js:5:31102) at e.exports.a.View.extend.createElementView (https://d7mj4aqfscim2.cloudfront.net/proxy/js2/d789a56888be55261b23-duolingo.js:3:3487) at e.exports.a.View.extend.renderElementView (https://d7mj4aqfscim2.cloudfront.net/proxy/js2/d789a56888be55261b23-duolingo.js:3:3564) at e.exports.r.extend.renderElementView (https://d7mj4aqfscim2.cloudfront.net/proxy/js2/d789a56888be55261b23-duolingo.js:7:6666) at e.exports.a.View.extend.render (https://d7mj4aqfscim2.cloudfront.net/proxy/js2/d789a56888be55261b23-duolingo.js:3:4619)

I'm using Chrome Version 43.0.2357.130 m on Win 7 64-bit. I have no connectivity problems with any other websites. I've tried this after disabling every extension I had enabled, and still get the same behavior. Thanks for any tips.

June 30, 2015

4 Comments


https://www.duolingo.com/hector

This should be fixed now. Please let us know if it keeps happening to you.

June 30, 2015

https://www.duolingo.com/pconaway

same problem - first time it happened was today.

June 30, 2015

https://www.duolingo.com/SparkIT

I use Firefox and I can't even start a new lesson. It works when I'm choosing the skill but then when the lesson should start it seems it can't be loaded.

July 1, 2015

https://www.duolingo.com/SparkIT

Oops... not sure why, but I was blocking ajax.googleapis.com with noscript and now it works :P

July 1, 2015
Learn a language in just 5 minutes a day. For free.